[Testing Update] 2018-05-31 - Kernels, Pacman, Deepin

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • We worked on our themes
  • Deepin got another set of updates
  • Pacman 5.1 issues got fixed
  • Some of our Kernels got another update
  • Usual upstream rebuilds

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.112 [EOL]
  • linux41 4.1.51
  • linux44 4.4.135
  • linux49 4.9.105
  • linux414 4.14.47
  • linux415 4.15.18 [EOL]
  • linux416 4.16.13
  • linux417 4.17-rc7
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5

Package Updates (Thu May 31 09:05:25 CEST 2018)

  • testing multilib x86_64: 20 new and 21 removed package(s)
  • testing extra x86_64: 122 new and 122 removed package(s)
  • testing community x86_64: 177 new and 181 removed package(s)

Overlay Updates

  • testing core x86_64: 11 new and 11 removed package(s)
  • testing extra x86_64: 89 new and 90 removed package(s)
  • testing community x86_64: 0 new and 1 removed package(s)

The full package list can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

wiki post


#3

The update succeeded with 2 warnings.

warning: could not get file information for usr/share/fonts/encodings/encodings.dir
warning: could not get file information for usr/share/fonts/encodings/large/encodings.dir

#4

good update here: linux146+nvidia+zfs+gnome


#5

On my Arch machine the update of librsvg to 2.42.4 breaks cairo-dock. Bug report: https://bugs.launchpad.net/cairo-dock-core/+bug/1770884 Also reported the bug upstream a few days ago, but no reply yet… Reported at Arch as well: https://bugs.archlinux.org/task/58803


#6

The systemd-kcm just became an AUR package ?!?!


#7

All good on KDE. Only one strange thing - but I am really not sure it is related to the update - I discovered I have an orphan package called systemd-kcm, which wanted to be updated… but from the AUR. As I don’t remember having installed it, I have deleted it. The visible change I see is that I don’t have the module “systemd” anymore in the System Settings gui, but I can live with it.
Just curious to understand if this package was until this update in anyway part of an official repository or…if I have just installed it from the AUR and don t remember it. (Could be when you are a “young 60+” :innocent: )
Edit: Well… just see now the previous comment from @bogdancovaciu … so I believe I have the answer.


#8

On xfce as well as on KDE plasma i also got the mentioned warnings as mentioned by ben81. Also the systemd-kcm thing on KDE. So i uninstalled sytemd-kcm and installed systemdgenie which is a seperate application.


#9

It seems it fails to build (even tho it was in official repos previously) because of Qt 5.11 dropping qt5_use_modules
Same was with Phonon last month.
https://phabricator.kde.org/D12180


#10

So was systemd-kcm dropped by Arch to AUR?

Is it still required?

Hasn’t been rebuilt since Dec 2015, I’m guessing it wouldn’t build against Qt 5.11 so it was dropped.

Name            : systemd-kcm
Version         : 1.2.1-2
Description     : Systemd control module for KDE
Architecture    : x86_64
...
Build Date      : Tue 08 Dec 2015 22:32:59 AEDT
...

#11

can help this doku Porting guide from Qt 1.0 to 5.11


#12

Besides this pacman 5.1.0 related bug breaking MSM language tool manager, all is ok.


#13

Update went without any issues, but I still encountering this: [Testing Update] 2018-05-30 - Deepin, Kernels, Pacman 5.1, Pamac, Firefox, QT 5.11
Octopi acts weird.


#14

Maybe Octopi is not 100% compatible with Pacman 5.1.0?!


#15

Please do a git-bisect on librsvg. Only 153 commits (some are doubled listed due to merges) were done. You can check how I did it for linux41 and do it similar with that package. In the past we had similar issues


#16

I’ve just pulled another set of upstream updates. Also we found some time to fix reported issues.


#17

There is a very nice package developed by a girl called ‘aurman’ and it iscompatible with Pacman5.1 Aurman requires it, actually…


#18

This “girl” ?


#19

Deepin-Terminal work now with right mouse klick and paste / menu - settings etc… Thx.

Info. Only warning, ups like @ben81 https://forum.manjaro.org/t/testing-update-2018-05-31-kernels-pacman-deepin/48555/3?u=sgs

Warnung: konnte Dateiinformationen für usr/share/fonts/encodings/encodings.dir nicht ermitteln
Warnung: konnte Dateiinformationen für usr/share/fonts/encodings/large/encodings.dir nicht ermitteln
Zusammenfassung
64
adobe-dingbats ./adobe-dingbats.enc.gz
adobe-standard ./adobe-standard.enc.gz
adobe-symbol ./adobe-symbol.enc.gz
armscii-8 ./armscii-8.enc.gz
ascii-0 ./ascii-0.enc.gz
big5-0 large/big5.eten-0.enc.gz
big5.cp950-0 large/big5.eten-0.enc.gz
big5.eten-0 large/big5.eten-0.enc.gz
big5hkscs-0 large/big5hkscs-0.enc.gz
cns11643-1 large/cns11643-1.enc.gz
cns11643-1 large/cns11643-1.enc.gz
cns11643-2 large/cns11643-2.enc.gz
cns11643-2 large/cns11643-2.enc.gz
cns11643-3 large/cns11643-3.enc.gz
cns11643-3 large/cns11643-3.enc.gz
dec-special ./dec-special.enc.gz
gb18030-0 large/gb18030-0.enc.gz
gb18030.2000-0 large/gb18030.2000-0.enc.gz
gb18030.2000-1 large/gb18030.2000-1.enc.gz
gb2312.1980-0 large/gb2312.1980-0.enc.gz
gbk-0 large/gbk-0.enc.gz
ibm-cp437 ./ibm-cp437.enc.gz
ibm-cp850 ./ibm-cp850.enc.gz
ibm-cp852 ./ibm-cp852.enc.gz
ibm-cp866 ./ibm-cp866.enc.gz
iso8859-11 ./iso8859-11.enc.gz
iso8859-13 ./iso8859-13.enc.gz
iso8859-16 ./iso8859-16.enc.gz
iso8859-6.16 ./iso8859-6.16.enc.gz
iso8859-6.8x ./iso8859-6.8x.enc.gz
jisx0201.1976-0 large/jisx0201.1976-0.enc.gz
jisx0208.1983-0 large/jisx0208.1990-0.enc.gz
jisx0208.1990-0 large/jisx0208.1990-0.enc.gz
jisx0212.1990-0 large/jisx0212.1990-0.enc.gz
ksc5601.1987-0 large/ksc5601.1987-0.enc.gz
ksc5601.1992-3 large/ksc5601.1992-3.enc.gz
ksx1001.1997-0 large/ksc5601.1987-0.enc.gz
ksx1001.1998-0 large/ksc5601.1987-0.enc.gz
ksx1001.1998-3 large/ksc5601.1992-3.enc.gz
ksxjohab-1 large/ksc5601.1992-3.enc.gz
microsoft-ansi ./microsoft-cp1252.enc.gz
microsoft-cp1250 ./microsoft-cp1250.enc.gz
microsoft-cp1251 ./microsoft-cp1251.enc.gz
microsoft-cp1252 ./microsoft-cp1252.enc.gz
microsoft-cp1253 ./microsoft-cp1253.enc.gz
microsoft-cp1254 ./microsoft-cp1254.enc.gz
microsoft-cp1255 ./microsoft-cp1255.enc.gz
microsoft-cp1256 ./microsoft-cp1256.enc.gz
microsoft-cp1257 ./microsoft-cp1257.enc.gz
microsoft-cp1258 ./microsoft-cp1258.enc.gz
microsoft-win3.1 ./microsoft-win3.1.enc.gz
mulearabic-0 ./mulearabic-0.enc.gz
mulearabic-1 ./mulearabic-1.enc.gz
mulearabic-2 ./mulearabic-2.enc.gz
mulelao-1 ./mulelao-1.enc.gz
sun.unicode.india-0 large/sun.unicode.india-0.enc.gz
suneu-greek ./suneu-greek.enc.gz
tcvn-0 ./tcvn-0.enc.gz
tis620-0 ./iso8859-11.enc.gz
tis620-2 ./tis620-2.enc.gz
tis620.2529-1 ./iso8859-11.enc.gz
tis620.2533-0 ./iso8859-11.enc.gz
tis620.2533-1 ./iso8859-11.enc.gz
viscii1.1-1 ./viscii1.1-1.enc.gz
26
big5-0 ./big5.eten-0.enc.gz
big5.cp950-0 ./big5.eten-0.enc.gz
big5.eten-0 ./big5.eten-0.enc.gz
big5hkscs-0 ./big5hkscs-0.enc.gz
cns11643-1 ./cns11643-1.enc.gz
cns11643-1 ./cns11643-1.enc.gz
cns11643-2 ./cns11643-2.enc.gz
cns11643-2 ./cns11643-2.enc.gz
cns11643-3 ./cns11643-3.enc.gz
cns11643-3 ./cns11643-3.enc.gz
gb18030-0 ./gb18030-0.enc.gz
gb18030.2000-0 ./gb18030.2000-0.enc.gz
gb18030.2000-1 ./gb18030.2000-1.enc.gz
gb2312.1980-0 ./gb2312.1980-0.enc.gz
gbk-0 ./gbk-0.enc.gz
jisx0201.1976-0 ./jisx0201.1976-0.enc.gz
jisx0208.1983-0 ./jisx0208.1990-0.enc.gz
jisx0208.1990-0 ./jisx0208.1990-0.enc.gz
jisx0212.1990-0 ./jisx0212.1990-0.enc.gz
ksc5601.1987-0 ./ksc5601.1987-0.enc.gz
ksc5601.1992-3 ./ksc5601.1992-3.enc.gz
ksx1001.1997-0 ./ksc5601.1987-0.enc.gz
ksx1001.1998-0 ./ksc5601.1987-0.enc.gz
ksx1001.1998-3 ./ksc5601.1992-3.enc.gz
ksxjohab-1 ./ksc5601.1992-3.enc.gz
sun.unicode.india-0 ./sun.unicode.india-0.enc.gz


#20

I got the same 2 warning as reported from a few users before. But update went well anyway.