[Testing Update] 2018-03-17 - Systemd, Firefox, Deepin

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. This is more a fixup to our last update. We mostly worked on Systemd, Deepin and additionally we added regular upstream updates as usual.

Here is the list of changes in more details:

  • We worked on Systemd
  • We added the latest Deepin packages
  • We added the latest Firefox developer edition

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.55
  • linux318 3.18.99 [EOL]
  • linux41 4.1.50
  • linux44 4.4.121
  • linux49 4.9.87
  • linux414 4.14.27
  • linux415 4.15.10
  • linux416 4.16-rc5
  • linux-RT-LTS 4.14.24_rt19
  • linux-RT 4.14.24_rt19

Package Updates (Sat Mar 17 12:03:04 CET 2018)

  • testing community x86_64: 163 new and 159 removed package(s)
  • testing core x86_64: 5 new and 5 removed package(s)
  • testing extra x86_64: 3 new and 3 removed package(s)
  • testing multilib x86_64: 16 new and 16 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro              3.2.7-1              3.2.8-1
                   deepin-session-ui              4.3.0-1              4.3.1-1
                       dmenu-manjaro                4.7-2                4.8-1
                        i3lock-color             2.10.1-4                    -
                        i3lock-fancy       r146.a12ce23-1                    -
                          lemonpanel  0.33.r196.6944990-1  0.34.r197.babff1c-1
      manjaro-bspwm-settings-minimal           20180315-2           20180316-1
                            rootmenu               0.10-1               0.11-1
                           timeshift            v18.1.1-1              v18.2-1
                   yakuake-skin-maia           20180315-1           20180316-1
              manjaro-openbox-common                    -                1.0-2
               manjaro-openbox-fonts                    -                1.1-1
            manjaro-openbox-settings                    -           20180316-5
                          obkey-gtk3                    -    1.0.47.gcf99076-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                             ansible            2.4.3.0-2            2.4.3.0-3
                             clojure              1.9.0-5              1.9.0-6
                             couchdb              2.1.1-2              2.1.1-3
                        deepin-clone            0.0.8.2-1            0.0.8.3-1
               deepin-control-center              4.4.0-1              4.4.1-1
              deepin-desktop-schemas              3.2.7-1              3.2.8-1
                     deepin-launcher              4.3.1-1              4.3.2-1
                       deepin-mutter            3.20.27-1            3.20.28-1
                   deepin-session-ui              4.3.0-1              4.3.1-1
                           deepin-wm             1.9.22-1             1.9.23-1
                              erlang               20.2-1               20.3-1
                         erlang-docs               20.2-1               20.3-1
                          erlang-nox               20.2-1               20.3-1
                     erlang-unixodbc               20.2-1               20.3-1
                              eslint             4.18.2-1             4.19.0-1
           firefox-developer-edition             60.0b3-1             60.0b4-1
  firefox-developer-edition-i18n-ach             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-af             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-an             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ar             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-as             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-ast             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-az             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-be             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-bg             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-bn-bd             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-bn-in             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-br             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-bs             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ca             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-cak             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-cs             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-cy             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-da             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-de             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-dsb             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-el             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-en-gb             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-en-us             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-en-za             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-eo             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-es-ar             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-es-cl             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-es-es             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-es-mx             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-et             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-eu             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-fa             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ff             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-fi             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-fr             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-fy-nl             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-ga-ie             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-gd             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-gl             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-gn             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-gu-in             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-he             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-hi-in             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-hr             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-hsb             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-hu             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-hy-am             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ia             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-id             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-is             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-it             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ja             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ka             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-kab             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-kk             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-km             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-kn             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ko             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-lij             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-lt             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-lv             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-mai             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-mk             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ml             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-mr             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ms             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-my             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-nb-no             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-ne-np             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-nl             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-nn-no             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-or             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-pa-in             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-pl             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-pt-br             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-pt-pt             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-rm             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ro             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ru             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-si             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-sk             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-sl             60.0b2-1             60.0b4-1
  firefox-developer-edition-i18n-son             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-sq             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-sr             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-sv-se             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ta             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-te             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-th             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-tr             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-uk             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-ur             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-uz             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-vi             60.0b2-1             60.0b4-1
   firefox-developer-edition-i18n-xh             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-zh-cn             60.0b2-1             60.0b4-1
firefox-developer-edition-i18n-zh-tw             60.0b2-1             60.0b4-1
                             fractal             0.1.16-1             0.1.18-1
                             freerdp        1:2.0.0_rc1-1        1:2.0.0_rc1-2
                           git-annex        6.20180227-41         6.20180316-1
                   haskell-setlocale            1.0.0.5-4            1.0.0.6-1
                              hatari              2.0.0-1              2.1.0-1
                              kcptun           20180305-1           20180316-1
                        lastpass-cli              1.2.2-1              1.3.0-1
                                 lv2             1.14.0-2             1.14.0-3
                                 nbd             3.16.2-2               3.17-1
                                ogre            1.10.11-3            1.10.11-4
                           ogre-docs            1.10.11-3            1.10.11-4
                           oniguruma              6.7.1-1              6.8.0-1
                            paintown              3.6.0-3                    -
                     percona-toolkit              3.0.7-1              3.0.8-1
                              pifpaf              2.1.0-1              2.1.1-1
                          processing              3.3.6-1              3.3.7-1
                      python-ansible            2.4.3.0-2            2.4.3.0-3
                 python-cinderclient              3.2.0-1              3.5.0-1
               python-flask-talisman              0.4.1-1              0.5.0-1
                 python-openstacksdk             0.12.0-1             0.12.0-2
                      python-pytools             2018.2-1             2018.3-1
                     python-selenium              3.9.0-1             3.10.0-1
                         python-tqdm             4.19.7-1             4.19.8-1
                python2-cinderclient              3.2.0-1              3.5.0-1
              python2-flask-talisman              0.4.1-1              0.5.0-1
                python2-openstacksdk             0.12.0-1             0.12.0-2
                      python2-pifpaf              2.1.0-1              2.1.1-1
                     python2-pytools             2018.2-1             2018.3-1
                    python2-selenium              3.9.0-1             3.10.0-1
                        python2-tqdm             4.19.7-1             4.19.8-1
                    telegram-desktop             1.2.12-1             1.2.12-2
                           terraform             0.11.3-1             0.11.4-1
                               v2ray               3.13-1               3.14-1
          vapoursynth-plugin-deblock                  4-2                  6-1
                              xmonad              0.13-12              0.13-13
                      xmonad-contrib              0.13-10              0.13-11
                               zcash             1.0.14-2             1.0.15-1
                               gdnsd                    -              2.4.0-1
                      perl-moox-late                    -              0.015-6
                         qpid-proton                    -             0.21.0-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                          libsystemd              238.0-4              238.0-6
                      linux-firmware   20180119.2a713be-2   20180314.4c0bf11-1
                             systemd              238.0-4              238.0-6
                  systemd-sysvcompat              238.0-4              238.0-6


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                            binutils             2.29.1-2             2.29.1-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                         intel-ucode           20180108-1           20180312-1
                           konqueror            17.12.3-1            17.12.3-2
                           libvorbis              1.3.5-1              1.3.6-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                       lib32-systemd              238.0-4              238.0-6


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-16           2018-03-17
-------------------------------------------------------------------------------
                          lib32-dbus             1.12.4-1             1.12.6-1
                         lib32-libnm             1.10.2-1             1.10.6-1
                    lib32-libnm-glib             1.10.2-1             1.10.6-1
                     lib32-libsodium             1.0.15-1             1.0.16-1
                       lib32-libteam               1.26-1               1.27-1
                       lib32-libthai             0.1.26-1             0.1.27-1
                  lib32-libxkbcommon              0.7.2-1              0.8.0-1
              lib32-libxkbcommon-x11              0.7.2-1              0.8.0-1
                       lib32-libxml2 2.9.4+16+g07418011-2              2.9.8-1
                  lib32-libxshmfence                1.2-1                1.3-1
                    lib32-mesa-demos              8.3.0-3              8.4.0-1
                           lib32-orc             0.4.27-1             0.4.28-1
                        lib32-polkit  0.113+29+g3272a98-1  0.113+34+g29ba7af-1
                        lib32-sqlite             3.21.0-1             3.22.0-1
                        wine-staging                3.3-1                3.4-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

wiki post


#3

@xabbu, @sueridgepipe, @Th3Z0ne: does the current systemd version works now as expected and similar to v237.64 we currently have in stable branch? The cryptsetup issue is another one and was already present in v237 series. Therefore I’m almost happy with this and ready for a new stable snap.


#4

Smooth update on KDE edition with kernels 4.14 and 4.15.


#5

All good: linux415+zfs+nvidia+cinnamon


#6

Yes, I don’t see any error messages on screen during shutdown with systemd 238.0-6. Also systemd doesn’t crash anymore at shutdown or reboot.

The cryptsetup issue is indeed a different topic.


#7

No anomalies detected. Bzzrt: :robot:


#8

I fixed some last issue with grub. Now it supports Multiple early Initrd-Images. Also the 17.1.7-rc5 of XFCE can be again installed on EFI.


#9

It’s all Good, thanks team.

bob@Manjaro-Testing ~$ inxi -Fxz
System:    Host: Manjaro-Testing Kernel: 4.16.0-1-MANJARO x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.4 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: desktop System: LENOVO product: 10181 v: Lenovo K450e serial: N/A
           Mobo: LENOVO model: N/A v: 31900058 STD serial: N/A
           BIOS: LENOVO v: I1KT38AUS date: 06/10/2014
Battery    hidpp__0: charge: 95% condition: NA/NA Wh
           model: Logitech M570 status: Discharging
CPU:       Quad core Intel Core i5-4460 (-MCP-) 
           arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25540
           clock speeds: max: 3400 MHz 1: 2391 MHz 2: 3146 MHz 3: 2018 MHz
           4: 2702 MHz
Graphics:  Card: NVIDIA GK208 [GeForce GT 720] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 720/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.42 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK208 HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.16.0-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168 v: 8.045.08-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: c000 bus-ID: 04:00.0
           IF: wlp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 2000.4GB (1.6% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
           ID-2: USB /dev/sdb model: Elements_25A2 size: 1000.2GB
Partition: ID-1: / size: 454G used: 22G (6%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:47C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 181 Uptime: 1:34 Memory: 634.2/7912.9MB
           Init: systemd Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

#10

No problems KDE with 4.15 kernel


#11

So, I have identified the issue I have since the update of 2018-03-14. It seems that this bug is back: https://bugs.kde.org/show_bug.cgi?id=367541

That is: if your digital clock is showing the events from your PIM TODO list, and you have at least one TODO without a starting date, an infinite loop is triggered and your plasma eats up all the memory in a bunch of seconds, until the kernel kills it.
Workaround: disable the PIM plugin in the digital clock settings and lose this useful functionality.

@philm: do you know whether some commit was “lost” in the update of March 14th? I didn’t have this issue before then. In the KDE bug page (link above) there are comments stating that this fix will not be merged before April 2018, but it seems to me that some kind of fix was indeed merged in the releases before the one of March 14th…

Thanks,

@chain-of-flowers


#12

Smooth update on kde with 4.14


#13

Nothing is lost. The fix got merged only in master and is not yet in 17.12 series of KDE-Apps.

Check if kdepim-addons-17.12.3-1.1 fixes your issue.


#14

On my main computer

A. New issues

Nothing new to report so far

Manjaro Cinnamon
Kernel 4.14 (using kernel-alive)
Did the update with Pamac

Intel i5-6400
Nvidia Geforce GTX 970

==========================
I received Firefox 59.0.1-0 on my main computer, and also on my laptop which use Stable branch of Manjaro. I noticed that this version doesn’t include distribution.ini file, unlike version 59.0-1 and 59.0-2.

Content of firefox 59.0.1-0

It includes the solution used on Arch package to fix the issue Manjaro users (and Arch users too) had with non-English language (translation didn’t work at all), which is a good thing, of course.

vendor.js included in firefox 59.0.1-0

However, since firefox 59.0.1-0 doesn’t include the distribution.ini file, unlike previous version of firefox we got in Testing (59.0-2), distribution.ini isn’t considered to be owned by firefox package according to pacman -Qo command.

[awesome@i56400 ~]$ date
Sat Mar 17 18:53:36 EDT 2018
[awesome@i56400 ~]$ pacman -Q firefox
firefox 59.0.1-0
[awesome@i56400 ~]$ pacman -Q manjaro-system
manjaro-system 20180315-1
[awesome@i56400 ~]$ pacman -Qo /usr/lib/firefox/distribution/distribution.ini
error: No package owns /usr/lib/firefox/distribution/distribution.ini
[awesome@i56400 ~]$

Therefore, if nothing is done and if Manjaro reuse a package of firefox that includes distribution.ini in it, I expect the file conflict issue we got a few days to come back again in next Testing updates release. Therefore, I strongly suggest that Manjaro Team push a new version of manjaro-system in Testing (and Unstable) to prevent the file conflict from happening again. @philm

Also, by doing several updates pushed after Stable 2018-03-14 release, I observed that the currently implemented solution (post-upgrade task of manjaro-system) to prevent the file conflict problem with firefox package from happening is not totally reliable. So far, for me, it worked flawlessly everytime, except… this time. Unfortunately, it failed on my laptop. This is the first time (and the only time so far for now) it failed for me. Here’s what happened.

I got the following updates on my laptop. It uses Stable branch.

Updates received on my laptop

I applied them with Pamac. As you can see in my pacman.log, update for manjaro-system has been applied first, then the rest got updated after. The message sent when the distribution.ini file is deleted as a post-upgrade task (“Fix firefox upgrade …”) has been received, which mean that the distribution.ini file got deleted after applying this update. Of course, because there’s an update of firefox package, post-transaction hook named firefox-post triggers. However, for some unknown reason, the firefox-post post-hook (which replaces the old manjaro-browser-settings-post and does the same task) could do its task successfully, with no error at all.

pacman.log - Laptop - Stable branch

[2018-03-17 15:38] [PAMAC] synchronizing package lists
[2018-03-17 15:38] [ALPM] transaction started
[2018-03-17 15:38] [ALPM] upgraded manjaro-system (20180107-2 -> 20180315-1)
[2018-03-17 15:38] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Fix firefox upgrade …e[1;0m
[2018-03-17 15:38] [ALPM] transaction completed
[2018-03-17 15:38] [ALPM] running ‘systemd-update.hook’…
[2018-03-17 15:39] [ALPM] running ‘manjaro-browser-settings-pre.hook’…
[2018-03-17 15:39] [ALPM] transaction started
[2018-03-17 15:39] [ALPM] upgraded libvorbis (1.3.5-1 -> 1.3.6-1)
[2018-03-17 15:39] [ALPM] upgraded firefox (59.0-0 -> 59.0.1-0)
[2018-03-17 15:39] [ALPM] upgraded manjaro-browser-settings (20180220-1 -> 20180316-2)
[2018-03-17 15:39] [ALPM] transaction completed
[2018-03-17 15:39] [ALPM] running ‘firefox-post.hook’…
[2018-03-17 15:39] [ALPM] running ‘gtk-update-icon-cache.hook’…
[2018-03-17 15:39] [ALPM] running ‘systemd-update.hook’…
[2018-03-17 15:39] [ALPM] running ‘update-desktop-database.hook’…

Therefore, the distribution.ini file is back in /usr/lib/firefox/distribution.

distribution.ini is back - Laptop - Stable branch
[awesome@ideapad ~]$ date
Sat Mar 17 18:26:48 EDT 2018
[awesome@ideapad ~]$ pacman -Q firefox
firefox 59.0.1-0
[awesome@ideapad ~]$ pacman -Q manjaro-browser-settings
manjaro-browser-settings 20180316-2
[awesome@ideapad ~]$ pacman -Qo /usr/lib/firefox/distribution/distribution.ini
error: No package owns /usr/lib/firefox/distribution/distribution.ini
[awesome@ideapad ~]$ ls /usr/lib/firefox/distribution/distribution.ini
/usr/lib/firefox/distribution/distribution.ini
[awesome@ideapad ~]$ ls /usr/lib/firefox/distribution/
distribution.ini
[awesome@ideapad ~]$ ls /usr/lib/firefox/
application.ini     dictionaries  hyphenation       minidump-analyzer
browser             distribution  liblgpllibs.so    omni.ja
chrome.manifest     firefox       libmozavcodec.so  pingsender
crashreporter       firefox-bin   libmozavutil.so   platform.ini
crashreporter.ini   fonts         libmozgtk.so      plugin-container
defaults            gmp-clearkey  libmozsandbox.so  removed-files
dependentlibs.list  gtk2          libxul.so         Throbber-small.gif
[awesome@ideapad ~]$

This is very different from what I observed in my previous experiences with this solution. Previously, after applying manjaro-system completely, the distribution folder, which becomes empty after post-upgrade of this package, also gets deleted (not just distribution.ini file). Deletion of distribution folder is a good thing, because it prevents the firefox-post post-hook from recreating distribution.ini file again until we install a firefox package that includes distribution.ini in it; it prevents the file conflict from happening until the transition is made. The post-hook fails because it cannot copy /etc/manjaro-firefox.ini in a folder that doesn’t exist (even with -f).

firefox-post.hook as it is in current version of manjaro-browser-settings

[Trigger]
Type = Package
Operation = Install
Operation = Upgrade
Target = firefox

[Action]
Description = Copy Firefox Distribution Settings
When = PostTransaction
Exec = /usr/bin/cp -f /etc/manjaro-firefox.ini /usr/lib/firefox/distribution/distribution.ini

But for some unknown reason, the behaviour I got when I updated my laptop is not the same as the behaviour I got in my previous experiences: the distribution folder did not get deleted and thus, the firefox-post post-hook could copy /etc/manjaro-firefox.ini without any problem at all. It might be what happened to MindWanderer, a user that got the file conflict in Testing yesterday, but it’s just a hypothesis.

Therefore, we have to expect for next Stable release that several people get the file conflict (of course, way less than if nothing was done, but still). Deleting distribution folder with rm -rf as a post-upgrade task of manjaro-system could be a more reliable solution than deleting distribution.ini file with rm -f. But at that point, it’s up to Manjaro Team to decide.


#15

This package is a quick-release security fix. It should be overwritten by 59.0.1-1 from the next unstable snap, assuming that happens before a testing->stable snap.

If that isn’t going to happen then 59.0.1-1 can be brought over from unstable.

@philm, which do you prefer here? New snap or cherry-pick?


#16

Perfectly understandable that it got pushed quickly everywhere then. Plus, it fixed the translation problem for Stable branch at the same time. :slight_smile:

However, I wanted to warn about a risk of file conflict problem that will happen in Testing (and Unstable) if firefox package include distribution.ini again with incoming 59.0.1-1, like version 59.0-1 and 59.0-2. :yum:


#17

Last two update solved connection at login. Thank you :slightly_smiling_face:


#18

Hi @philm, yes, the new kdepim-addons package fixes the issue :slight_smile:

Thanks!

@chain-of-flowers


#19

It doesn’t matter, as long as our build also includes the distribution.ini file.


#20

Why is every manjaro-system update is overwriting my sddm config?