Can't update nvidia driver (conflict in configs)

When attempting to update graphics drivers through the Hardware Configuration menu, I get the following error:

Error: config 'video-nvidia-455xx' conflicts with config(s): video-nvidia-430xx

Edit: Re-installing mhwd has fixed the issue with hardware, but I still can't install the latest driver

Done ...

I have attempted to use the method in stable-update-2020-10-19-kernels-nvidia-455-browsers/32850/2 update post, but I cannot locate my linuxZZ-nvidia-440xx package or it’s equivalent (I’m still on 430xx) and just removing nvidia-440xx-utils does not fix the issue. I am unsure how to proceed.

Also, removing the mhwd-nvidia-430xx package seems to have broken the hardware module in settings and re-installing it/rebooting has not fixed it.

You should not remove any mhwd package, but rather use mhwd to remove a driver and install another.
sudo mhwd -r pci video-nvidia-430xx
sudo mhwd -i pci video-nvidia-455xx

Thanks - that worked. I’m not sure why the GUI didn’t do that. I realised removing the mhwd package was probably the wrong thing to do right after I did it!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.