[Testing Update] 2017-09-13 - Calamares, Pamac, MSM, Python, Perl

update
testing

#1

Hi community,

we worked a little on Calamares, fixed small things in Manjaro-Settings-Manager and Pamac. Also we have the usual upstream changes such as Python and Perl.

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.107
  • linux312 3.12.74 [EOL]
  • linux316 3.16.47
  • linux318 3.18.70 [EOL]
  • linux41 4.1.43
  • linux44 4.4.87
  • linux48 4.8.17 [EOL]
  • linux49 4.9.49
  • linux410 4.10.17 [EOL]
  • linux411 4.11.12 [EOL]
  • linux412 4.12.12
  • linux413 4.13.1
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt12 (x86_64)

Package Updates (Tue Sep 12 22:32:18 CEST 2017)

  • testing community i686: 121 new and 113 removed package(s)
  • testing community x86_64: 120 new and 109 removed package(s)
  • testing core i686: 1 new and 1 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra i686: 26 new and 26 removed package(s)
  • testing extra x86_64: 26 new and 26 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gcc              7.1.0-1              7.2.0-1
                                 afl              2.50b-1              2.51b-1
                                anki        2.1.0beta15-1        2.1.0beta16-1
                             arc-kde           20170423-1           20170912-2
                           argyllcms              1.9.2-1              1.9.2-2
                   arm-none-eabi-gcc              7.1.0-1              7.2.0-1
                                avfs              1.0.4-1              1.0.5-1
                             avr-gcc              7.1.0-2              7.2.0-1
                             aws-cli           1.11.143-1           1.11.149-1
                         bitcoin-cli             0.14.2-2             0.14.2-4
                      bitcoin-daemon             0.14.2-2             0.14.2-4
                          bitcoin-qt             0.14.2-2             0.14.2-4
                          bitcoin-tx             0.14.2-2             0.14.2-4
                         btchip-udev                  2-1                  2-2
                            dropbear            2017.75-1            2017.75-2
                       elasticsearch              5.5.2-1              5.6.0-1
                           emacs-nox               25.2-1               25.3-1
                            etherape             0.9.15-1             0.9.15-2
                            filebeat              5.5.1-1              5.6.0-1
                               fplll              5.1.0-1              5.2.0-2
                            fswebcam           20140113-1                    -
                                 gap              4.8.8-1              4.8.8-2
                            gap-data              4.8.8-1              4.8.8-2
                             gap-doc              4.8.8-1              4.8.8-2
                        gap-packages              4.8.8-1              4.8.8-2
                                glyr              1.0.8-1              1.0.8-2
                    gnome-packagekit             3.24.0-2             3.26.0-1
                    haskell-swagger2           2.1.4.1-12                    -
                           heartbeat              5.5.1-1              5.6.0-1
                               hexer              1.0.3-1              1.0.3-2
                              i3lock              2.9.1-1              2.9.1-2
     intellij-idea-community-edition         2:2017.2.2-1         2:2017.2.4-1
                                john       1.8.0.jumbo1-8       1.8.0.jumbo1-9
                              kibana              5.5.1-1              5.6.0-1
                                 ldc            1:1.3.0-1                    -
                          libclastfm                0.5-2                0.5-3
                              libdbi              0.9.0-2              0.9.0-3
                        libfilezilla             0.10.0-1             0.10.1-1
                          liblphobos            1:1.3.0-1                    -
                              linbox             1.4.2-10             1.4.2-11
                               lynis              2.5.3-1              2.5.5-1
                                 m2r             0.1.11-1             0.1.12-1
                   massif-visualizer              0.7.0-1              0.7.0-2
                          metasploit             4.16.1-1             4.16.6-1
                          metricbeat              5.5.1-1              5.6.0-1
                       mingw-w64-gcc              7.1.1-1              7.2.0-1
                           miniupnpc       2.0.20170509-1       2.0.20170509-2
                           miniupnpd       2.0.20170421-1       2.0.20170421-2
                           mtd-utils              2.0.0-1              2.0.0-2
                                 nim             0.17.0-2             0.17.2-1
                              nimble            1:0.8.6-1            1:0.8.8-1
                               ninja              1.8.1-1              1.8.2-1
                    nodejs-lts-boron             6.11.2-1             6.11.3-1
                           npapi-vlc              2.2.5-1              2.2.5-2
                      openbsd-netcat            1.130_3-1            1.178_3-1
                            openntpd              6.2p1-1              6.2p2-1
                         openvswitch              2.7.2-1              2.8.0-1
                          packagekit              1.1.6-1              1.1.7-1
                          packetbeat              5.5.1-1              5.6.0-1
                             packeth              1.8.1-1              1.8.1-2
                           pax-utils              1.2.2-2              1.2.2-3
                       perl-sub-info              0.002-3              0.002-4
                     perl-term-table              0.008-3              0.008-4
                    perl-test-simple           1.302086-2                    -
                    perl-test2-suite           0.000072-2           0.000075-1
                            pngcrush             1.8.12-1             1.8.13-1
                                poco            1.7.8.3-4              1.7.9-1
                              povray             1:3.7-15      1:3.7.2_alpha-2
                     purple-skypeweb                1.4-1                1.4-2
                               pynac             0.7.10-1             0.7.11-1
                python-async-timeout              1.3.0-1              1.4.0-1
                     python-botocore              1.7.1-1              1.7.7-1
                       python-fpylll           0.2.4dev-1           0.3.0dev-1
                       python-hidapi          0.7.99.20-1          0.7.99.20-2
                   python-hypothesis             3.24.1-1             3.25.1-1
                        python-pyaes              1.6.0-1              1.6.0-2
                   python-s3transfer             0.1.10-2             0.1.11-1
                      python2-btchip             0.1.20-1             0.1.20-2
                      python2-fpylll           0.2.4dev-1           0.3.0dev-1
                      python2-hidapi          0.7.99.20-1          0.7.99.20-2
                  python2-hypothesis             3.24.1-1             3.25.1-1
                  python2-jsonrpclib              0.1.7-1              0.1.7-2
                         python2-m2r             0.1.11-1             0.1.12-1
                      python2-pbkdf2                1.3-1                1.3-2
                       python2-pyaes              1.6.0-1              1.6.0-2
                     python2-slowaes              0.1a1-2              0.1a1-3
                            rabbitmq             3.6.11-1             3.6.12-1
                       rabbitmqadmin             3.6.11-1             3.6.12-1
                               ragel               6.10-1               6.10-2
                        ruby-rubydns              2.0.1-1              2.0.1-2
                            sagemath                8.0-2                8.0-3
                    sagemath-jupyter                8.0-2                8.0-3
                               siege              4.0.2-2              4.0.4-1
                            smplayer             17.8.0-1             17.9.0-1
                        snap-confine             2.26.1-1             2.26.1-2
                               snapd             2.26.1-1             2.26.1-2
                      soundkonverter              2.2.2-2              3.0.0-1
                              sqlmap              1.1.8-1              1.1.9-1
                             sub2srt              0.5.5-1              0.5.5-2
                        systemd-swap              3.5.1-1              3.5.2-1
                              tcplay                2.0-1                2.0-2
                           tcpreplay              4.2.5-1              4.2.5-2
                           terraform             0.10.2-1             0.10.3-1
                            umockdev              0.9.2-1              0.9.3-1
                              uthash              2.0.2-1              2.0.2-2
                             variety              0.6.4-1              0.6.5-1
                        wine-staging               2.16-1               2.16-2
                       wireshark-cli              2.4.1-1              2.4.1-2
                    wireshark-common              2.4.1-1              2.4.1-2
                       wireshark-gtk              2.4.1-1              2.4.1-2
                        wireshark-qt              2.4.1-1              2.4.1-2
                          xwallpaper              0.2.0-3              0.2.1-1
                             you-get            0.4.803-1            0.4.909-1
                        kgraphviewer                    -              2.4.0-1
                         kvantum-qt5                    -             0.10.4-1
                   kvantum-theme-arc                    -           20170912-2
                            logstash                    -              5.6.0-1
                      python-axolotl                    -             0.1.39-2
           python-axolotl-curve25519                    -                0.1-2
                 python-recommonmark                    -  0.4.0.133.c410abb-3
                     python2-axolotl                    -             0.1.39-2
          python2-axolotl-curve25519                    -                0.1-2
                python2-recommonmark                    -  0.4.0.133.c410abb-3
                          ruby-async                    -              1.2.0-1
                      ruby-async-dns                    -              1.0.0-1
                       ruby-async-io                    -              1.0.0-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gcc              7.1.0-1              7.2.0-1
                                 afl              2.50b-1              2.51b-1
                                anki        2.1.0beta15-1        2.1.0beta16-1
                             arc-kde           20170423-1           20170912-2
                           argyllcms              1.9.2-1              1.9.2-2
                   arm-none-eabi-gcc              7.1.0-1              7.2.0-1
                                avfs              1.0.4-1              1.0.5-1
                             avr-gcc              7.1.0-2              7.2.0-1
                             aws-cli           1.11.143-1           1.11.149-1
                         bitcoin-cli             0.14.2-2             0.14.2-4
                      bitcoin-daemon             0.14.2-2             0.14.2-4
                          bitcoin-qt             0.14.2-2             0.14.2-4
                          bitcoin-tx             0.14.2-2             0.14.2-4
                         btchip-udev                  2-1                  2-2
                            dropbear            2017.75-1            2017.75-2
                       elasticsearch              5.5.2-1              5.6.0-1
                           emacs-nox               25.2-1               25.3-1
                            etherape             0.9.15-1             0.9.15-2
                            filebeat              5.5.1-1              5.6.0-1
                               fplll              5.1.0-1              5.2.0-2
                            fswebcam           20140113-1                    -
                                 gap              4.8.8-1              4.8.8-2
                            gap-data              4.8.8-1              4.8.8-2
                             gap-doc              4.8.8-1              4.8.8-2
                        gap-packages              4.8.8-1              4.8.8-2
                                glyr              1.0.8-1              1.0.8-2
                    gnome-packagekit             3.24.0-2             3.26.0-1
                           heartbeat              5.5.1-1              5.6.0-1
                               hexer              1.0.3-1              1.0.3-2
                              i3lock              2.9.1-1              2.9.1-2
     intellij-idea-community-edition         2:2017.2.2-1         2:2017.2.4-1
                                john       1.8.0.jumbo1-8       1.8.0.jumbo1-9
                              kibana              5.5.1-1              5.6.0-1
                          libclastfm                0.5-2                0.5-3
                              libdbi              0.9.0-2              0.9.0-3
                        libfilezilla             0.10.0-1             0.10.1-1
                              linbox             1.4.2-10             1.4.2-11
                               lynis              2.5.3-1              2.5.5-1
                                 m2r             0.1.11-1             0.1.12-1
                   massif-visualizer              0.7.0-1              0.7.0-2
                          metasploit             4.16.1-1             4.16.6-1
                          metricbeat              5.5.1-1              5.6.0-1
                       mingw-w64-gcc              7.1.1-1              7.2.0-1
                           miniupnpc       2.0.20170509-1       2.0.20170509-2
                           miniupnpd       2.0.20170421-1       2.0.20170421-2
                           mtd-utils              2.0.0-1              2.0.0-2
                                 nim             0.17.0-2             0.17.2-1
                              nimble            1:0.8.6-1            1:0.8.8-1
                               ninja              1.8.1-1              1.8.2-1
                    nodejs-lts-boron             6.11.2-1             6.11.3-1
                           npapi-vlc              2.2.5-1              2.2.5-2
                      openbsd-netcat            1.130_3-1            1.178_3-1
                            openntpd              6.2p1-1              6.2p2-1
                         openvswitch              2.7.2-1              2.8.0-1
                          packagekit              1.1.6-1              1.1.7-1
                          packetbeat              5.5.1-1              5.6.0-1
                             packeth              1.8.1-1              1.8.1-2
                           pax-utils              1.2.2-2              1.2.2-3
                       perl-sub-info              0.002-3              0.002-4
                     perl-term-table              0.008-3              0.008-4
                    perl-test-simple           1.302086-2                    -
                    perl-test2-suite           0.000072-2           0.000075-1
                            pngcrush             1.8.12-1             1.8.13-1
                                poco            1.7.8.3-4              1.7.9-1
                              povray             1:3.7-15      1:3.7.2_alpha-2
                     purple-skypeweb                1.4-1                1.4-2
                               pynac             0.7.10-1             0.7.11-1
                python-async-timeout              1.3.0-1              1.4.0-1
                     python-botocore              1.7.1-1              1.7.7-1
                       python-fpylll           0.2.4dev-1           0.3.0dev-1
                       python-hidapi          0.7.99.20-1          0.7.99.20-2
                   python-hypothesis             3.24.1-1             3.25.1-1
                        python-pyaes              1.6.0-1              1.6.0-2
                   python-s3transfer             0.1.10-2             0.1.11-1
                      python2-btchip             0.1.20-1             0.1.20-2
                      python2-fpylll           0.2.4dev-1           0.3.0dev-1
                      python2-hidapi          0.7.99.20-1          0.7.99.20-2
                  python2-hypothesis             3.24.1-1             3.25.1-1
                  python2-jsonrpclib              0.1.7-1              0.1.7-2
                         python2-m2r             0.1.11-1             0.1.12-1
                      python2-pbkdf2                1.3-1                1.3-2
                       python2-pyaes              1.6.0-1              1.6.0-2
                     python2-slowaes              0.1a1-2              0.1a1-3
                            rabbitmq             3.6.11-1             3.6.12-1
                       rabbitmqadmin             3.6.11-1             3.6.12-1
                               ragel               6.10-1               6.10-2
                        ruby-rubydns              2.0.1-1              2.0.1-2
                            sagemath                8.0-2                8.0-3
                    sagemath-jupyter                8.0-2                8.0-3
                               siege              4.0.2-2              4.0.4-1
                            smplayer             17.8.0-1             17.9.0-1
                        snap-confine             2.26.1-1             2.26.1-2
                               snapd             2.26.1-1             2.26.1-2
                      soundkonverter              2.2.2-2              3.0.0-1
                              sqlmap              1.1.8-1              1.1.9-1
                             sub2srt              0.5.5-1              0.5.5-2
                        systemd-swap              3.5.1-1              3.5.2-1
                              tcplay                2.0-1                2.0-2
                           tcpreplay              4.2.5-1              4.2.5-2
                           terraform             0.10.2-1             0.10.3-1
                            umockdev              0.9.2-1              0.9.3-1
                              uthash              2.0.2-1              2.0.2-2
                             variety              0.6.4-1              0.6.5-1
                       wireshark-cli              2.4.1-1              2.4.1-2
                    wireshark-common              2.4.1-1              2.4.1-2
                       wireshark-gtk              2.4.1-1              2.4.1-2
                        wireshark-qt              2.4.1-1              2.4.1-2
                          xwallpaper              0.2.0-3              0.2.1-1
                             you-get            0.4.803-1            0.4.909-1
                        kgraphviewer                    -              2.4.0-1
                         kvantum-qt5                    -             0.10.4-1
                   kvantum-theme-arc                    -           20170912-2
                            logstash                    -              5.6.0-1
                      python-axolotl                    -             0.1.39-2
           python-axolotl-curve25519                    -                0.1-2
                 python-recommonmark                    -  0.4.0.133.c410abb-3
                     python2-axolotl                    -             0.1.39-2
          python2-axolotl-curve25519                    -                0.1-2
                python2-recommonmark                    -  0.4.0.133.c410abb-3
                          ruby-async                    -              1.2.0-1
                      ruby-async-dns                    -              1.0.0-1
                       ruby-async-io                    -              1.0.0-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                         btrfs-progs             4.12.1-1               4.13-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                         btrfs-progs             4.12.1-1               4.13-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                           calamares              3.1.4-1              3.1.4-8
                            devtools           20170320-1           20170911-1
            manjaro-settings-manager              0.5.3-4              0.5.3-6
        manjaro-settings-manager-kcm              0.5.3-4              0.5.3-6
  manjaro-settings-manager-knotifier              0.5.3-4              0.5.3-6
   manjaro-settings-manager-notifier              0.5.3-4              0.5.3-6
                   manjaro-tools-pkg             0.15.3-4             0.15.3-5
                  manjaro-tools-yaml             0.15.3-4             0.15.3-5
                               pamac              5.1.1-3              5.1.1-4
                           pamac-dev             5.90.3-1             5.90.4-1
         pamac-dev-tray-appindicator             5.90.3-1             5.90.4-1
             pamac-tray-appindicator              5.1.1-3              5.1.1-4


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                         breeze-grub             5.10.5-1             5.10.5-2
                         flashplugin         26.0.0.151-1         27.0.0.130-1
               gtk-update-icon-cache            3.22.20-1            3.22.21-1
                                gtk3            3.22.20-1            3.22.21-1
                 gtk3-print-backends            3.22.20-1            3.22.21-1
                                gvim           8.0.1066-1           8.0.1092-1
                              libraw             0.18.3-1             0.18.4-1
                           memcached             1.4.37-1              1.5.1-1
                        pepper-flash         26.0.0.151-1         27.0.0.130-1
              postgresql-old-upgrade              9.5.8-3              9.5.9-1
               python-pyasn1-modules              0.1.1-1              0.1.4-1
              python2-pyasn1-modules              0.1.1-1              0.1.4-1
                                 vim           8.0.1066-1           8.0.1092-1
                         vim-runtime           8.0.1066-1           8.0.1092-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                           calamares              3.1.4-1              3.1.4-8
                            devtools           20170320-1           20170911-1
            manjaro-settings-manager              0.5.3-4              0.5.3-6
        manjaro-settings-manager-kcm              0.5.3-4              0.5.3-6
  manjaro-settings-manager-knotifier              0.5.3-4              0.5.3-6
   manjaro-settings-manager-notifier              0.5.3-4              0.5.3-6
                   manjaro-tools-pkg             0.15.3-4             0.15.3-5
                  manjaro-tools-yaml             0.15.3-4             0.15.3-5
                               pamac              5.1.1-3              5.1.1-4
                           pamac-dev             5.90.3-1             5.90.4-1
         pamac-dev-tray-appindicator             5.90.3-1             5.90.4-1
             pamac-tray-appindicator              5.1.1-3              5.1.1-4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                         breeze-grub             5.10.5-1             5.10.5-2
                         flashplugin         26.0.0.151-1         27.0.0.130-1
               gtk-update-icon-cache            3.22.20-1            3.22.21-1
                                gtk3            3.22.20-1            3.22.21-1
                 gtk3-print-backends            3.22.20-1            3.22.21-1
                                gvim           8.0.1066-1           8.0.1092-1
                              libraw             0.18.3-1             0.18.4-1
                           memcached             1.4.37-1              1.5.1-1
                        pepper-flash         26.0.0.151-1         27.0.0.130-1
              postgresql-old-upgrade              9.5.8-3              9.5.9-1
               python-pyasn1-modules              0.1.1-1              0.1.4-1
              python2-pyasn1-modules              0.1.1-1              0.1.4-1
                                 vim           8.0.1066-1           8.0.1092-1
                         vim-runtime           8.0.1066-1           8.0.1092-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                          lib32-gtk3          3.22.20-0.1          3.22.21-0.1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-11           2017-09-13
-------------------------------------------------------------------------------
                   lib32-flashplugin         26.0.0.151-1         27.0.0.130-1
                        wine-staging               2.16-1               2.16-2

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

KDE, smooth update on multiple laptops and VMs, thanks.


#3

smooth update on xfce thanks


#4

Smooth update on KDE here.


#5