Testing | Plasma 5.20 : network speed applet displays incorrect values

I noticed that the network speed applet seems to be off by a factor 2. See here during an scp tranfert: left scp shows 11.2 MB/s, right the applet showing 23.6 MiB/s.

Same phenomenon during speed test and cif file copy with Dolphin.

Anybody else seeing this?

Hello,

Could it be that the left side is showing megabyte per second, and the graph is showing Megabits per second. They are different as on is MB and the other mib/s

He talk about a factor 2… according the units in the screenshots normally the ratio should be 1.048576 from MiB/s to MB/s that mean MB/s should be higher…
And megabits per second is written Mbps
MiB/s is mebibyte/sec.

The factor from MB/s to Mbps would be 8.

1MB/s = 8Mbps.
1MB/s = 0.95Mib/s

scp show you the actual data transfer speed of your file and the applet should show you all datas transferred with the network card.
that mean including the data overhead due to the protocols (tcp/ip headers and scp protocol) or data data size (encrypted if it’s the case).
It’s maybe because of that…
The applet don’t take into account the time to add headers etc… then the card actually transfer more data in less time… i hope I’m clear…

Let say scp send a chunk of 1MB of your file. The time scp calculate is from the time it sends the chunk to the kernel or its scp subsystem and the end time when it got the answer the transfer completed. But the kernel need time to add the headers, the scp protocol time and data etc… finally the data will be bigger, and the time to transfer it lower than what scp calculate… but the applet don’t know about that… he just look what is transferred on the card…

For scp, it transferred 1MB in maybe 1.4s… but the card actually transferred more than 1MB and in less than 1.4s

Select not ALL INTERFACES but just your Network card in the settings.

On plasms If it’s the usual network applet the speed is already by interface no? Or it include 127.0.0.1? :thinking:
I need to check but i never saw a such setting. Ooh looks like an applet on the desktop.

EDIT: it does not come from the ALL INTERFACE…
I did some test… and it seems the applet is not correctly “averaging” the transfter speed.
as the data are transmitted by “burst” and it seems the applet show the maximum or close to the maximum speed. you can kind of see the “burst” in ksysguard… if you check the text value it go from 0 to about what show the applet, the network applet seems to average it correctly, and I cheked there is no transfer measured on lo interface… only the wired one…

The settings I’m talking about is in the NetSpeed widget but yeah it doesn’t have a graph so it is not that…
What are you talking about exactly, how do you have this graph?

I think you are right but that does not explain it all.

When I do a speedtest.net for example I see a download speed of 75 Mb/s. During the test the desktop widget shows 19.3 MiB/s which is 193 MB/s (or 154 Mb/s if it actually indicates MB/s instead of MiB/s). I know for sure that my connection is incapable of transferring more than 100 Mb/s, with or without overhead.

  • Right click on desktop
  • Add Widgets…
  • Drag and drop the Network Speed widget on the desktop

I frankly think that it is plain wrong. Here is the comparison with KSysGuard during a speed test (which is not bursty):

No… 19.3MiB/s = 20.24 MB/s = 161.9Mbps

the speed test (speedtest.nl) usualy indicate the speed in Mbps (megabits per second).
then a speed of 75Mbps (on speedtest.nl) correspond to : 9.4MB/s or 8.94MiB/s

did you check the refresh rate of the tab in ksysguard? put to a lowe refresh rate (0.5s) and check the numerical value in the legend…

exemple on mine:
speedtest give me a result of 520Mbps.
then 520Mbps = 62MiB/s = 65MB/s (1Gbps connection to the /modem-router with 1Gbps switch between)

on ksysguard I have this (burst… the graph is not accurate… the digital value displayed is 0 or or around 130Mib/s during the test) if you look the average it’s about 60MiB/s (don’t forget you have a router/modem between)

on the network applet I have this (all correct)
Screenshot_20201015_171015

I tried to add again the desktop widget but it did not wanted to display anything and I don’t know why…

I had the same symptom as you… factor 2 on desktop widget… but this factor is what I see in ksysguard… so it seems related to that… and I would not relay on the desktop widget…

He is talking about another widget, basically we have three available in Plasma, the Network one in tray icon when developing the network card info like just above, the NetSpeed widget I initially though he was talking about, and the one he has issue with, for me it is localized so I looked for “Réseau” which mean “Network” and found it, dropped it on the desktop and it shows the graph as his first image.

yes… I explained that I saw his problem… and that it seems the widget has a bug… and I tried to explain or correlate the issue with other measuring… and I see the same value as the faulty widget in ksyguard if we look the burst value read…

NetSpeed widget works properly though if you don’t need a graph it is very accurate. Doesn’t solve the issue though.

Ouch, yes I always mix up those.

My KSysGuard is set at 0.5s refresh interval.

In summary KsysGuard and the network connection manager applet both display correct values but the desktop applet is wrong by a factor 2.

I will try to find where I can report the bug to KDE.

Here is a side by side comparison, seems like it is messed up yes:

Left: Firefox on nperf.com
Middle: Network Speed Graph
Right: Network card stats
Inside taskbar next to Steam icon: NetSpeed Widget

The Network card speed should be 1.3MiB download

You can see the Network Speed graph is messed up, it lags behind by a lot, and shows double the rate.

1 Like

Thanks for taking the time to verify it.

KDE Bug filed.
https://bugs.kde.org/show_bug.cgi?id=427976

Fixed:

Is it just me or since the testing update of this weekend the Network speed applet has stopped working?