Testing - can't see the dtb files or the file to modify

Hi All,
So I decided to give Marjaro Arm another shot on my old Android Box.
From a previous thread of mine:


I learned to use this command to build the latest Testing version:

sudo buildarmimg -d gtking-pro -e kde-plasma -v 2023.09.30 -b testing n

I updated the date (I tried using today’s date and the date of the latest Testing release) and ran this command for both KDE and XFCE.
It seemed to work just fine as it created the compressed files.
I extracted the files and used Etcher to write them to their own SD cards.
Previously I would then be able to mount the SD card and select the correct dtb to use.
However, now I no longer see any of the files that I need to view and modify.
When I insert the SD card and mount it, it appears twice (it did this previously as well). When I select the SD card, one of the instances (where I would view and modify the files) is blank. The other instance appears as before, a listing of a typical Manjaro install (I did not search through this in any detail).

I tried booting the SD cards, just to try but of course it did not work.

One thing I noticed was the image files that were extracted were a lot smaller than the previous image files (1.8Gb vs 5+Gb).

By the way, I also went back and downloaded the VIM2 Manjaro version and followed the same method and was able to select the correct dtb and modify the file. I know from my previous experience that this VIM2 file won’t work but I wanted to see if the method I was using was correct or if I missed something.

If someone could kindly help and point me down the correct path, I would greatly appreciate it.

You are going to have 2 file manager windows pop up when you insert the sdcard. One is a fat32 boot partition and the other is an ext4 root partition. The /boot directory on the root partition will be blank when you are not booted with the sdcard. When booted the fat32 boot partition files will be overlayed into the root partion’s /boot directory so the can be easily accessed when boot up.

That is because it failed a dependency check and no packages get installed with pacman when that happens; except the base filesystem. I have found and fixed the issue and pushed a newer package to the testing/unstable repo’s.

I made an image here and all seems good but I do not have your device to test; so give it a go now.

sudo buildarmimg -d gtking-pro -e kde-plasma -v 2023-10-28 -b testing -n -x
5.8G Oct 28 08:31 Manjaro-ARM-kde-plasma-gtking-pro-2023-10-28.img
1 Like

Many thanks @Darksky , I’ll give it a try and report back!

I ran the command as you provided for the KDE version and it appears to have worked (I am writing the image it created to an SD card as I type this so I haven’t tried it yet).
It did take a long time, over 22 minutes.

Now when I tried the same command but for XFCE instead of KDE, it did not work. It only created a 1.8 Gb file.

Here is the output from Termina (the 22.38 minutes is how long it took to complete the KDE version):

==> Time elapsed: 22.38 minute(s)
   ~  sudo buildarmimg -d gtking-pro -e xfce -v 2023-10-28 -b testing -n -x  :heavy_check_mark:  22m 27s 
[sudo] password for neo:

==> Creating xfce edition rootfs image for gtking-pro…
→ Removing old aarch64 rootfs…
→ Removing old aarch64 rootfs archive…
→ Downloading latest aarch64 rootfs archive…
/var/lib/manjaro-ar 100%[===================>] 203.41M 4.60MB/s in 42s
→ Extracting aarch64 rootfs…
→ Setting up keyrings…
→ Setting branch to testing…

==> Installing packages for xfce edition on gtking-pro…
:: Synchronizing package databases…
core downloading…
extra downloading…
community downloading…
warning: systemd-libs-254.5-1 is up to date – reinstalling
error: target not found: kvantum-qt5
==> ERROR: Aborting…

==> Creating xfce edition image for gtking-pro…
→ Creating ext4 partitions…
→ Copying files to image…
mv: cannot stat ‘/var/lib/manjaro-arm-tools/tmp/root/boot/*’: No such file or directory
→ Writing the boot loader images…
Boot PARTUUID is f53db631-01…
Root PARTUUID is f53db631-02…
Root UUID is a71e3d08-f662-400f-b639-51fb458238d3…
→ Cleaning up image…
→ Image not compressed, option -x was passed

==> Time elapsed: 1.73 minute(s)

I was able to boot up the KDE version.
However, I keep running into the same Authentication Error when I try to install programs using pamac.
It simply will not accept my password.
I even tried using “1234” as the password in the initial set-up (a tip I received on a previous post) but no joy.

What is the correct password that it is looking for?

The other issue that remains is no wifi.
I might be able to get around that if I purchase a WiFi USB adapter (maybe that would work), but not being able to install programs or update the OS because it won’t accept my password isn’t something that I can work around.

Was someone’s password inadvertently set in the image?

@NeoVeo I can’t readily find the Contributing to Manjaro Arm thread but you have to updated the profiles; should do it before each image to get the latest. kvantum-qt5 has been renamed to kvantum.

sudo getarmprofiles -f

Thanks again @Darksky, I’ll try that.
By the way, I provided an update and it looks like our messages crossed paths.

I am having an issue with pamac not accepting the password I used in the set up (I literally tried 1234). Please see my post above for details.

I can confirm that using this worked!

I am in the process of creating an XFCE image.

It should be what ever password you set for root up in the OEM Setup in your first boot. Only thing I know of that is with the mobile devices they have a default password using numbers.Seems like in KDE some where here in the forums someone had issues with passwords and it was to do with wrong keyboard being set up in the KDE DE. I’m not a KDE person; I use XFCE.

Thanks for the tip.
I found one post with the same issue, but it was from two years ago and remains unresolved.

I set up the XFCE version and updated the system, then it required a reboot and after doing so I no longer have any internet connection.
The KDE version does have Ethernet working but alas I keep running into the Authentication issue.
I tried changing the keyboard in the OS (several generics plus several from the actual manufacturer of my keyboard) but no joy.

I’ll try making a separate post on this issue.