Terminal stopped working: _p9k_init_params:72: character not in range manjaro%

Im on Manjaro GNOME. I installed this package from AUR via Add/Remove Software: AUR (en) - github-desktop

It told me that I need to restart as it /installed/reinstalled some kernel modules or something. Now my default gnome-terminal does not work. I cannot open it.
Please help ;-;

When I try to open it either via keyboard shortcut or an icon it tries to start but never shows up. I can see it as a process, it shows up for a second in my System Monitor and then just disappears :frowning_face:

I installed another (Deepin) terminal. And when I open him that’s what I get:

_p9k_init_params:72: character not in range                                                                   
manjaro% 

I had that gnome terminal, it had a lot of emojis etc so it was kind cool. Was that the reason?

I just read the PKGBUILD and viewed the git repository for github-desktop. It should not have installed kernel modules or affected gnome-terminal. How did you install it?

Try this from your working Deepin terminal:

Backup your existing configuration:

mv ~/.zshrc ~/.zshrc.bak

Restore the default:

cp -i /etc/skel/.zshrc ~/.zshrc

Make it so:

source ~/.zshrc

Now open GNOME Terminal.

That had nothing to do with github-desktop, you had pending system updates:

What was the point of crossposting on StackExchange? Please don’t use tags like arch-linux, you’re using Manjaro.

1 Like

I’m having the exact same problem. Gnome terminal doesn’t start anymore after installing Nordvpn using the Gnome terminal. The solution offered by @Yochanan doesn’t work for me, it still won’t start.

I also get the error message “_p9k_init_params:72: character not in range” in Deepin Terminal.

Fixed by enabling the correct locales in /etc/locale.gen. After that run locale-gen and Gnome Terminal works fine again

1 Like

Fix (run as root):

echo en_US.UTF-8 UTF-8 > /etc/locale.gen && locale-gen
2 Likes

am having the same problem: all the solutions propose here did not work for me: # echo fr_fr.UTF-8 UTF-8 > /etc/locale.gen && locale-gen
Generating locales…
fr_fr.UTF-8…failed to set locale!
[error] cannot open locale definition file `fr_fr’: No such file or directory

fr_fr.UTF-8…failed to set locale!
[error] cannot open locale definition file `fr_fr’: No such file or directory

fr_fr.UTF-8 is not a valid locale name
the correct name is:

fr_FR.UTF-8 UTF-8

use this command:
sudo echo fr_FR.UTF-8 UTF-8 > /etc/locale.gen && sudo locale-gen
to fix and regenerate the french locale

You should not have used
echo fr_fr.UTF-8 UTF-8 > /etc/locale.gen
as this overwrites the entire file and you now have only that one (wrong) locale in it

Instead, you should have used two of these “>”:

echo fr_FR.UTF-8 UTF-8 >> /etc/locale.gen

as this will append that one line to the end of the file.

The original locale.gen file is in the package glibc if you want to restore it.

It is a crude fix and destroys the file in the process.
What your fix does is:
overwrite the entire file (which has all the locales in it, in commented form)
with just that one line

You probably should have appended it - to preserve the contents of the file.
like this:

echo en_US.UTF-8 UTF-8 >> /etc/locale.gen

or just open the file in an editor and uncomment the locale(s) you want to have
… but now your file contains only that one line
It works if you need no other locales besides en_US.UTF-8

Exactly! You should append it. Yesterday’s update resetted the /etc/locale.gen to its default again (all locales are commented again) which resulted in a broken terminal again. This time I appended the locale. :slight_smile:

Many thanks! It works; am able to have the local. gen set up correctly!

Thanks, I was worried for a while but setting and generating locales fixed it.

Is this bug reported already…? By the looks of it, quite many people have hit this bug…

I found that the latest bios update for my B-550 from Asus fix that issue