Terminal problem (हिन्दी) in manjaro cinnamon

cinnamon

#1

Hindi is looking right on the whole system but does not look right on the terminal. What is the reason that Hindi is not showing right on the terminal, please solve the problem.

जब मैं टर्मिनल पर हिन्दी टाइप करता हूँ तो दिखती है “ह िन् द ी”। बाकी पूरे सिस्टम पर हिन्दी सही दिखाई देती है केवल टर्मिनल पर हिन्दी सही नही दिखाई पडती। konsole X terminal emulator को इन्स्टाल कर के देखा, फान्ट बदल कर देखा लेकिन कोई फायदा नही हुआ। ubuntu, linux mint आदि OS मे सही है लेकिन मन्जारो सिनामन मे नहीं। Please help.


#2

translator used.
मैं नहीं जानता कि यह कितना अच्छा अनुवाद करेगा। यदि आप मंजूरो सेटिंग मैनेजर में जाते हैं, तो देखें कि क्या आपका भाषा पैक स्थापित है और यदि नहीं, तो स्थापित करें। किसी भी अन्य स्थापित करें थाय आपके लिए भी उपयुक्त हो सकता है। रिबूट और जाँच करें।


#3

हिन्दी भाषा पैक संस्थापित होने के बाउजूद यह समस्या बनी हुई है।


#4

What’s output of localectl in terminal?


#5

%E0%A4%9A%E0%A5%81%E0%A4%A8%E0%A4%BE%E0%A4%B5_060


#6

You have (sh… screen shot, please print)

hi_IN
not
hi_IN UTF-8

  1. Can you go into /etc/locale.gen uncomment “hi_IN UTF-8”
  2. At terminal
sudo locale-gen
sudo localectl set-locale LANG=hi_IN UTF-8 
  1. Reboot.

#7

%E0%A4%9A%E0%A5%81%E0%A4%A8%E0%A4%BE%E0%A4%B5_062


#8

Try with appostrophes (sorry)

sudo localectl set-locale LANG="hi_IN UTF-8"

Don’t forget to reboot. Needs reboot to work.


#9

Selection_063
रिबूट करने के बाद भी अभी समस्या बनी हुई है। Document आदि फोल्डर मे रखी .odt फाइल खोलने पर मौजूद नहीं है का मैसेज दिखा रहा है। वापस hi_IN करने पर पुनः .odt फाइल खुलने लगी है।LANG=hi_IN UTF-8 पर सेट करने पर सिस्टम मे उपरोक्त समस्या आ रही है।


#10

Since I know hindi, I thought let me intervene and translate what umesh is saying.

His original problem is that the language in the terminal is not supporting hindi, even though system-wide, hindi appears appropriately.

In the last post above, he has mentioned that - “reboot didnt help. In Document and other folders, odt files are not opening and the message comes not available. But when locale is setback to hi_IN, the odt files open”

@Umesh - I am not clear about few things.

  1. Your initial problem was that text in terminal is not coming inhindi language. Right?
  2. The second, recent problem you are reporting is different. Right? Please tell whether this is the following problem: after changing the locale from hi_IN to hi_IN UTF-8, odt files are not opening. If this is the case, can you please tell us what exact message you are getting?

#11

So now your terminal hindi fonts is okay now?
You didn’t say. Now problem at Libreoffice?
To use Hindi at LO, you will need to install LO Hindi input and keyboard to Hindi.
You keyboard is in ‘us’. But I have no idea on using HIndi keyboard (Hindi input package?) or LO Hindi font package (like libreoffice-fresh-hi ?).


#12

%E0%A4%9A%E0%A5%81%E0%A4%A8%E0%A4%BE%E0%A4%B5_064

महोदय जी
अभी भी टर्मिनल पर हिन्दी “ह िन् द ी” नजर आ रही है।


#13

मै बताने की यह कोशिश कर रहा था कि जब मैं अपने सिस्टम को hi_IN की जगह LANG=hi_IN UTF-8 पर सेट कर रहा हूँ तो मेरा सिस्टम गडबडा रहा है। ड्रापबाक्स वगैरह काम करना बन्द कर रहे हैं। .odt फाइल आदि खोलना चाहता हूँ तो मैसेज आता है कि फाइल मौजूद नहीं है। हो सकता है कि मैने फाइल का नाम हिन्दी मे रखा इसलिए एैसा हो रहा हो। यह तभी होता है जब मै सिस्टम को sudo localectl set-locale LANG=“hi_IN UTF-8” द्वारा सेट करता हूँ। टर्मिनल की समस्या अभी ठीक नहीं हुई है।


#14

%E0%A4%9A%E0%A5%81%E0%A4%A8%E0%A4%BE%E0%A4%B5_065


#15

At this point, I have to say I do not know Hindi to be of any use in the specific issue you have of Hindi fonts. Hope others can help you here.
Maaf.


#16

@gohlip - umesh is mentioning that after setting hi_IN UTF-8, none of the files opened since these file names were in hindi. This was not a problem when the lang was hi_IN.

@umesh - I dont exactly know the solutions for your problem. But when I just did a google search for kde konsole different language settings several relevant searches came up. Among these, thought this discussion might be relevant for you. I would request you to search online — there are many discussions on language settings of konsole in arch and kde forums.


#17

%E0%A4%9A%E0%A5%81%E0%A4%A8%E0%A4%BE%E0%A4%B5_069

उपलब्ध लैग्वेज पैक मे hi_IN UTF-8 लैग्वेज पैक नहींहै।कहीं यह तो मुख्य कारण नहीं है। यदि यह कारण है तो इसे सिस्टम मे कैसे इन्स्टाल करुँ क्योंकि लिनक्स मिन्ट मे hi_in और hi_IN UTF-8 दोनो सिस्टम मे इन्टाल करने के लिए मौजूद रहता है।


#18

Thanks for explanation.
Can OP set both at MSM shown above?:point_up_2:
And, can he check at “Installed Languages Packages” tab if there is any Hindi pack he should install like OpenOffice Hindi pack?

As said, I will have to leave you people here and good luck.
Danyawad. Namaste.


#19

hi_IN UTF-8 लैग्वेज पैक मन्जारो सेटिंग मैनेजर मे नहीं है। hi_IN UTF-8 लैग्वेज पैक सिस्टम मे कैसे इन्स्टाल करें। please help.


#20

Umesh,

I checked in my system and looks like, as you pointed correctly, there is no hi_IN UTF-8. The UTF-8 version is present only for English and few other languages. So, as a language pack, you just need hi_IN.

For Hindi (only hi_IN is available)

For English (US) (both en_US and en_US UTF-8 is available)

Given this, I think you should now check why konsole is not picking this locale settings.