Terminal does not “source” on startup

terminal does not “source” on startup and output bashrc:type:64: bad option: -P on source

I freshly installed manjaro (coming from ubuntu)
and the terminal doesn’t seems to load ~/.bashrc on start-up,
for example I added the alias alias ll='ls -alF', but doesn’t get recognized.\

When I run source ~/.bashrc I get this output

source ~/.bashrc                                                                                                                                                                                   
/.../.bashrc:type:64: bad option: -P
zsh: command not found: complete
zsh: command not found: shopt
zsh: command not found: shopt
zsh: command not found: shopt

and ll get now correctly recognized,
but if I close and reopen the terminal it’s again not recognized

did I miss something?

You are clearly using zsh and as such .bashrc won’t work.

Either change shell to bash or add you aliases to .zshrc


I think it’s because you are using zsh. Add the alias to your .zshrc and source it.

source ~/.zshrc


thanks, it works
is there any reason to keep .bashrc around?

Yes do not remove it!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.