Terminal does not source .bashrc by default

Hello,

I added some lines to my .bashrc recently, sourced the .bashrc and everything worked fine. However, after rebooting, my modifications didn’t work anymore. I then realized, I have to manually source my .bashrc every time I start a terminal window for them to become effective.

My first suspicion was that I need my .bash_profile to source my .bashrc and that the file is somehow missing. But the file is there and the contents look right to me:

# ~/.bash_profile
#

[[ -f ~/.bashrc ]] && . ~/.bashrc

Can someone help me out please?

Edit: typing bash -l after starting a terminal works, too. So probably, I could exchange the command that starts the terminal upon hitting the icon to that. But it changes the commandline from this fancy looking Manjaro logo with that house to [username@pcname ~]$. Also, to me it seems, the terminal should be doing this by default? There must be some other way.

1 Like

Are you sure that you are actually using bash? I think the GNOME edition actually use zsh by default.

You can check which shell you’re running with echo $SHELL .

If you actually prefer to use the classic bash shell, you can do with chsh -s /bin/bash . It will only be effective at the next login (i.e. you have to log out, then log in again to make it work).

2 Likes

Gnome uses zsh by default, so it won’t source bashrc, since it’s actually not using bash.

I guess your default shell is not Bash.
You can change this with chsh. (With your username, the path to bash is /bin/bash)

If you want to check, run:

$ which $SHELL

/usr/bin/zsh

Then you’ll be able to see which shell you’re using. As you can see, I use zsh and for that you need to work with ~/.zshrc and not ~/.bashrc.

2 Likes

Thanks a lot for all these quick replies! It makes sense of course that my changes in the .bashrc won’t affect my terminal if Gnome doesn’t use bash. This is solved then.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.