Teamviewer not running because of no daemon running

That’s a new one. I can’t recall when it start but teamviewer does not start anymore complaining about daemon not started. I did start teamviewerd and it is listed has running but teamviewer still complain. No go.

Hey, welcome to Manjaro!! :blush: Once you have installed TeamViewer correctly from the AUR (either with pamac or yay etc.), activate the TeamViewer daemon by writing the following command in a terminal:
sudo systemctl enable teamviewerd --now
and confirm with your root user password user. edit by mod
Now TeamViewer should start. If not, restart your computer. After that, it should work.

2 Likes

Thank you very much. Yes I know about that service but for a strange reason, it will still complain. After a couple of install/reinstall, I finally got it going, on boot too. By the way what does “–now” actually do? “enable” is not instant ? Wait the “–now” also “start” the service right ?
Tx

Exactly, you estimated correctly. The argument --now ensures that not only is the automatic start of a service performed when the computer is booted, but also that the corresponding service is loaded immediately, so that a restart of the computer would not be required first.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.