Task manager window preview not working


Recently I’ve been thinking of replacing Windows with a Linux distro on my PC so I installed the latest stable build of Manjaro in a VM to get things setup and work out what kind of packages I want before doing the actual install on my PC.

I ran into the issue of the window previews when hovering over a program in the task manager/taskbar showing just an icon of the program and not the window preview as expected. I’ve tried setting Keep Window Previews to Always in the compositor settings and trying different rendering backends including opengl 2 and 3, but the previews still seem to be broken.

Screenshots below:

Incidentally I was testing out Arch before and the window previews seem to work on there so I’m not sure if there’s a bug or if something is missing on the Manjaro install. Using X11 on both systems.


The output to inxi -Fxzis:

System:    Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux
           base: Arch Linux
Machine:   Type: Vmware System: VMware product: VMware Virtual Platform v: N/A serial: <filter>
           Mobo: Intel model: 440BX Desktop Reference Platform serial: <filter> BIOS: Phoenix v: 6.00 date: 07/22/2020
CPU:       Info: 8-Core model: Intel Core i7-6700K bits: 64 type: MCP arch: Skylake-S rev: 3 cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 64152
           Speed: 4008 MHz min/max: N/A Core speeds (MHz): 1: 4008 2: 4008 3: 4008 4: 4008 5: 4008 6: 4008 7: 4008 8: 4008
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: bus-ID: 00:0f.0
           Display: x11 server: X.Org 1.20.11 driver: loaded: vmware unloaded: modesetting resolution: 1693x928~60Hz
           OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.1.2 direct render: Yes
Audio:     Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371 v: kernel bus-ID: 02:02.0
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes
           Sound Server-2: JACK v: 0.125.0 running: no
           Sound Server-3: PulseAudio v: 14.2 running: yes
           Sound Server-4: PipeWire v: 0.3.30 running: no
Network:   Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine type: network bridge driver: N/A port: 1060
           bus-ID: 00:07.3
           Device-2: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: kernel port: 2000
           bus-ID: 02:01.0
           IF: ens33 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 50 GiB used: 8.07 GiB (16.1%)
           ID-1: /dev/sda vendor: VMware model: Virtual S size: 50 GiB
Partition: ID-1: / size: 40.67 GiB used: 8.07 GiB (19.8%) fs: ext4 dev: /dev/sda1
Swap:      ID-1: swap-1 type: partition size: 8.38 GiB used: 0 KiB (0.0%) dev: /dev/sda2
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 250 Uptime: 5m Memory: 3.81 GiB used: 1.34 GiB (35.3%) Init: systemd Compilers: gcc: N/A Packages: 1180
           Shell: Bash v: 5.1.8 inxi: 3.3.04

Help with this really appreciated, thank you. :slight_smile:

What’s the output of both inxi --admin --verbosity=7 --filter --no-host --width under Arch and Manjaro because it looks like the Arch install had a dGPU passthrough and the Manjaro install didn’t, because that just works on my Manjaro KDE system (Bare metal) out of the box just like in your Arch VM.