T480 trackpad help

Recently bought a t480 thinkpad installed xfce and im having issues with the trackpad sometimes it will lag like its not picking up my movements . I installed windows and it works fine on windows , when I boot to any linux distro its a 50/50 chance if it works .
If its lagging and I reboot it may fix it , if i go to terminal and run ; sudo rmmod psmouse && sudo modprobe psmouse it may take a few tries before it acts normal once its normal if i keep trying the comand it will eventually go back to acting up.
I’m not ruling out a bad motherboard but does any one have any suggestions before that ?


provide some info,

Ok I ran fwupd no updates available, the modprode.d folder is empty .
my apology thought I posted in the xfce section , installed xf86-input-synaptics drivers and updated bios

sorry im a bit slow , added psmouse.config file and it made it worse lagging and jumping constantly so i removed it .
section 4.6 , im not sure how to modify kernel to try this. or ill have to deal with it , it sounds like .

Enabling synaptics_intertouch=1 doesn’t mean you have to install the old xf86-input-synaptics driver. You misinterpreted that.

I inderstand , said that as something I tried it was one of the first things I did .

Here are some (more detailed) infos about X1C6, wich is pretty similar to T480.

Interesting parts are here and here. Read all please, and try to sort it out with “trial and error”. Make notes and back up your original configs.