T410 - Can't connect to wifi | WPA2 + WPA3 (mixed mode)

can you post output from:
lsmod | grep iwl

Sure :slight_smile:
This provides the following output:

iwldvm                282624  0
mac80211             1236992  1 iwldvm
iwlwifi               458752  1 iwldvm
cfg80211             1073152  3 iwldvm,iwlwifi,mac80211

so try to remove the modules:
sudo modprobe -r iwlwifi
sudo modprobe -r iwldvm
then reboot, they should be loaded, just to be sure check if they are with the same command:
lsmod | grep iwl
if it didnt work, then try installing the latest kernel 5.17.1-3 and also the 5.4 LTS and try with them

maybe try disabling 11n protocol?

file: /etc/modprobe.d/iwlwifi.conf

options iwlwifi 11n_disable=1

@brahma
I first tried removing the modules and then rebooted the system. I verified that both modules got loaded again and tried connecting to the wifi again → Did not work.
I then downloaded the mentioned kernel versions and booted from them → Same problem with both of them.
I even tried the kernel 4.19.236-1 LTS because i know that wifi did work in the past on that notebook (manjaro and several other distros). Weirdly even with this kernel i was unable to connect to the wifi. At this point i’m wondering if this is even a driver issue or something else?

@megavolt
I did try this but this sadly still results in the infinite password prompt loop.

Did you reboot?

You can also set such parameter like that:

sudo systemctl stop NetworkManager
sudo rmmod -v iwlwifi
sudo modprobe -v iwlwifi swcrypto=1 11n_disable=1 disable_11ac=1 disable_11ax=1
sudo systemctl start NetworkManager

At the end it should only use 11b and 11g. Maybe in this mode it works?

Yes i did reboot after creating /etc/modprobe.d/iwlwifi.conf and setting the option.

I just entered the commands you provided and tried connecting to the wifi after that but that still results in the same outcome.

Here is a journalctl -g iwl after entering all those commands:

-- Boot 0f17e55aa8524629b44846a8c47be377 --
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 6000-4.ucode op_mode iwldvm
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
Mai 12 20:32:35 l0st kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
Mai 12 20:32:35 l0st kernel: iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
Mai 12 20:32:44 l0st NetworkManager[519]: <info>  [1652380364.6667] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/ieee80211/phy0/rfkill0) (driver iwlwifi)
Mai 12 20:32:46 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:32:47 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:32:47 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:32:47 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:32:52 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:32:52 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:33:18 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:33:18 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:33:23 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:33:24 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:34:48 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:34:48 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:35:51 l0st dbus-daemon[504]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.51' (uid=0 pid=1286 comm="sudo nano iwlwifi.conf")
Mai 12 20:35:54 l0st sudo[1286]:      red : TTY=pts/0 ; PWD=/etc/modprobe.d ; USER=root ; COMMAND=/usr/bin/nano iwlwifi.conf
Mai 12 20:36:20 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:36:20 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
-- Boot 5efafc92d3c14872a48c000bd9e7e95e --
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 6000-4.ucode op_mode iwldvm
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
Mai 12 20:37:47 l0st kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
Mai 12 20:37:47 l0st kernel: iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
Mai 12 20:37:56 l0st NetworkManager[530]: <info>  [1652380676.3021] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/ieee80211/phy0/rfkill0) (driver iwlwifi)
Mai 12 20:37:58 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:37:58 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:37:59 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:37:59 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:03 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:03 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:29 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:29 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:34 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:38:35 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:41:54 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:41:54 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:42:07 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:42:07 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:43:57 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:43:57 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:50:52 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:50:52 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:54:33 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:54:33 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:54:57 l0st dbus-daemon[506]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.72' (uid=0 pid=1458 comm="sudo rmmod -v iwlwifi")
Mai 12 20:54:57 l0st sudo[1458]:      red : TTY=pts/0 ; PWD=/home/red ; USER=root ; COMMAND=/usr/bin/rmmod -v iwlwifi
Mai 12 20:55:00 l0st dbus-daemon[506]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.73' (uid=0 pid=1460 comm="sudo rmmod -v iwlwifi")
Mai 12 20:55:00 l0st sudo[1460]:      red : TTY=pts/0 ; PWD=/home/red ; USER=root ; COMMAND=/usr/bin/rmmod -v iwlwifi
Mai 12 20:55:08 l0st dbus-daemon[506]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.74' (uid=0 pid=1463 comm="sudo rmmod -v iwldvm")
Mai 12 20:55:08 l0st sudo[1463]:      red : TTY=pts/0 ; PWD=/home/red ; USER=root ; COMMAND=/usr/bin/rmmod -v iwldvm
Mai 12 20:55:12 l0st dbus-daemon[506]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.75' (uid=0 pid=1469 comm="sudo rmmod -v iwlwifi")
Mai 12 20:55:12 l0st sudo[1469]:      red : TTY=pts/0 ; PWD=/home/red ; USER=root ; COMMAND=/usr/bin/rmmod -v iwlwifi
Mai 12 20:57:22 l0st dbus-daemon[506]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.76' (uid=0 pid=1479 comm="sudo modprobe -v iwlwifi swcrypto=1 11n_disable=1")
Mai 12 20:57:22 l0st sudo[1479]:      red : TTY=pts/0 ; PWD=/home/red ; USER=root ; COMMAND=/usr/bin/modprobe -v iwlwifi swcrypto=1 11n_disable=1 disable_11ac=1 disable_11ax=1
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 6000-4.ucode op_mode iwldvm
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
Mai 12 20:57:22 l0st kernel: ieee80211 phy1: Selected rate control algorithm 'iwl-agn-rs'
Mai 12 20:57:22 l0st kernel: iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
Mai 12 20:57:38 l0st NetworkManager[1496]: <info>  [1652381858.1051] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/ieee80211/phy1/rfkill1) (driver iwlwifi)
Mai 12 20:57:38 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:57:38 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:57:38 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:57:38 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:57:41 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:57:41 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:59:19 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1
Mai 12 20:59:19 l0st kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1

// Edit: Is there actually a way where i can look at what the driver is doing or at which point the wifi connection fails? Already took a look at my router but i can’t find anything in the wifi logs about my notebook there.

since you installed the minimal version, could you just try full version in the live usb session

You can check the logs here:

journalctl --boot 0 --unit NetworkManager

or in follow mode:

journalctl --boot 0 --unit NetworkManager --follow

To set the logging level do this:

# check your log level
nmcli general logging 
# switch to debug level
sudo nmcli general logging level debug
# switch back to info level
sudo nmcli general logging level info

no offense but just to make sure that it’s active because the journalctl-messages are always referring to the wifi-switch (switch on and wifi is in bios activated):

1 Like

@Olli
No offense taken :slight_smile:
This was one of the first things i actually double checked. My wifi card is enabled in the BIOS and my wifi hardware button is set to ‘active’. Just tried disabling them → rebooting → enabling them → rebooting again just to make sure but my wifi card isn’t even recogniced by manjaro as soon as i turn it off in BIOS or switch the hardware button to ‘deactivate’.

@megavolt
I just did that and took a look at the output. Sadly there isn’t really much suspicious i can find. The only thing that catched my eye is that my wifi card seems to always rotate between the states authenticating -> associating -> disconnected

Here is a little bit of output:

Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0204] agent-manager: agent[5cc6c0ab59c6e371,:1.31/org.freedesktop.nm-applet/1000]: agent returned secrets for request [1c2919ee99b3ed84/"WIFI-SSID"/"802-11-wireless-security"]
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0209] settings-connection[ce4c5ecb0f128777,74b5c6fa-da41-43c7-bd67-eab26293a5ff]: (802-11-wireless-security:0x7f3110006b70) secrets returned from agent :1.31
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0210] settings-connection[ce4c5ecb0f128777,74b5c6fa-da41-43c7-bd67-eab26293a5ff]: (802-11-wireless-security:0x7f3110006b70) secrets request completed
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0216] settings-connection[ce4c5ecb0f128777,74b5c6fa-da41-43c7-bd67-eab26293a5ff]: (802-11-wireless-security:0x7f3110006b70) saving new secrets to backing storage
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0963] device[f7f4fbf5a162b44f] (wlp3s0): activation-stage: schedule activate_stage1_device_prepare
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0965] device[f7f4fbf5a162b44f] (wlp3s0): activation-stage: invoke activate_stage1_device_prepare
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0965] device (wlp3s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0965] device[f7f4fbf5a162b44f] (wlp3s0): add_pending_action (2): 'in-state-change'
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0972] device[f7f4fbf5a162b44f] (wlp3s0): remove_pending_action (1): 'in-state-change'
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0975] device[f7f4fbf5a162b44f] (wlp3s0): activation-stage: synchronously invoke activate_stage2_device_config
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0976] device (wlp3s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0976] device[f7f4fbf5a162b44f] (wlp3s0): add_pending_action (2): 'in-state-change'
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0980] device[f7f4fbf5a162b44f] (wlp3s0): remove_pending_action (1): 'in-state-change'
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0981] route-manager: sync routing-rule
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0981] device[f7f4fbf5a162b44f] (wlp3s0): bringing up device 4
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0982] platform-linux: link: change 4: flags: set 0x1/0x1 ([up] / [up])
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0983] platform-linux: do-request-link: 4 
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0984] platform-linux: do-change-link[4]: success changing link: success
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0985] device (wlp3s0): Activation: (wifi) connection 'WIFI-SSID' has security, and secrets exist.  No new secrets needed.
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0986] Config: added 'ssid' value 'WIFI-SSID'
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0986] Config: added 'scan_ssid' value '1'
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0987] Config: added 'bgscan' value 'simple:30:-70:86400'
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0987] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK SAE FT-SAE'
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0987] Config: added 'auth_alg' value 'OPEN'
Mai 12 21:26:16 l0st NetworkManager[1496]: <info>  [1652383576.0988] Config: added 'psk' value '<hidden>'
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.0995] sup-iface[8ac0c029ad4f9762,1,wlp3s0]: assoc[5e34dc11e10136cf]: starting association...
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.1041] sup-iface[8ac0c029ad4f9762,1,wlp3s0]: set bridge (null) result: success
Mai 12 21:26:16 l0st NetworkManager[1496]: <debug> [1652383576.1302] sup-iface[8ac0c029ad4f9762,1,wlp3s0]: assoc[5e34dc11e10136cf]: association request successful
Mai 12 21:26:17 l0st NetworkManager[1496]: <info>  [1652383577.1756] device (wlp3s0): supplicant interface state: scanning -> authenticating
Mai 12 21:26:17 l0st NetworkManager[1496]: <debug> [1652383577.1756] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:17 l0st NetworkManager[1496]: <info>  [1652383577.3922] device (wlp3s0): supplicant interface state: authenticating -> associating
Mai 12 21:26:17 l0st NetworkManager[1496]: <info>  [1652383577.4288] device (wlp3s0): supplicant interface state: associating -> disconnected
Mai 12 21:26:19 l0st NetworkManager[1496]: <debug> [1652383579.1867] connectivity: (enp0s25,IPv6,86) skip connectivity check due to no carrier
Mai 12 21:26:19 l0st NetworkManager[1496]: <debug> [1652383579.1868] connectivity: (enp0s25,IPv6,86) check completed: NONE; no carrier
Mai 12 21:26:20 l0st NetworkManager[1496]: <debug> [1652383580.1851] connectivity: (enp0s25,IPv4,87) skip connectivity check due to no carrier
Mai 12 21:26:20 l0st NetworkManager[1496]: <debug> [1652383580.1852] connectivity: (enp0s25,IPv4,87) check completed: NONE; no carrier
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.4344] device (wlp3s0): supplicant interface state: disconnected -> scanning
Mai 12 21:26:27 l0st NetworkManager[1496]: <debug> [1652383587.4344] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.4775] device (wlp3s0): supplicant interface state: scanning -> authenticating
Mai 12 21:26:27 l0st NetworkManager[1496]: <debug> [1652383587.4776] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.4789] device (wlp3s0): supplicant interface state: authenticating -> associating
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.5081] device (wlp3s0): supplicant interface state: associating -> authenticating
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.7927] device (wlp3s0): supplicant interface state: authenticating -> associating
Mai 12 21:26:27 l0st NetworkManager[1496]: <info>  [1652383587.8310] device (wlp3s0): supplicant interface state: associating -> disconnected
Mai 12 21:26:37 l0st NetworkManager[1496]: <info>  [1652383597.8372] device (wlp3s0): supplicant interface state: disconnected -> scanning
Mai 12 21:26:37 l0st NetworkManager[1496]: <debug> [1652383597.8373] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:40 l0st NetworkManager[1496]: <debug> [1652383600.1616] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:41 l0st NetworkManager[1496]: <warn>  [1652383601.0435] device (wlp3s0): Activation: (wifi) association took too long
Mai 12 21:26:41 l0st NetworkManager[1496]: <info>  [1652383601.0435] device (wlp3s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0436] device[f7f4fbf5a162b44f] (wlp3s0): add_pending_action (2): 'in-state-change'
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0440] device[f7f4fbf5a162b44f] (wlp3s0): remove_pending_action (1): 'in-state-change'
Mai 12 21:26:41 l0st NetworkManager[1496]: <info>  [1652383601.0441] sup-iface[8ac0c029ad4f9762,1,wlp3s0]: wps: type pbc start...
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0446] Secrets requested for connection /org/freedesktop/NetworkManager/Settings/2 (WIFI-SSID/802-11-wireless-security)
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0447] agent-manager: agent[5cc6c0ab59c6e371,:1.31/org.freedesktop.nm-applet/1000]: agent allowed for secrets request [6c2c5df591d1d38d/"WIFI-SSID"/"802-11-wireless-security"]
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0447] settings-connection[ce4c5ecb0f128777,74b5c6fa-da41-43c7-bd67-eab26293a5ff]: (802-11-wireless-security:0x560e8c977ef0) secrets requested flags 0xF hints '(none)'
Mai 12 21:26:41 l0st NetworkManager[1496]: <warn>  [1652383601.0448] device (wlp3s0): Activation: (wifi) asking for new secrets
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0454] agent-manager: ([6c2c5df591d1d38d/"WIFI-SSID"/"802-11-wireless-security"]) system settings secrets insufficient, asking agents
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0455] agent-manager: agent[5cc6c0ab59c6e371,:1.31/org.freedesktop.nm-applet/1000]: agent getting secrets for request [6c2c5df591d1d38d/"WIFI-SSID"/"802-11-wireless-security"]
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0455] agent-manager: ([6c2c5df591d1d38d/"WIFI-SSID"/"802-11-wireless-security"]) request has system secrets; checking agent :1.31 for MODIFY
Mai 12 21:26:41 l0st NetworkManager[1496]: <info>  [1652383601.0460] device (wlp3s0): supplicant interface state: scanning -> disconnected
Mai 12 21:26:41 l0st NetworkManager[1496]: <info>  [1652383601.0554] device (wlp3s0): supplicant interface state: disconnected -> scanning
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0554] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0574] agent-manager: agent[5cc6c0ab59c6e371,:1.31/org.freedesktop.nm-applet/1000]: agent [6c2c5df591d1d38d/"WIFI-SSID"/"802-11-wireless-security"] MODIFY check result YES
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.0788] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:41 l0st NetworkManager[1496]: <debug> [1652383601.5797] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:43 l0st NetworkManager[1496]: <debug> [1652383603.8970] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:44 l0st NetworkManager[1496]: <debug> [1652383604.3989] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:46 l0st NetworkManager[1496]: <debug> [1652383606.7130] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:47 l0st NetworkManager[1496]: <debug> [1652383607.2146] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:49 l0st NetworkManager[1496]: <debug> [1652383609.4779] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:49 l0st NetworkManager[1496]: <debug> [1652383609.9794] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:52 l0st NetworkManager[1496]: <debug> [1652383612.2906] device[f7f4fbf5a162b44f] (wlp3s0): failed to match hidden AP 50:6F:0C:53:25:52
Mai 12 21:26:52 l0st NetworkManager[1496]: <debug> [1652383612.2917] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:52 l0st NetworkManager[1496]: <debug> [1652383612.7956] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:55 l0st NetworkManager[1496]: <debug> [1652383615.0561] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:55 l0st NetworkManager[1496]: <debug> [1652383615.5605] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning
Mai 12 21:26:57 l0st NetworkManager[1496]: <debug> [1652383617.8744] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: idle (notify last-scan)
Mai 12 21:26:58 l0st NetworkManager[1496]: <debug> [1652383618.3758] device[f7f4fbf5a162b44f] (wlp3s0): wifi-scan: scanning-state: scanning

I sadly didn’t have an old iso lying around so i i downloaded the current version from Manjaro - Downloads (XFCE), created a bootable usb with rufus and booted from it. Seems like i get the same problem there too.

you could try a live usb session of a non arch distro like linux mint, just to narrow it down if its a arch/manjaro issue or a linux issue

1 Like

Connection request was successful:

But authenticating not:

Also here:

So I assume there is problem with the password or with the way how the password has been saved.

Can you try to connect with:

nmtui connect

:question:

@brahma
I actually thought about this too and booted from a live usb with linux mint (XFCE). When i then connect to the wifi i get the exact same behaviour as with manjaro. So it seems like this is not a distro related problem.

@megavolt
I just tried this (deleted the saved wifi configuration before) but i get the same behaviour (and same debug output) as before.

thats unfortunate… maybe its a xfce desktop thing? … you could try disable ipv6:
Edit the file: /etc/default/grub and in this line: GRUB_CMDLINE_LINUX_DEFAULT add inside the quotes this kernel parameter:
ipv6.disable=1 - dont remove anything from there, just add it
Update grub, then reboot:
sudo update-grub

I think i was able to narrow down the problem.

Out of curiousity i started playing around with the different wifi security options in my router.

Turns out:

  • Disabling wifi security → Notebook can connect without problems to wifi
  • Enabling WPA + WPA2 → Notebook can connect without problems to wifi
  • Enabling WPA2 CCMP → Notebook can connect without problems to wifi
  • Enabling WPA2 + WPA3 → Notebook can’t connect to wifi and presents me the infinite password prompt

While i’m not surprised that the old intel wifi card doesn’t support wifi authentication with wpa3 i’m kinda surprised that there seems to be a difference between pure wpa2 ccmp and wpa2 + wpa3 mode (as wpa2 should still be an available option to use).
Gonna keep researching …

1 Like

After narrowing down the problem and further research i was able to solve it with the help of another post on this forum from @Pino :slight_smile:

It seems like there is a problem with the wpa_supplicant package regarding connecting to WPA2 + WPA3 (mixed mode) wifi’s. As soon as i installed the packages iwd and networkmanager-iwd-overlay (AUR), removing wpa_supplicant and then rebooting i was able to connect to my wifi without a problem.

Forumpost:
Manjaro does not connect to WPA2/3 mixed WIFI network

Additional info:
ArchWiki - Network Configuration - Wireless - WPA2
ArchWiki - iwd
AUR - networkmanager-iwd-overlay

// Edit: This seems to be a known problem as a bug report to this already exists for the package wpa_supplicant which you can find here: Archlinux - Bugs - FS#73844
As of right now this probably won’t get fixed as it seems to be a problem on the router site and not on the client site. A specific description of the problem and additional workarounds (which don’t include using an old AUR package instead) can be found here: infradead.org - Bug#1003907

1 Like

@RedPanda Well spotted :+1: I have changed the name of the topic to better reflect this problem.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.