I was able to install Manjaro on a T2 intel Macbook Air using the t2linux project on github in an attempt to revive it, and I was able to thankfully get it fully functional (Except Bluetooth, but I don’t need that).

The one issue I’m having with it is that, it won’t suspend which drains my battery when the laptop is closed.

Running systemctl --failed returns the following:

  UNIT                    LOAD   ACTIVE SUB    DESCRIPTION   
● systemd-suspend.service loaded failed failed System Suspend

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

Running systemctl enable systemd-suspend.service returns:

The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

Running inxi for system info:

CPU: dual core Intel Core i3-1000NG4 (-MT MCP-)
speed/min/max: 1200/400/3200 MHz Kernel: 5.15.32-1-MANJAROT2-YURUYURI x86_64
Up: 40m Mem: 2233.8/7755.4 MiB (28.8%) Storage: 233.76 GiB (5.7% used)
Procs: 215 Shell: Zsh inxi: 3.3.19

Does anyone have any ideas on what I could try, or is this likely an issue with the custom T2-adapted iso?

Thank you all in advance!


The systemd-suspend.service should be located in /usr/lib/systemd/system/systemd-suspend.service
and be provided by systemd package. As far as it goes, the content of it should be:

#  SPDX-License-Identifier: LGPL-2.1-or-later
#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

Description=System Suspend

ExecStart=/usr/lib/systemd/systemd-sleep suspend

Maybe try hibernate instead.
Regarding bluetooth, this might help

1 Like

Thank you! Hibernate is doing it wonderfully for me.

Unfortunately, that’s still a no-go on Bluetooth. I looked into the T2 Wiki (Device Support and State of Features) and it seems that the wireless/bluetooth chip I have (BRCM4377) is unsupported.

Thank you so much for the prompt reply.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.