Systemctl command won't return (when starting a service to fix standby on Lenovo x230)


I am trying to fix a known issue with the standby on an Lenovo notebook, however I am stuck with systemctl.

The hints I tried to follow, come from the Arch wiki, I am not allowed to link to that page here, the URL ends with Lenovo_ThinkPad_X230#Suspend_to_ram.

I created the two files, set permissions to 755, called systemctl daemon-reload.
When trying to start the service via CLI, the command sudo systemctl start rc-local-shutdown.service never returns, there is no error message.

Do you guys have any idea what I could do?

You don’t need to start the service. It is automatically started when the system reaches the shutdown target.
You have to enable it though with systemctl enable rc-local-shutdown.service.

Using the journal, you can see possible error messages:
journalctl -u rc-local-shutdown.service

1 Like

Thanks, seems to be working now!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.