System won't use newer kernel ...stays on LTS

Hello everyone…
although I’ve installed new kernels (Linux 5.9.3-11 and 5.9.1_rt19-1) my system won’t use either after reboot and keeps using LTS Linux 5.4.80-2
I have no problem at all with my system using the LTS …but i would like to learn why …
Sorry for the newbie question and thank you in advance to anyone who can enlighten me…

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MONETARY = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "el_GR.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
  Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=6602f6da-ccbf-456c-97f5-15d10da3de47 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: FUJITSU product: LIFEBOOK A530 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: FUJITSU model: FJNBB06 serial: <filter> BIOS: FUJITSU // Phoenix 
  v: Version 1.16 date: 08/19/2010 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: Dual Core model: Intel Core i3 M 380 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7 
  L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20221 
  Speed: 1072 MHz min/max: 933/2533 MHz Core speeds (MHz): 1: 958 2: 962 
  3: 950 4: 965 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; 
  SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Core Processor Integrated Graphics vendor: Fujitsu Limited. 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0046 
  Device-2: Silicon Motion - Taiwan (formerly Feiya ) USB 2.0 PC Cam 
  type: USB driver: uvcvideo bus ID: 1-1.1:3 chip ID: 090c:37b6 
  serial: <filter> 
  Display: x11 server: 1.20.10 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Fujitsu Limited. driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:3b56 
  Sound Server: ALSA v: k5.4.80-2-MANJARO 
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter 
  vendor: Fujitsu Limited. driver: ath9k v: kernel port: 1840 bus ID: 03:00.0 
  chip ID: 168c:002b 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Fujitsu Limited. driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: 5000 bus ID: 07:00.0 chip ID: 10ec:8168 
  IF: enp7s0 state: down mac: <filter> 
  Local Storage: total: 298.09 GiB used: 20.78 GiB (7.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Hitachi model: HTS545032B9A300 size: 298.09 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: C61J scheme: MBR 
  ID-1: / raw size: 290.05 GiB size: 284.49 GiB (98.09%) 
  used: 20.78 GiB (7.3%) fs: ext4 dev: /dev/sda1 
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.04 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 167 Uptime: 8m Memory: 3.65 GiB used: 915.2 MiB (24.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 
  pacman: 1401 lib: 347 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08```
  1. Welcome to the forum :wink:
  2. Please edit your post and place ``` before and after the part you pasted in on their own lines.
    This will make that part be properly formatted
  3. Please inform about what bootloader you use.
    Eg. Grub, sd-boot, rEFInd, etc…
    This will allow people to help you with your problem better.

Assuming you are using Grub, select advanced options during boot in the Grub menu and there you’ll find all the kernels installed on your system.

@TriMoon thank you for the formatting tip …and as i can see from my boot folder the bootloader is Grub…
@chomsky thank you for the answer and i indeed found all the newer kernels installed in the Grub menu and also in the boot folder
the thing is that none of the newer kernels is used by the system
“automatically” after reboot as it used to do and keeps using the LTS kernel…
is this normal…?


You have to select the kernel in the grub menu during startup under advanced options. As far as I know it doesnt do so automatically.

Does grub not have any option to set the default menu entry?

thank you chomsky … my system used to switch to new installed kernel after installation and reboot …is there a way to set it up like so…?

Yes it does though i dont know when selecting “1” as the default entry for advanced options it automatically selects the latest kernel from the list.

You could try setting GRUB_DEFAULT=1 in /etc/default/grub update grub and see what happens. Assuming advanced options is the second choice in the menu.

In my case, whenever I install a new kernel, i need to boot by selecting it manually once. Then it becomes the default. Otherwise it defaults to whichever kernel I was already using. I thought this was the expected behaviour. And if so, then,
You can press Esc or Shift during boot to get into grub menu, then advanced, then choose the kernel you want to boot through. Reboot and you should be defaulting to the chosen one.

ok…done that …but i’ll need some help on updating Grub…

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 resume=/dev/sda2"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

@audialche manually selecting the latest installed kernel from Grub menu worked fine…
my system used to do the switch to latest kernel after installation and reboot …
not a big problem but i was wondering what happened…

thank you all…

@chomsky thank you for the try…same result … old kernel

Do you have the package linux-latest installed? That’s the package that should put you on the latest kernel or at least make sure you have the latest kernel installed

thank you all…
@sawdoctor I wasn’t aware such package even existed but it solved my little “problem”…many thanks

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.