System Wide DSP (Equalizer)

Hello there,

I’ve been interested in applying a system wide eq lately, both to improve the audio coming out of my not-so-good speakers and to learn a bit about how linux handles audio, I was not satisfied with pulseaudio-equalizer-ladspa because I wanted to be able to choose the frequency and the quality-factor of the filters, so I tried following this guide, but it seems like I’m doing something wrong. I’ll go trough what I did step by step:

  1. I cloned and installed https://github.com/bmc0/dsp.git. Everything seems fine.

  2. I created a configuration file ~/.config/ladspa_dsp/config_<plugin_name>. Everything seems fine.

  3. I made PulseAudio load the plugin using
    $ pacmd load-module module-ladspa-sink sink_name=dsp master=alsa_card.usb-Yamaha_Corporation_Steinberg_UR12-00 plugin=ladspa_dsp:<plugin_name> label=ladspa_dsp:<plugin_name>
    Nothing seems to have happened.

All of that didn’t seem to have any noticeable effect, so I thought that maybe my eq configuration was too subtle for me to notice the difference, but after trying again with totally crazy eq settings I am sure the problem is not in my ears.
I am also pretty sure the problem is in point 3 of the above list because the configuration file seems to be ok since the plugin gets listed with the correct name when I issue the command $ analyseplugin ~/Audio/dsp/ladspa_dsp.so .
Can you give me some hints on how to get unstuck?
Not sure if it’s relevant but I run linux58 kernel, Manjaro Mikah 20.1 and Plasma KDE, at the moment I’m using a Steinberg UR12 audio interface.

Thanks in advance.

According to the Arch Documentation (of which Manjaro is a derivative) you also have to

pactl load-module module-dbus-protocol

Which seems to be missing from your guide.

Could you follow the Arch docs and report back, please?

:innocent:

master=alsa_card.usb-Yamaha_Corporation_Steinberg_UR12-00

That is the card name not the sink name

use this command to get list of sink names

pactl list sinks | grep -A3 Sink

According to this - Problems installing DSP correction - elementaryos.stackexchange.com
the dsp configuration file should just be called config - ~/.config/ladspa_dsp/config

then use pacmd options for ‘plugin’ and ‘label’ are as shown in the guide - plugin=ladspa_dsp label=ladspa_dsp

and use this command to set the the default sink

pacmd set-default-sink dsp
1 Like

Thanks for your answers, I’ll let you know if it works as soon as I can