System Upgrade Keyring Error

I recently discovered that I was not receiving any system updates notifications. If I remember correctly I think it was a problem with the mirrors. Once, I fixed that I was finally able to detect all version upgrades for all the packages that I have installed, when running sudo pacman --sync --refresh --sysupgrade. However, it fails before anything is installed on a specific key with the error:

downloading required keys...
:: Import PGP key 1F358118A07ACF57, "Unknown Packager"? [Y/n] 
error: key "1F358118A07ACF57" could not be looked up remotely
:: Import PGP key 1F358118A07ACF57, "Unknown Packager"? [Y/n] 
error: key "1F358118A07ACF57" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

I have tried a few different things with no success. For instance, making sure my system time was correct, initializing the key ring and populating it, etc.

I have no idea what the problem is and any help would be appreciated.

System Info:

System:    Host: pi4 Kernel: 4.19.97-1-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: coherent_pool=1M 8250.nr_uarts=0 cma=64M cma=256M 
           smsc95xx.macaddr=DC:A6:32:20:6F:12 vc_mem.mem_base=0x3ec00000 
           vc_mem.mem_size=0x40000000 root=/dev/mmcblk0p2 rw rootwait console=ttyS0,115200 
           console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N 
           dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200 elevator=noop 
           Desktop: KDE Plasma 5.17.5 Distro: Manjaro ARM 
Machine:   Type: ARM Device System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835 
           rev: c03111 serial: <filter> 
Battery:   Device-1: hid-76:09:25:15:32:a5-battery model: Anker A7721 charge: N/A 
           status: Discharging 
CPU:       Topology: Quad Core model: N/A variant: cortex-a72 bits: 64 type: MCP arch: ARMv8 
           family: 8 model-id: N/A stepping: 3 microcode: N/A 
           features: Use -f option to see features bogomips: 432 
           Speed: 600 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 
           4: 600 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 status: Vulnerable 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: bcm2835-vc4 driver: vc4_drm v: N/A bus ID: N/A 
           Device-2: bcm2835-hdmi driver: N/A bus ID: N/A 
           Display: x11 server: 1.20.7 driver: modesetting 
           resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: bcm2835-audio driver: bcm2835_audio bus ID: N/A 
           Device-2: bcm2835-hdmi driver: N/A bus ID: N/A 
           Sound Server: ALSA v: k4.19.97-1-MANJARO-ARM 
Network:   Message: No ARM data found for this feature. 
           IF-ID-1: eth0 state: down mac: <filter> 
           IF-ID-2: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 59.48 GiB used: 11.72 GiB (19.7%) 
           ID-1: /dev/mmcblk0 model: SC64G size: 59.48 GiB block size: physical: 512 B 
           logical: 512 B 
Partition: ID-1: / raw size: 59.39 GiB size: 58.40 GiB (98.34%) used: 11.69 GiB (20.0%) 
           fs: ext4 dev: /dev/mmcblk0p2 
           ID-2: /boot raw size: 94.0 MiB size: 93.8 MiB (99.79%) used: 38.6 MiB (41.2%) 
           fs: vfat dev: /dev/mmcblk0p1 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 169 Uptime: 2h 35m Memory: 3.73 GiB used: 1.63 GiB (43.8%) 
           Init: systemd Compilers: gcc: N/A Shell: bash v: 5.0.11 inxi: 3.0.37 

It looks like one of the packages you have installed or want to install is signed by a key that can not be downloaded.

The key does exist on a key server:

12# gpg --keyserver hkp:// --search-keys 1F358118A07ACF57
gpg: data source:
(1)	Ray Sherwin <>
	  2048 bit RSA key 1F358118A07ACF57, created: 2020-02-10
Keys 1-1 of 1 for "1F358118A07ACF57".  Enter number(s), N)ext, or Q)uit > q
gpg: error searching keyserver: Operation cancelled
gpg: keyserver search failed: Operation cancelled

You want to import this key to your keyring:

gpg --keyserver hkp:// --recv-keys 1F358118A07ACF57

Ray Sherwin is our Raspberry Pi kernel maintainer.
Do you have the manjaro-arm-keyring package installed?

@Strit I do have that package installed:
pacman --query --info manjaro-arm-keyring

Name : manjaro-arm-keyring
Version : 20200210-1
Description : Manjaro-Arm PGP keyring
Architecture : any
Licenses : GPL
Groups : None
Provides : None
Depends On : None
Optional Deps : None
Required By : pacman
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 14.50 KiB
Packager : Dan Johansen
Build Date : Mon 10 Feb 2020 02:46:12 PM EST
Install Date : Thu 20 Aug 2020 10:08:59 PM EDT
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By : Signature

I am not sure when the initial install date was for manjaro-arm-keyring because I did end up reinstalling it to be sure.

Prior to reading this I did try to install packages by first letter, without doing a full system upgrade. For example:

sudo pacman --sync `sudo pacman --query --upgrades | sed 's/\([[:blank:]]\).*/\1/' | sed '/^[^abc]/d' | tr '\r\n' ' '`

I was able to get all packages updated that way but I did run into an issue when trying to install all packages updates for packages that started with ā€œLā€. When I broke up the list of updates for packages that start with ā€œLā€ I was able to get everything updated. I am not sure why it happened that. I am wondering if the order in which the packages were installed had something to do with it, or it was just a odd coincidence. I suppose it is possible that manjaro-arm-keyring package was updated before I went to install the package that was causing the failure. I am not sure if there is anything that I can do to check that.

@mbod I am also seeing the key information now, when I run:
pacman-key --list-keys 1F358118A07ACF57

Is there is anything further that I should check? If not, I am comfortable calling this resolved.

Thanks for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.