System update causes black screen on boot, restore caused grub_is_shim_lock_enabled not found error

so i installed the latest 300 package update about 4 days ago, restarted my computer to end up on just infinite black screen after grub menu, so i restore a backup from a few hours before i updated via timeshift, and then when i tried to boot i get the symbol grub_is_shim_lock_enabled not found which is really weird given my secure boot has been disabled since forever (did check anyways and it definitely is) not sure whats causing this.

Randomly out of the blue it started working again yesterday but skipped grub menu during the boot, so i reinstalled grub, and now it doesnt detect my other installation of windows (on a seperate drive) and running into the same error code again, is this fixable?

Please edit your topic title to be clear and concise about the problem.

Also edit your first post with information that helps us help you.

Please see:

what extra info do you require? never had this kind of problem before so im not sure what info would be relevant in this case, ill be sure to provide it if i can though

I have just experienced the exact same issue, after trying to restore to a Timeshift restore point. It rebooted & I got the following error…

“grub_is_Shim_lock_enabled not found”

Let me know if you found a solution. Thanks…


Once could be a random occurrence.
Twice, well, I don’t think coincidence applies all that much in Linux.

Grub was updated a short while ago - possibly after your last visit to the forum - and required some manual intervention.

The grubx64.efi is placed in $esp/EFI/Manjaro.

Some implementations of the efi firmware has a hardcoded expectation to find the loader in $esp/EFI/boot/bootx64.efi.

Therefore - as a precaution to a non bootable system - the grubx64.efi is copied to said backup location as bootx64.efi.

This poses a problem when grub is updated - because only the Manjaro location is updated - thus leaving you with two different loaders - of which only one matches the /boot/grub/grub.cfg and the other will create issues.

There is two ways of solving it

  1. ensure the correct efi loader is default in your efi firmware

    • set the Manjaro one as default
  2. copy the updated Manjaro/grubx64.efi as boot/bootx64.efi overwriting the previous.

The package [install-grub] is doing exactly that - ensuring sync between those two locations.

if you reinstalled grub - I suggest you look at the /etc/default folder - possibly you have a pacsave or pacnew - but the os-prober may be disabled in the new /etc/derfault/grub file

With some manual intervention by your sysadmin - yes.