System Tray Icons not showing / Close to Tray Option

Hello, I am having an issue after updates, none of the usual programs that “Close to tray icon” behave as they should and instead they are completely closed, also even when opened they don’t show the system tray icon as they used before, for example Telegram which is the most common App I use.

This is the system info:

OS: Manjaro Linux x86_64 
Host: Z370M DS3H 
Kernel: 5.4.164-1-MANJARO 
Shell: bash 5.1.12 
Resolution: 1920x1080 @ 60.00Hz 
DE: GNOME 41.2 
WM: Mutter 
WM Theme: ChromeOS-dark-compact-shell 
Theme: Cameo-Manjaro [GTK2/3] 
Icons: Papirus-Adapta-Maia [GTK2/3] 
Terminal: gnome-terminal 
CPU: Intel i5-8500 (6) @ 4.1GHz [44.0°on] 
Memory: 1707MiB / 15953MiB (10%) 

Usually I would mention the extensions I run since Gnome without extensions is a weird thing to me BUT I disabled the extensions option completely to check if the issue was related with any of them and it persist, so I have no clue on how to fix it.

I tried a lot of stuff in other websites like checking for the installed version of Telegram (and this happened with both, the one downloaded from source in the community repos and the portable app from the Telegram web itself).

Can someone please help me? I can try with whichever program you ask installing to check if it shows its System Tray Icon when launched and test the close to tray as well

You’ll need the AppIndicator and KstatusNotifierItem Support extension (gnome-shell-extension-appindicator) enabled for most tray icons to appear.

1 Like

Thanks so much! I can’t believe it needs an extension for it TBH… shocking to me, but Gnome I guess, that is why I rarely use Gnome without extensions but after installing so many I lost what is needed for each thing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.