System stopped working out of nowhere and now I can't boot in my computer

So I left my computer for a while and I realized that something was up as I was locked out and my password kept getting incorrect turns out my shift isn’t working properly but that’s not my issue my issue is I rebooted my computer and now all the sudden I’m in this emergency mode and this is all I see.

Scanning for btrfs file system
[FAILED] Failed to mount /mint/LocalDisk
[DEPEND] dependency failed for local file system
You are an emergency mode. After logging in, type “journal to -xb” to view system logs, “system to reboot” to reboot, “system to default” or “exit” two Boots into default mode.
Give her password for maintenance
(or press Control-D to continue):

When I answer the password I have terminal access. I do not have a live USB anymore so is there anything I can do to fix this here?

I edited the other post (from the other thread) a few times.

Just to confirm:

Logging in with the password takes you to a normal terminal?

systemctl restart sddm
results in what?

You can get the UUID of the devices with the following command:

lsblk -o name,UUID

You need the partition’s UUID, not the drive itself.

You’ll need to substitute LABEL for UUID in your fstab entry. You can use the nano text editor in the console to directly edit /etc/fstab

1 Like

So I did the restart command and it just brought me back to the login prompt I already grabbed the uuid of my drive and put it all in my FS tab file and it still did the same stuff

Which login prompt? For the console? or the KDE / SDDM login screen? What happens if you try to switch to TTY1 after restarting the SDDM service?

UUID of the drive or the partition?

What does your fstab currently look like now? (With regards to /mnt/LocalDisk)

Is this a typo? I see “mint” instead of “mnt”

What is the entry above it?

Is the the UUID for the drive or partition?

What is the output of

lsblk -o name,UUID

What message did you get from trying to restart SDDM? Could you switch to TTY1?

No I couldn’t switch TTY I just s ent you the picture of the uuid output and I believe I have whatever UUID it showed here on the picture. Restarting stdm just brought me back to the emergency mode message.

While in emergency mode, what do you see with,


Then what happens if you try,

mount -a

Finally does,

systemctl default

continue the boot/login process like normal?

No it just brings me back to the message as displayed on that first image I sent you when I did the mount -a command it says /mint/LocalDisk: mount(2) system call failed: no such file or directory.

Something was entered incorrectly in the fstab, or maybe there’s a small mistake, like not enough columns in one of the entries.

What do you see with,

blkid /dev/sda1

Is there a way to show the entire contents of your fstab, maybe move the cursor to see the stuff on the right side?

As a test, replace the UUID portion and just use /dev/sda1 instead, and see if you can then use mount -a to mount everything.

Blkid just says no file or directory and what do you mean by replace the entry do I delete everything including uuid=

Delete UUID=XXXX-XXXX and replace it with /dev/sda1

Eh?! blkid claims no file or directory for the device, /dev/sda1, yet it shows up with lsblk? You’re sure you typed in the commend correctly?

I typed it incorrectly the first time but when I did the thing that you told me to do in the fs tab when retyping the command it actually worked

Works, as in it mounts properly with mount -a again? Rebooting is normal again?

Sorry for the wait I was trying to do something on another computer but anyways no it didn’t render it normal again it just worked and listed the uuid

Did you do this step? :point_up_2:

Like this right? If so, then know this is the same stuff that happens