System shutdown taking way too long

My system is taking too long to shutdown (>90 seconds). The issue is that something is causing a network drive to not disconnect and so I have to wait for it to timeout fully before it continues the shutdown. I’m guessing something is trying to write to it, but I have no idea what. Any suggestions to troubleshoot this?

inxi --full --verbosity=7 --filter --no-host
System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GF65 Thin 9SD v: REV:1.0 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Micro-Star model: MS-16W1 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16W1IMS.108 
           date: 12/04/2019 
Battery:   ID-1: BAT1 charge: 36.4 Wh condition: 49.7/51.3 Wh (97%) volts: 12.0/11.4 model: MSI Corp. MS-16W1 type: Li-ion 
           serial: N/A status: Unknown 
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
Memory:    RAM: total: 31.21 GiB used: 4.43 GiB (14.2%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           bogomips: 62431 
           Speed: 900 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
           9: 900 10: 900 11: 900 12: 901 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
           smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Micro-Star MSI driver: nvidia v: 450.80.02 
           bus ID: 01:00.0 chip ID: 10de:2191 
           Device-3: Acer HD Webcam type: USB driver: uvcvideo bus ID: 1-11:3 chip ID: 5986:211b 
           Display: x11 server: X.Org 1.20.10 driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
           resolution: 1: 1920x1080~120Hz 2: 1920x1080~75Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: 3000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: down mac: <filter> 
           IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A 
           IP v4: <filter> scope: global 
           WAN IP: <filter> 
Drives:    Local Storage: total: 953.88 GiB used: 333.95 GiB (35.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLV512HCJH-000L2 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 5L0QBXV7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1032 size: 476.94 GiB speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> rev: 21101000 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 125.30 GiB used: 77.67 GiB (62.0%) fs: ext4 dev: /dev/nvme1n1p4 label: N/A 
           uuid: 9ce0d192-74cb-480c-a301-5218e56ae9d2 
           ID-2: /boot/efi size: 500.0 MiB used: 360 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 label: N/A uuid: 9146-CB96 
           ID-3: /home size: 310.67 GiB used: 187.13 GiB (60.2%) fs: ext4 dev: /dev/nvme1n1p3 label: N/A 
           uuid: 301dc4d2-0455-4799-ae01-db9895f819f7 
           ID-4: /home/<filter>/d_drive size: 176.24 GiB used: 69.15 GiB (39.2%) fs: ntfs dev: /dev/nvme0n1p5 label: d_drive 
           uuid: 43FBFFD71AD3FC68 
           ID-5: /home/<filter>/network_drives size: 931.28 GiB used: 560.67 GiB (60.2%) fs: cifs 
           remote: // label: N/A uuid: N/A 
           ID-6: /run/timeshift/backup raw size: 127.80 GiB size: <superuser/root required> used: <superuser/root required> 
           fs: ext4 dev: /dev/nvme1n1p4 label: N/A uuid: 9ce0d192-74cb-480c-a301-5218e56ae9d2 
Swap:      ID-1: swap-1 type: partition size: 32.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme1n1p2 label: N/A 
           uuid: 5b9fd5b9-6a63-41d5-977e-336d40f2ebaf 
Unmounted: ID-1: /dev/nvme0n1p2 size: 300.00 GiB fs: ntfs label: c_drive uuid: C6AE0EAEAE0E9759 
           ID-2: /dev/nvme0n1p3 size: 100.0 MiB fs: vfat label: BOOT uuid: 429D-B2A7 
           ID-3: /dev/nvme0n1p4 size: 561.0 MiB fs: ntfs label: diagnostic uuid: A04478FB4478D60E 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-3:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0605 
           Device-1: 1-3.1:4 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c52b 
           Device-2: 1-3.2:6 info: Microsoft Nano Transceiver 1.1 type: Keyboard,HID,Mouse driver: hid-generic,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 045e:07fd 
           Device-3: 1-11:3 info: Acer HD Webcam type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
           chip ID: 5986:211b 
           Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: Bluetooth driver: btusb interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aaa 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 68.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 332 Uptime: 20m Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1862 pacman: 1839 
           flatpak: 15 snap: 8 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08 

This is useless till I get it fixed:

journalctl --boot=-1 
An error was encountered while opening journal file or directory /var/log/journal, ignoring file: Not a directory
Specifying boot ID or boot offset has no effect, no persistent journal was found.

One solution, and probably the better one, is to create the missing directory.

sudo mkdir /var/log/journal

The other would be to disable logging to disk for journald but that is a personal choice.

Edit: This is not the cause of your slow shutdown, just the error.

I may have fixed the issue. I had a similar problem before where a program installed via snap would not let me unmount /home when doing a shutdown. So I went and uninstalled a few snap programs I never use and now shutdowns are quick. I’ll test it a few more times after running the system a bit more to make sure my ‘fix’ is a FIX!

Turns out I had accidentally made /var/log/journal a file instead of a directory no telling how long ago. Deleting it and making it an actual directory made disk logging work. Thanks for the suggestion.