System randomly freeze or reset

I’ve been working fine with Manjaro KDE from long time ago, I work with dual boot (Windows 10 / Manjaro KDE) and two (NTFS) drives mounted from booting. After several months without using Manjaro, I full-updated system and changed kernel to 5.4.x LTS, and proprietary graphic drivers to video-nvidia-440xx. Shortly after I started having problems with random freezes ans reboots. Recently I’ve done a fresh installation (EFI(fat32,100MB), / (root, ext4, 190GB), swap (4GB)), the same problem arose some time later. I tried Ubuntu Budgie without any problems. With Windows 10 no problem.

The output for inxi -Fza is:

System:    Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=8c5e9e33-d0ff-4332-869d-9438cea2160a rw quiet 
           resume=UUID=1f1b1cc2-dbdc-47c1-924c-290b3b99e43e udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: CROSSHAIR VI HERO v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 1701 date: 09/22/2017 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 stepping: 1 
           microcode: 8001129 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95844 
           Speed: 1831 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 2678 2: 2278 3: 1373 4: 1373 5: 1374 
           6: 1371 7: 1375 8: 1374 9: 1319 10: 1318 11: 1318 12: 1318 13: 1317 14: 1315 15: 1375 16: 1374 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nouveau v: kernel alternate: nvidia_drm,nvidia 
           bus ID: 29:00.0 chip ID: 10de:1b81 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting alternate: fbdev,nouveau,nv,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           OpenGL: renderer: NV134 v: 4.3 Mesa 20.1.6 direct render: Yes 
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 29:00.1 
           chip ID: 10de:10f0 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 2b:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.8.3-2-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: e000 bus ID: 23:00.0 
           chip ID: 8086:1539 
           IF: enp35s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.73 TiB used: 1.35 TiB (49.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Western Digital model: WD10EARS-00Y5B1 size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 0A80 scheme: MBR 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-75WN4A0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
           ID-3: /dev/sdc vendor: Western Digital model: WD10EZRX-00L4HB0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: MBR 
Partition: ID-1: / raw size: 196.00 GiB size: 191.92 GiB (97.92%) used: 17.54 GiB (9.1%) fs: ext4 dev: /dev/sdb7 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb8 
Sensors:   System Temperatures: cpu: 36.8 C mobo: N/A gpu: nouveau temp: 35 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 337 Uptime: 2m Memory: 15.63 GiB used: 1.37 GiB (8.8%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1129 lib: 293 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Any solution? Thanks in advance.

see this
https://wiki.archlinux.org/index.php/Ryzen

also
https://wiki.gentoo.org/wiki/Ryzen#Random_reboots_with_mce_events

can you update your bios version ?
be very careful to get version for your CPU only – recheck this point

Hi, first off thanks for your prompt response. I’ve updated my BIOS and now I cannot boot from Manjaro, BIOS recognize Windows boot only so I booted from Manjaro Live USB and selected “Detect EFI boot loaders” to start Manjaro, and from there I run sudo update-grub and rebooted but system starts with Windows. What happened? and how can I fix it?

recheck all option in bios

  • secure boot disable
  • fast boot disable
  • no csm
  • no legacy
  • UEFI only ( not windows )
  • disks on AHCI
  • no rst or optane

you mays need USB mass storage on

if no boot , go to live iso manjaro ( not your disk )
open a terminal and browser on this topic
and return

test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v

BIOS rechecked… no changes with the problem,

Running commands from Manjaro Live USB:

https://i.imgur.com/jwa2lJl.jpg

While I was checking BIOS, I noted that frequency of DRAM was less (2133 MHz) than normal (3200 MHz), I don’t know how and when it changed, when I bought my PC, I overclocked my RAM (I don’t remember how much but it was greater than 3200 MHz). Well I fixed it now, my question is: Can it have influence with the problem of freezing/rebooting?

windows has removed entry in efiboot ,
boot on USB iso manjaro live

sudo manjaro-chroot -a ( type 1 if only one line appears )
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --verbose
update-grub
efibootmgr -v
exit ( end chroot )

then reboot

updated bios do a reset on bios configuration , before apply any profile
overclocking over 3200Mhz memory can be a problem , if you memory do not support theses values

Hi, big news all is resolved but the issue about freezing/rebooting which is being watched for a couple of days.

Here my traveler’s log:

  • Googling I found an interesting post(1), which talks about the probable cause of problem, and it gave me a tip about how to solve this issue.
  • this video(2) and efibootmgr with .efi file(3) completed the whole idea of a solution my case (the following command obviously was run from my harddisk and boot partition mounted):
# efibootmgr --create --disk /dev/sdb --part 2 --label "Manjaro" --loader "EFI\Manjaro\grubx64.efi"
  • after booting I entered BIOS Setup and entry for “Manjaro” is showed now.
  • alright, then all resolved? nop, now I got a new problem with sleeping/hibernating my system, it was not working.
  • this article(4) helped, I have two kernels installed: one stable (default and running) and one LTS (for fallback). I booted Manjaro with LTS kernel and Sleep/Hibernate operation worked again, then I booted with the stable kernel, and it is working as expected.
  • With respect to microcode(5), OS is managing by itself, but it is good to check it out.
  • At present, the only problem “not resolved” yet is about random freeze/reboot that is being watching, but I have faith in Stephane’s tips and the great community on Internet.

“When using Windows I miss Linux, when using Linux I miss Windows… why life is so complicated?”

PS: I’m not permitted to use links/images in posts, why?

1: https://www.linuxquestions.org/questions/linux-newbie-8/uefi-bios-not-recognizing-linux-efi-bootloader-dual-boot-4175619918/#post5795766
2: https://youtu.be/MN-Q5h2Iv8A
3: https://wiki.archlinux.org/index.php/EFISTUB#efibootmgr
4: https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate#Suspend/hibernate_does_not_work,_or_does_not_work_consistently
5: https://wiki.archlinux.org/index.php/Ryzen

After some days of using the distro, I’ve not had any problems about freezing/rebooting. I cannot say what was exactly the solution: updating/modifying BIOS, setting ucode to kernel, setting two kernels, uninstalling video-nvidia-450xx, or maybe it is a little of all of them.

Anyway, thanks for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.