System not detecting any bluetooth devices

When trying to connect a bluetooth device to my unix pc using blueberry, no bluetooth devices are detected.

The output of
sudo dmesg | grep -i 'blue'
looks like this:

[    4.513515] Bluetooth: Core ver 2.22
[    4.513533] Bluetooth: HCI device and connection manager initialized
[    4.513536] Bluetooth: HCI socket layer initialized
[    4.513537] Bluetooth: L2CAP socket layer initialized
[    4.513539] Bluetooth: SCO socket layer initialized
[    4.790751] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.790752] Bluetooth: BNEP filters: protocol multicast
[    4.790754] Bluetooth: BNEP socket layer initialized
[   19.136131] Bluetooth: RFCOMM TTY layer initialized
[   19.136134] Bluetooth: RFCOMM socket layer initialized
[   19.136136] Bluetooth: RFCOMM ver 1.11

I am on manjaro release 21.1.6-1,
Kernel 5.10.70-1-MANJARO
Xfce 4.16

Just putting this.

I have read the Bluetooth documention for arch linux.

When trying hcitool lescan, I get the error Set scan parameters failed: Input/output error
I tried restarting hci0 by

hciconfig hci0 down
hciconfig hci0 up


hciconfig hci0 reset

But this doesnt help.
However, the following looks fine:

[imedv11 myuser]# btmgmt info
Index list with 1 item
hci0:	Primary controller
	addr 00:15:83:09:0F:B6 version 3 manufacturer 15 class 0x7c0104
	supported settings: powered connectable fast-connectable discoverable bondable link-security br/edr debug-keys phy-configuration 
	current settings: powered connectable discoverable bondable br/edr 
	name imedv11
	short name 
[imedv11 myuser]# hciconfig -a hci0
hci0:	Type: Primary  Bus: USB
	BD Address: 00:15:83:09:0F:B6  ACL MTU: 1017:8  SCO MTU: 64:8
	RX bytes:1572 acl:0 sco:0 events:78 errors:0
	TX bytes:1323 acl:0 sco:0 commands:78 errors:0
	Features: 0xff 0xff 0x8d 0xfe 0x9b 0xf9 0x00 0x80
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Name: 'imedv11'
	Class: 0x7c0104
	Service Classes: Rendering, Capturing, Object Transfer, Audio, Telephony
	Device Class: Computer, Desktop workstation
	HCI Version: 2.0 (0x3)  Revision: 0x4027
	LMP Version: 2.0 (0x3)  Subversion: 0x430e
	Manufacturer: Broadcom Corporation (15)

[imedv11 myuser]# lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c08e Logitech, Inc. MX518 Gaming Mouse
Bus 001 Device 004: ID 0a5c:2039 Broadcom Corp. BCM2045 Bluetooth
Bus 001 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 006: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 005: ID 046d:c248 Logitech, Inc. G105 Gaming Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Do you have any ideas, what I can do?

I also uninstalled all bluetooth tools and libs and installed only the recommended tools mentioned on the archlinux bluetooth page.

In generel what you can do, when such errors occur is to Google (use a search engine of your choice) the device name (BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)).

That being said: I tried this and I didn’t really find anything conclusive.

One person got it working by installing the right Windows drivers in a Windows VM to activate the Bluetooth (absolutely wild).
But I don’t think it’s the problem here?

It seems that this device has problems running on alot of peoples machines (from what I have gathered) even tho it seems the drivers are implemented into the Linux kernel from version 2.6 onwards…

I also want to mention that it seems to run a rather old version of Bluetooth - which might cause problems when you try to pair it with newer devices (I remember trying to pair my jbl Bluetooth speakers with my pc over a dongle - but the speakers ran Bluetooth version 4 and the dongle only 2 so it didn’t work at all).

Sorry I couldn’t be of more help, but maybe you find something by looking the devices name up.

1 Like