System lag and slow rendering on both primary and external monitors when run on NVIDIA card

I know, and it’s OK. If you don’t want to continue, that’s fine. But you can’t expect someone to automagically know you have an old, EOL and thus unsupported kernel still installed. Especially when your info shows kernel 5.19:

We might be good. But we’re not that good.

I understand that you are trying to help, but it really hasn’t moved one bit towards solution. Till now i have deleted the drivers, deleted conky and it’s dependencies, and also stuck in tty. Now i am typing this from my phone

Now i tried switching kernels even then i am getting same errors. Previously my kernel was 519. Now i switched to 515, still getting not found linux513-nvidia.
How can i now get the xserver started and install the drivers? Nvidia-smi is working and outputs driver Version 515.65

As I said, if you’ve got a relatively new USB thumb drive available, you can chroot, from where you can more easily work.

Provide the output of:

ls /boot

Please. And doing it from a chroot environment would make it that much easier.

To enter a chroot environment

  1. Ensure you’ve got a preferably relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a

If you have more than one Linux installation, select the correct one to use from the list provided.

If sucessfully done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment oon your computer, so any changes you make will persist after a restart and can cause damage.

Don’t have a live USB with me rn.
I deleted the 513 kernel and now it installed video-hybrid-intel.
However still not able to starts Xorg

What happens when you run:


Not able to switch to GUI. the screen goes blank for a second, and then reverts back to TTY. Inserting image for reference.


OK, can you ping?

ping -c 4

Yes, am able to ping

Interesting thing. Installing drivers only installed video-hybrid-intel.
So mhwd --listinstalled
Outputs only


Video-linux is missing

Cool. I’m going to be honest now. I don’t know if this will work, especially seeing as I’ve never done anything like it. So continue at own risk!

Backup the X11 config files and remove them:

sudo  mv /etc/X11 /etc/X11.backup

Now reinstall xorg-server, forcing overwrite of any conflicts:

pamac install xorg-server --overwrite='*'

If successful, hold your thumbs, cross your heart, and reboot.

That seems to be OK. I don’t have it, either.

Doesn’t work. :grinning:

Hmmm…OK, honestly? I’m becoming s little lost here. The only other thing I can think of is that maybe xorg-server didn’t do anything because it wasn’t really uninstalled. In which case, this command might be better:

pamac reinstall --overwrite='*' xorg-server

If this doesn’t work, I’ll have to call in reinforcements.

Did this, doesn’t work.
No problem, i have already texted one guy who i think can help. Waiting for his reply.
I also have a dual boot system, will have to use windows for now

Glad you have the option at least. You can always, maybe even should download a new ISO and make a new thumb drive from Windows.

Yeah, will try that once i get the USB. Thanks anyways.

1 Like

how did you switched to only nvidia? are you using optimus?

Yeah, used optimus. However now the problem is different. I can’t get out of tty as i tried deleting the drivers. Couldn’t install. :man_facepalming:

well you need to remove optimus … and also optimus manager-qt/plasma, check with:
pacman -Qs optimus

Let me try. Hope this works