System is sluggish after system upgrade

Ok

Did that, thanks for the suggestions. I rebooted I do see verry different thing which is what I expect after resetting all conifg. But the issue still remains. The system is still sluggish. It gets even worse when I have PHPStorm running. It ran smooth before.

What steps can I take more to debug the issue?

Not sure what to do now. Would it be possible to revert the upgrade? Not sure if that is a straigtforward solution? I don’t have specific backups or something.

Only if you use timeshift or snapper

No unfortunatly I don’t use those. So the only way forward is debugging. How would I proceed on the debugging journey?

One step could be to create a new user, login and test if this user works better.

Thanks, ok I tried this. At first it looked like it was solved. But after a while I get the same problem of a slow/laggy system.

I got back to my original user and did some tests. When I reboot everything works very very fast. Then I start working day to day and the system gets slower. I cannot pinpoint any patterns when it gets slow. Just when I use programms like Thunderbird, Brave browser, PHPStorm, Spotify, Kate, Terminal etc. Closing one or more apps does not fix the issue. The system keeps being slow.

Any further guidance on how to proceed?

Possibly related: I’ve seen issues in the past with baloo apparently slowing file and directory browsing. Perhaps search the forum for any issues containing baloo slow for example, and see if you find anything that seems similar.

It’s possible but I doubt it’s baloo, one of the last updates to Plasma 5 they changed some settings and it’s now a very low priority and really didn’t interfere at all with my normal use when I tested (re-indexed).

1 Like

I’m dubious too, but nothing much else is jumping out screaming “Pick me!”. :man_shrugging:

The OP might check the partitions for consistency, I suppose, to see if that reveals any issues (fsck), but even that wouldn’t seem to match the symptoms they describe.

I disabled Baloo just for the sake of testing. I will report back if this solves the issue.

Disabling Baloo does not have the desired effect unfortunately.

Your / (root) shows 89% usage; or, at least it did at the time of the inxi output posted earlier. I note also that your /home is not on a separate partition, so its contents too are included in that percentage. Add the dynamic zswap file to the mix, and your entire / utilization is fairly high.

What I’m suggesting here is that all these factors combined may contribute to a progressive slowing down as more data is written to both system and user caches, and the swap file is increased in size while using your favourite apps over a period of time. As the amount(s) of available space decreases, so does the performance.

Only you best know your system, however, if this indeed is causing it, there are a few possible resolutions;

  • Clean your system; empty caches; rid yourself of any unwanted junk; or packages you never use.
  • Offload larger less frequently used personal data to an external USB drive; ISO files and movies, for example.
  • Buy a larger SSD for use with Manjaro: I find a 1TB disk is usually sufficient; but it would depend on your needs.
  • Buy another SSD for /home: I generally suggest a separate partition for /home but a separate disk could be beneficial in this case.

Just something to consider. Cheers.

I cannot translate the GPU information - I don’t have a similar system.

Which GPU is in use?

Just speculations and something for you to experiment with.

Selectively removing plasma configuration files may help → Applications / Manjaro Plasma Reset · GitLab

The inxi output seems to indicate it is your intel GPU driving the show - and your desktop seems to be x11.

With plasma 6 the focus has shifted to Wayland and Intel on wayland works without known issues.

Please see The issue with Plymouth and the Black Screen if you want to use Nvidia as it does appear to be everything but a walk in the park.

Current testing sync can be followed [Testing Update] 2024-06-11 - Mesa, KDE Frameworks, Octopi, LibreOffice - #2 by philm for known issues and possible solutions before they reach stable

I removed files, it looks like below now. Is this ok? My main working partition has +/- 5% free space.

xps ~> df -h
Filesystem      Size  Used Avail Use% Mounted on
dev              16G     0   16G   0% /dev
run              16G  2,5M   16G   1% /run
/dev/nvme0n1p2  452G  400G   29G  94% /
tmpfs            16G  390M   16G   3% /dev/shm
/dev/loop5      100M  100M     0 100% /var/lib/snapd/snap/remmina/6419
/dev/loop0      196M  196M     0 100% /var/lib/snapd/snap/arduino/70
/dev/loop4      100M  100M     0 100% /var/lib/snapd/snap/remmina/6358
/dev/loop2       39M   39M     0 100% /var/lib/snapd/snap/snapd/21465
/dev/loop3       56M   56M     0 100% /var/lib/snapd/snap/core18/2823
/dev/loop1       64M   64M     0 100% /var/lib/snapd/snap/core20/2318
/dev/loop6      196M  196M     0 100% /var/lib/snapd/snap/arduino/85
/dev/loop7       75M   75M     0 100% /var/lib/snapd/snap/core22/1122
/dev/loop8       56M   56M     0 100% /var/lib/snapd/snap/core18/2812
/dev/loop10      39M   39M     0 100% /var/lib/snapd/snap/snapd/21759
/dev/loop9       75M   75M     0 100% /var/lib/snapd/snap/core22/1380
/dev/loop11      64M   64M     0 100% /var/lib/snapd/snap/core20/2264
tmpfs            16G   78M   16G   1% /tmp
/dev/nvme0n1p1  300M  288K  300M   1% /boot/efi
tmpfs           3,2G  104K  3,2G   1% /run/user/1000

It doesn’t seem much different from what I can see.

Are you a Steam Gamer? If so, maybe some of those games are taking up a lot of space; some of the downloaded data for games can be 10G+ each.

You’re using Snap apps - using the Official Repository version of some of these would also save an amount of space; even .appimage or .flatpak might be more performant; and certainly allow better security than Snap (but that’s not relevant to the topic).

I would prefer as much unused space as possible; perhaps a total utilization of 75% (approx); but only you can know how much you can comfortably work with.

Create more space if you can, and see how it then performs through the week. If you feel the system slowing again, compare the usage % when it happens.

That’s all I can suggest. Let us know if it seems to make any difference.

Cheers.

Filling a system to over 80% is unhealthy and will sooner or later end in disaster.

:footprints:

I just switched from X11 to Wayland, there was a dropdown on the login screen where I could choose one of those (didn’t know about this feature). Right away the system feels instand and snappy. I have been working for an hour now, but I am confident this solved the issue(s) since it feeld really fast and stable.

I want to thank everybody who have contributed with answers and suggestions! Very much appreciated!

Btw: is it possible fonts are rendered a bit different in Wayland? I notice some difference in some apps. They seem a bit fuzzy compared to before. But it can also be that I need to adjust to the (minor) changes, I am not sure.

yes

Indeed - I have been there for along time …

Appreciate youre feed-back :smile:

Yes. I recall this was mentioned a few times recently. Search the forum and you may find the relevant threads. I didn’t pay much attention to it, despite using Wayland myself, as I hadn’t noticed any font blurring and presumed it must have been Nvidia related (as so many issues seem to be).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.