The issue with Plymouth and the Black Screen

Some might notice, especially when you are using testing branch that the plymouth version often jumps back to 22.02.122 version. That is to us the last known version, which also works with broken KMS setup.

Nvidia users and now also some with AMD GPUs might see the black screen issue on newer versions of plymouth.

We are discussing this issue also with upstream: KMS fallback (#252) · Issues · plymouth / plymouth · GitLab
In our forum you may find this thread interesting: Black Screen with Plymouth - Cause and Solution

Most likely without a git-bisect we might not find the cause of the issue, as this can be many.

SimpleDRM is something upstream is looking at to enable by default:

However it is not always a smooth ride: [ SOLVED ] Plymouth can't start SDDM? / [testing] Repo Forum / Arch Linux Forums, [Bug 1194384] New: [simpledrm][UEFI] Black screen until KMS engages, then system freezes, when KMS is defective and plymouth=0 - openSUSE Bugs - openSUSE Mailing Lists, Comment #91 : Bug #1970069 : Bugs : plymouth package : Ubuntu


Seems the thing goes even deeper. We all know that Fedora is the trend giver in new tech on Linux. So dropping legacy stuff which is not maintained anymore might be a good thing, at some point. Changes/ReplaceFbdevDrivers - Fedora Project Wiki

However not all companies adopted the new approach. One of those is Nvidia. Their 390 driver doesn’t get any updates. All others should support simpledrm by now. Well, or not. There is a kernel patch to workaround this issue: drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set · archlinux/linux@7bfc7b3 · GitHub

This exact patch created another Black Screen issue after we tried to enable those settings for our Nvidia users by default: [pkg-upd] 550.90.07-2 (e7846495) · Commits · Packages / Extra / nvidia-utils · GitLab

So why I got those issues? Normally you guys test it for me - right? Hmm. Actually all testing is done by the community using Manjaro Linux. We as developers not always have all devices to test on and also it will take a long time to verify all setups before we can do an update.

So why it landed in stable branch? There was another issue with Bluetooth and other things in newer kernel series. So the whole set of kernels got fast tracked to stable. Those who tested the Nvidia change use their Laptops with Nvidia cards in dedicated mode and not in hybrid.

So what is the fix? Well, since we reverted the stuff we changed, it should work again. The whole Black Screen issue is very complex. Even Canonical is struggling with it: Bug #1965303 “Migrate from fbdev drivers to simpledrm and DRM fb...” : Bugs : linux package : Ubuntu

So since when do we have the issues? Arch adopted the change in 6.4.8 kernel: FS#73720 : [linux-zen] using new DRM based Linux fb driver instead legacy fbdev driver as Fedora do On our end we added it via 6.5.0rc1. Older kernels like 6.1 series and below don’t ship CONFIG_SYSFB_SIMPLEFB enabled.

You can check how Nvidia should be set-up for KMS and early KMS: NVIDIA - ArchWiki

But with all that combination and kernel patches setting those flags on hybrids or non Nvidia systems might create issues: which might result in a Black Screen


Lol. The amount of problems Plymouth causes, all for a tiny bit of eye candy, is a complete waste of everyone’s time IMHO. :stuck_out_tongue:


:point_up_2: :100:
It’s hard to disagree with that…