System is presenting strange "lags", and sometimes it is impossible to work

Hi everyone!

i would be very grateful in to count with your help, if possible.

Today I installed Manjaro (I’m coming from Kubuntu). But, the system started presenting strange “lags”. I really don’t know how to explain this, but it seems sometimes the things are doing some “hicups”.

Lags, etc, I don’t know. But, for example, if I try to open Konsole sometimes everything froozes . And this happens with several apps and moments.

I am really lost here, and don’t know even from where to begin to discover where’s the problem.

Below is the output of inxi:

CPU: quad core Intel Core i7-7700HQ (-MT MCP-)
speed/min/max: 890/800/3800 MHz Kernel: 5.15.60-1-MANJARO x86_64 Up: 23m
Mem: 3569.1/15882.6 MiB (22.5%) Storage: 2.27 TiB (21.9% used) Procs: 251
Shell: Zsh inxi: 3.3.20

Thanks in advance.

can you report

inxi -Fza
sudo pacman -S cpupower 
sudo cpupower frequency-info
sudo mhwd-kernel -li

since its a fresh install its probably related to baloo indexer, so go to system settings/search/file search and uncheck all the options, delete the index, click apply and see if it helped

Thank you! Sure! :slight_smile:

inxi -Fza
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=48a23c44-4ccb-44d2-9319-62b3469c0221 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Predator G3-572 v: V1.22
    serial: <superuser required>
  Mobo: KBL model: Sienta_KLS v: V1.22 serial: <superuser required>
    UEFI: Insyde v: 1.22 date: 03/15/2019
  ID-1: BAT1 charge: 44.3 Wh (100.0%) condition: 44.3/48.9 Wh (90.4%)
    volts: 16.6 min: 15.2 model: LG 004B384234314341 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 843 high: 900 min/max: 800/3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 875 2: 865 3: 808 4: 801
    5: 800 6: 801 7: 900 8: 900 bogomips: 44817
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:591b
    class-ID: 0300
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Acer
    Incorporated ALI driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 01:00.0 chip-ID: 10de:1c20 class-ID: 0300
  Device-3: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-9:5
    chip-ID: 0408:a060 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x61ed built: 2016 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.1.6
    direct render: Yes
  Device-1: Intel CM238 HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171
    class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: Acer Incorporated
    ALI driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 10de:10f1 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.1 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0f1 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 2.27 TiB used: 510.92 GiB (21.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: ACM1 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk
    model: Extreme 55AE size: 465.73 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 3001 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 502.18 GiB size: 493.22 GiB (98.22%) used: 12.29 GiB
    (2.5%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 57.4 MiB
    (59.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.23 TiB size: 1.21 TiB (98.35%) used: 258.44 GiB
    (20.9%) fs: ext4 dev: /dev/sda6 maj-min: 8:6
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 29.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda7 maj-min: 8:7
  System Temperatures: cpu: 43.0 C pch: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 273 Uptime: 29m wakeups: 1 Memory: 15.51 GiB used: 3.53 GiB
  (22.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: 1176 pacman: 1167 lib: 314
  flatpak: 9 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.20
sudo cpupower frequency-info
analisando o CPU 0:
  driver: intel_pstate
  CPUs que rodam na mesma frequência de hardware: 0
  CPUs que precisam ter suas frequências coordenadas por software: 0
  maior latência de transição:  Cannot determine or is not supported.
  limites do hardware: 800 MHz - 3.80 GHz
  reguladores do cpufreq disponíveis: performance powersave
  política de frequência atual deve estar entre 800 MHz e 3.80 GHz.
                  O regulador "powersave" deve decidir qual velocidade usar
                  dentro desse limite.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.29 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes
Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515

@brahma ,

I’ll try. Many thanks!

can you check

sudo pacman-mirrors -c all
sudo pacman -Syyu

you can also add sensors ( follow uppercase value )

sudo pacman -S lm_sensors
sudo sensors-detect

Thanks once again.

So, below is the sensors outpub:

Adapter: ISA adapter
Package id 0:  +42.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +40.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: ACPI interface
in0:          16.65 V  
curr1:         0.00 A  

Adapter: Virtual device
temp1:        +35.0°C  

Adapter: Virtual device
temp1:        +44.0°C  

Adapter: ACPI interface
temp1:        +27.8°C  (crit = +119.0°C)
temp2:        +29.8°C  (crit = +119.0°C)

The sudo pacman-mirrors -c all command returned a series of queries. The only problem (in red - I suppose this was a problem) was wtih Bangladesh (read timeout).

After that, I ran sudo pacman -Syyu, and the system seems to be upgrading without problems. The only thing I am afraid to have done wrong is that I accidentaly answered Yes to a series of questions, as for example the one mentioning “Change at-spi2-atk for extra/at-spi2-core?”.

no it was good always says Y to go forward.

is there any change since reboot ?

Understood. Thank you.

So, the system is updating right now. I think the total size is around 2GB. I will await it finishes, restart and check. :slight_smile:

Hi again,

Just updating the thread. :slight_smile:

I think the problem is solved (or almost solved). And I think that it was solved by the two procedures you’ve suggested me ( @stephane and @brahma ).

I also noticed a lot of work when I acessed system settings ==> searches. That was probably also causing slowness.

Now I’ll finish somethings and reboot the system.

Thank you very much for all the support and kindness.

Everything is looking very good! Thank you very much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.