System is freezing randomly. Do i need to move out of manjaro?

After installing manjaro on brand new SSD 2TB on HP z400 system. Manjaro randomly freezes. I tried to disable the gnome ext’s as per suggestions provided by this forum but still no use. Today while giving an interview it froze completely and i have no other choice except Hard press reboot( i know this was very bad method but no choice). There is no other OS running on it and there is no swap issue at all as i am using whole 2TB for the OS and also i used auto partition during installation.

Here is my inxi -Fazy output:

System:
  Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=d0942261-e115-4c23-84a9-273f812ad8b2 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Z400 Workstation v: N/A
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Hewlett-Packard model: xxx v: C serial: <superuser required>
    BIOS: Hewlett-Packard v: 7xxxxv03.57 date: 07/15/2013
CPU:
  Info: model: Intel Xeon W3520 bits: 64 type: MT MCP arch: Nehalem level: v2
    built: 2008-10 process: Intel 45nm family: 6 model-id: 0x1A (26) stepping: 5
    microcode: 0x1D
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1620 high: 1765 min/max: 1596/2661 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1600 2: 1600
    3: 1600 4: 1600 5: 1600 6: 1765 7: 1600 8: 1600 bogomips: 42684
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA G96GL [Quadro FX 380] driver: nouveau v: kernel non-free:
    series: 340.xx status: legacy (EOL) last: release: 340.108 kernel: 5.4
    xorg: 1.20 arch: Tesla process: 40-80nm built: 2006-13 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 ports: active: DVI-I-2 empty: DVI-I-1
    bus-ID: 0f:00.0 chip-ID: 10de:0658 class-ID: 0300 temp: 58.0 C
  Device-2: Trust HDH Webcam USB type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 2-4:4 chip-ID: 145f:02ec class-ID: 0102 serial: <filter>
  Display: x11 server: X.org v: 1.21.1.6 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: nouveau gpu: nouveau display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: DVI-I-2 model: Asus VE247 serial: <filter> built: 2013
    res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 size: 531x299mm (20.91x11.77")
    diag: 609mm (24") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL v: 3.3 Mesa 22.3.1 renderer: NV96 direct render: Yes
Audio:
  Device-1: Intel 82801JI HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel bus-ID: 2-4:4 v: kernel bus-ID: 00:1b.0
    chip-ID: 145f:02ec class-ID: 0102 chip-ID: 8086:3a3e class-ID: 0403
    serial: <filter>
  Device-2: Trust HDH Webcam USB type: USB driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k5.15.85-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe
    vendor: Hewlett-Packard driver: tg3 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: N/A bus-ID: 01:00.0 chip-ID: 14e4:1684 class-ID: 0200
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: d0c0
    bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
  Local Storage: total: 1.82 TiB used: 22.93 GiB (1.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 045 scheme: MBR
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 22.93 GiB (1.3%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 59.0 C
  Fan Speeds (RPM): cpu: 3006 fan-2: 0 fan-3: 0 gpu: nouveau fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: N/A gpu: nouveau mV: 1000.00
Info:
  Processes: 280 Uptime: 11h 57m wakeups: 1 Memory: 15.61 GiB
  used: 6.1 GiB (39.1%) Init: systemd v: 252 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1319
  libs: 343 tools: gnome-software,pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.24

… just saying that this is a double non sequitur :sunglasses:
because you do not have any swap - so, of course it can’t be an issue …
and because having used auto partition and the whole drive also doesn’t magically prevent any problems

with 16GB RAM and no swap you can very well run into problematic situations

3 Likes

Thank you Nachlese for the reply. Yes after going through the output i too figured out that there is no swap and did create swapfile for 32GB based on swap recommendations from forum [Swap#Do_I_Need_Swap]
I would like to create a separate partition but don’t know how to create. Any help would be appreciable

Paritial inxi output:

AID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: d0c0
    bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
  Local Storage: total: 1.82 TiB used: 54.19 GiB (2.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 045 scheme: MBR
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 54.19 GiB (3.0%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 31.25 GiB used: 516 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:

Can you post fdisk -l and/or blkid ?

this is probably one of the reasons for those freezes:

you have old nvidia gpu, which is no longer supported by manjaro and other distros…
you can install older kernels:

sudo mhwd-kernel -i linux54
sudo mhwd-kernel -i linux510

and try with them and see how it works…
or you can install the drivers manually by checking this topic:


another possible reason could be that you are on RAID:

instead of being on AHCI, you can switch to AHCI in bios, but if you are dual booting with windows, you will not be able to boot into windows after switching…

In addition to the info @brahma provided, and as someone who’s tried running the same generation of hardware (requiring the 340.108 legacy driver) on open source nouveau, I can say that cinnamon, kde and especially gnome are a definite no-no (Xfce, mate, openbox and awesome editions run ok but temps are generally higher).
My tip would be: pick the right edition (LTS kernels only and ideally starting with the ‘minimal’ versions on open source nouveau), configure desktop to ease load on graphic, then install the above mentioned 340.108 legacy driver.

The swap file that you now have is just as good - no need to invest time in trying to use a partition instead.
It probably does not need to be that big either, equal the RAM size should be plenty.
You can look at something like zramswap, mentioned here:

Improving performance - ArchWiki

to give you more leeway.

I can’t help with the potential graphics issue though.

Just enable zram, it is amazing nobody has suggested this to you. It works like a charm in my SSD, no damage at all and no need for swap file or swap in general

Thank you Lycan. How to enable Zram?

Thank you @brahma, 6x12 for all suggestions. I will try to check the device drivers.

Feel free to try but I wouldn’t. zram is for speeding up swap, not for extending RAM.

zswap is already enabled by default, it’s similar to zram but can also be backed by a swapfile/partition, which makes it superior IMO.

Zswap - ArchWiki
Improving performance - ArchWiki

I’d stick with your swapfile for now.

1 Like

Disk /dev/sda: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: CT2000MX500SSD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x8050eb1d

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 3907024064 3907022017 1.8T 83 Linux

Can you post the output of top ?

You have a swap file.

What programs are running when it freezes?
How much RAM was used at time of freezing?
Have you checked for BIOS updates?

1 Like