System hangs out/freezes on external monitor after last update

I have hybrid graphics configuration managed by nvidia-prime outputting the image on external monitor through hdmi cable.
Everything went well till I rebooted from the last update which contained nvidia 525.60.11.
The issue is that system displayed on external monitor hangs out significantly on every basic action: activating any opened window takes up to 1 min, as well as switching between icons or window buttons or launching any app, video renders extremely slow; making work practically impossible. While on the main display (laptop) everything goes fluently.
I tried switching to previous kernel (5.15), reinstalling nvidia-prime, linux**-nvidia, nvidia-utils (also mhwd -a pci nonfree 0300), removing .Xauthority and nvidia.conf files, but nothing helped.

$ mhwd-kernel -li
Currently running: 6.1.0-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux510
   * linux515
   * linux60
   * linux61

$ inxi -G
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 525.60.11
  Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau,vesa dri: iris gpu: i915
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics 630 (CFL

$ sudo mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI

try deleting the kscreen folder in your home/.local/share, reboot

Done. Now the external monitor only displays an “empty” wallpaper and checking-in/applying it as "Primary" (in Display configuration) does not make any effect. (so when I run some youtube HD video: the video runs on laptop but the sound goes from the external display)
Anything else should be made?

unfortunately that was it, there were some recent issues with dual monitor setup on kde and nvidia, and this helped in some cases…
try creating a new test user, reboot, log in with it and see if it helped

I’ve tried to login in with my test user and had the same issue.
Another observation is that when dragging some window out of the right boundary of the active screen and making it appear on external monitor - it seems rendering fine there. It looks like it troubles with dual monitor arrangement.
But, as I mentioned earlier, checking-in/applying it (ext. monitor) as "Primary" (in Display configuration) does not make any effect, more precisely, that action only pulls up the taskbar there but all new apps and windows still open on laptop display.

did you tried with different kernels?
also post output from:
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"

I tried 5.15 but had the same.

[roman@roman-pc ~]$ ls /etc/modprobe.d
mhwd-gpu.conf  nobeep.conf
[roman@roman-pc ~]$ find /etc/X11/ -name "*.conf"

try reinstalling the drivers:
sudo mhwd -r pci video-hybrid-intel-nvidia-prime
install them again:
sudo mhwd -i pci video-hybrid-intel-nvidia-prime
disconnect the external monitor;
delete again the kscreen folder;
reboot - the monitor still disconnected - then connect it again when you are in desktop

Done. The same issue, with additional drawbacks: empty (non-recognized filled “grey”) taskbar icons and ugly, small fonts in window titles.

you can also try changing refrehs rates on the external monitor;
also change the resolution, start with the lowest, click apply, and then increase one at a time…

if it didnt helped, try the 470 version:
sudo mhwd -r pci video-hybrid-intel-nvidia-prime
install the 470:
sudo mhwd -r pci video-hybrid-intel-nvidia-470xx-prime

When I check Replica of: builtin screen for external monitor - it “copies” the output, but that’s not what’s needed.
When I use Fn + F8 shortcut I’m able to dim the builtin screen and get the output on external, but it slows down the system extremely.

  1. should I proceed with sudo mhwd -i pci video-hybrid-intel-nvidia-470xx-prime ?
  2. how to recover back normal taskbar icons and window fonts ?

did you tried the different resolutions from system settings/ display configuration?
if it didnt helped, proceed with the installation of nvidia470…

but reading your issues with ugly fonts, icons, taskbar, you describing what others have reported…

yes, does not give a desirable effect

i would no longer bother with installing the 470 version, but try downgrading kscreen and libkscreen, as described here:

install the downgrade package, run the command, and downgrade to the previous version, not the version mentioned in the link, reboot

I’ve installed video-hybrid-intel-nvidia-470xx-prime, rebooted and see no changes.
The icons and fonts has recovered.
I noticed that even just checking off Enabled on “Buil-in Screen” causes system to hang out/slow down.
Should I proceed with sudo DOWNGRADE_FROM_ALA=1 downgrade kscreen libkscreen ?

yes, you have nothing to lose… but you have to install the package downgrade first, then proceed with the command, and select the previous versions, where it worked, reboot … (thats assuming kscreen is the cause)

well, I did a couple of downgrades up to 5.25 … and it did not helped.
It’s unclear how many downgrades(with reboots) should be made.

well thats unfortunate… did you downgrade both of the packages, the kscreen + libkscreen?
do you have a timeshift backup?
also provide logs, maybe there will be something:
journalctl -b0 -p4 --no-pager



(forum throws error due to big file, here’s a link)

I have some trouble in one time
For me help Downgrade kscreen and libkscreen to 5.25.1

  1. Install downgrade
    sudo pamac install downgrade
  2. Enter the command
    sudo DOWNGRADE_FROM_ALA=1 downgrade kscreen libkscreen
    and choose verison 5.25.1
  3. Reboot
    sudo reboot

i found this in other topic

Icons on the taskbar are not visible (drivers problem)

I too have nvidia gpu + intel gpu
I try delete cache, edit /etc/default/grub, reinstall plasma \ xorg

But now we have only 2 work way how to fix it

  1. Downgrade kscreen and libkscreen to 5.25.1<=
  2. Install Plasma LTSC ( include kscreen and libkscreen to 5.25.1<= )
  3. Not per-moment - When your log on in plasma, try to upload new wallper< you screen to bee a black and all to be normal ( after logout, need do it again )

I use video-hybrid-intel-nvidia-prime
and for me second display output only normal in thunderbolt → hdmi

Second fix your can try -
Install optimus manager
and use only Nvidia gpu
optimus-manager --switch nvidia