System Gets Unresponsive (KDE)


My system suddenly got very unresponsive. Had to restart (power button), it is unresponsive immediately after booting.

Luckily I had a Timeshift image I took, restored it and worked fine… then again it happened, and restored the same image. Tried to find a solution, but not really convincing for me it’s about swap as it was unresponsive just after boot!

Here is my system:

    ~  inxi -Fxxx                                                                                     ✔ 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "ar_EG.UTF-8",
        LC_IDENTIFICATION = "ar_EG.UTF-8",
        LC_MEASUREMENT = "ar_EG.UTF-8",
        LC_MONETARY = "ar_EG.UTF-8",
        LC_NAME = "ar_EG.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LC_PAPER = "ar_EG.UTF-8",
        LC_TELEPHONE = "ar_EG.UTF-8",
        LC_TIME = "en_001.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:    Host: ManjaroLenovo Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20157 v: Lenovo G580 serial: <superuser required> Chassis: 
           type: 10 v: 0.1 serial: <superuser required> 
           Mobo: LENOVO model: Emerald Lake 2 v: FAB1 serial: <superuser required> UEFI: LENOVO 
           v: 62CN34WW date: 04/26/2012 
Battery:   ID-1: BAT0 charge: 24.8 Wh (98.4%) condition: 25.2/42.8 Wh (59.0%) volts: 12.1 min: 10.8 
           model: SMP LNV-L11M6Y01 type: Li-ion serial: 6365 status: Unknown 
CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 cache: 
           L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19961 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1244 3: 1197 4: 1197 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
           Device-2: Acer Lenovo Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-1.5:4 
           chip-ID: 5986:0294 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting 
           alternate: fbdev,vesa resolution: 1366x768~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl v: kernel port: efa0 
           bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280 
           IF: wlp2s0 state: up mac: 08:ed:b9:97:27:0f 
           Device-2: Qualcomm Atheros AR8162 Fast Ethernet vendor: Lenovo driver: alx v: kernel port: 2000 
           bus-ID: 03:00.0 chip-ID: 1969:1090 class-ID: 0200 
           IF: enp3s0 state: down mac: f0:de:f1:fd:53:97 
Bluetooth: Device-1: Foxconn / Hon Hai Broadcom BCM20702 Bluetooth type: USB driver: btusb v: 0.8 
           bus-ID: 1-1.4:3 chip-ID: 0489:e032 class-ID: fe01 serial: 08EDB9972710 
           Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
Drives:    Local Storage: total: 465.76 GiB used: 128.37 GiB (27.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST9500325AS size: 465.76 GiB speed: 3.0 Gb/s type: HDD 
           rpm: 5400 serial: 5VEV48VG rev: LVM1 scheme: GPT 
Partition: ID-1: / size: 457.09 GiB used: 128.36 GiB (28.1%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 46.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 200 Uptime: 9m wakeups: 1 Memory: 3.69 GiB used: 1.34 GiB (36.3%) Init: systemd 
           v: 248 Compilers: gcc: 11.1.0 Packages: pacman: 1240 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.06 
    ~                                                                                                 ✔ 
    ~                                                                                             INT ✘ 

Out of curiosity I noticed something about locale at the beginning and about swap.

It is working fine now after latest Timeshift restore.

NB: I am bilingual and have both languages on keyboard working as expected.
I am keeping all interfaces in English.

What might be the problem? What can be done to avoid having this issue in the future?
Thanks a lot.

Just to update you.

sudo locale-gen

export LC_ALL=en_US.UTF-8

Seems to sort out the locale thing
Now, I have:

   ~  inxi -Fxxx  :heavy_check_mark:
System: Host: ManjaroLenovo Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux
base: Arch Linux

EDIT 2: rebooted, same error appears again :roll_eyes:

1 Like

Please read this:



Ah, you already did that! :+1:

Do you have a compelling reason to be on 5.13 Stable? If not, does this also happen on 5.10 LTS?

Read this, please! :rainbow: :unicorn:

After you’ve remedied all of the above, please provide an inxi --admin --verbosity=7 --filter --no-host --width as that provides more detailed information while keeping Personally Identifiable Information private…

Thank you Fabby
Thanks for the hint about REISUB/REISUO, I’ll try.



Ah, you already did that! :+1:


But after reboot the same warning is sill there.

Do you have a compelling reason to be on 5.13 Stable? If not, does this also happen on 5.10 LTS?

Well, I’m not that techie, and I would never try to play with the kernel on my own (a bit cowardly here :pleading_face:
I just download the iso, install, update and that’s it. This is what Manjaro gave me.
So, there is no “reason” as such, I just installed! :roll_eyes:

I’ll read about the swap you provided.

Thanks a lot. :+1:

Please read this:

especially the section about Linux has multiple kernels

Then do this:

  • Execute:

     sudo mhwd-kernel --install linux54
     sudo mhwd-kernel --install linux510
  • to ensure grub is showing, execute:

     sudo nano --backup /etc/default/grub
  • Change (or add?) the following 3 lines:


    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

     sudo update-grub
  • Reboot

  • Go to grub’s Advanced options

  • Choose these kernels one by one and try them out one by one and see if that helps.

  • If it does help, remove 5.13.


1 Like

If you think it’s better start with kernel, (my kernel is 5.13). At I see there are:

  • mainline: 5.14
  • stable: 5.13.13 (which I think this is mine)
  • longterm: 5.10.61 (which I believe older - but longterm/more stable than above 2?)

Let me try one kernel at a time.
Which one would be more suitable for my old laptop? The one that might solve the freezing problem?

sudo mhwd-kernel --install linux54
 sudo mhwd-kernel --install linux510

which version does linux54 and linux510 refer to? (am I getting it right that linux510 refers to the long term above? older than my current kernel? why shouldn’t I go straight to the latest?)
Or should I start with sorting out the swap issue?

Forgive me please for being so “illiterate” :pleading_face:

I really appreciate your patience and understanding.
Whatever you see more convenient, what commands to do?

After reading I assume I should install
longterm: 5.10.61
as the most stable now
How to do it without bricking the system? Make it the default kernel? Remove the current one?

Is this Manjaro Kernels - Manjaro

Just to update you.

According to Manjaro Kernels - Manjaro


    ~  uname -r                                                                                       ✔ 
    ~  mhwd-kernel -li                                                                                ✔ 
Currently running: 5.13.12-1-MANJARO (linux513)
The following kernels are installed in your system:
   * linux513
    ~  mhwd-kernel -li                                                                         ✔  5s  
Currently running: 5.13.12-1-MANJARO (linux513)
The following kernels are installed in your system:
   * linux510
   * linux513
    ~                                                                                                 ✔ 

I hope I’ll safely reboot to the new kernel :crossed_fingers:

Rebooted, but to the same kernel, so I updated grub as dear Fabby mentioned.

Will reboot again and see.


Booted and rebooted to same kernel.
So I used Manjaro Settings Manager, and removed the kernel.
I assume it did everything.

checking dependencies...
Packages (2) linux513-5.13.12-1  linux513-broadcom-wl-
Total Removed Size:  102.46 MiB
:: Do you want to remove these packages? [Y/n]
:: Running pre-transaction hooks...
(1/1) Removing linux initcpios...
:: Processing package changes...
removing linux513-broadcom-wl...
removing linux513...
:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating module dependencies...
(3/4) Refreshing PackageKit...
(4/4) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Detecting snapshots ...
Root partition isn't a btrfs filesystem.
This script only supports snapshots of the btrfs filesystem.
If you think an error has occurred , please file a bug report at " "
Nothing to do. Abort.
Found memtest86+ image: /boot/memtest86+/memtest.bin

Done ...

I’m finaly done

    ~  mhwd-kernel -li                                                                                ✔ 
Currently running: 5.10.60-1-MANJARO (linux510)
The following kernels are installed in your system:
   * linux510
    ~    

I will try and see if it doesnt freez, hopefully :crossed_fingers:
:+1: :grin: :hugs: Thanks to Fabby

:man_shrugging: :stuck_out_tongue_winking_eye:

For more info, please read this:

(At a minimum the Linux has multiple kernels section, at a maximum, everything except the “What’s this upstream / downstream business?”


Almost 24 Hrs later.
It seems much better now after taking hints from Fabby

I really appreciate your support.
Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.