System freeze when watching video on any browser

Hi, i have been using manjaro for a while and finally figured why my system kept freezing out of no where. it only happens when im watching any kind of video on any browser (i tried firefox and chrome) i can’t figure out what is wrong here is my pc spec

  Kernel: 5.4.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=0eae79a7-3429-4499-8846-e654191bb135 rw nouveau.modeset=0 
  video=astdrmfb video=efifb:off quiet pcie_acs_override=downstream 
  intel_iommu=on apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z390 AORUS ULTRA v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: Z390 AORUS ULTRA-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F10b date: 12/18/2019 
  Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 76831 
  Speed: 4300 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4300 2: 4300 
  3: 4300 4: 4301 5: 4300 6: 4300 7: 4300 8: 4300 9: 4300 10: 4300 11: 4300 
  12: 4300 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: NVIDIA vendor: driver: vfio-pci v: 0.2 
  alternate: nouveau,nvidia_drm,nvidia bus ID: 01:00.0 chip ID: 10de:2206 
  Device-2: NVIDIA TU106 [GeForce RTX 2070] vendor: ASUSTeK TURBO 
  driver: nvidia v: 455.23.04 alternate: nouveau,nvidia_drm bus ID: 02:00.0 
  chip ID: 10de:1f02 
  Display: x11 server: X.Org 1.20.9 driver: modesetting FAILED: nvidia 
  display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
  OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 455.23.04 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA vendor: driver: vfio-pci v: 0.2 
  alternate: snd_hda_intel bus ID: 01:00.1 chip ID: 10de:1aef 
  Device-3: NVIDIA TU106 High Definition Audio 
  vendor: ASUSTeK TURBO-RTX2070-8G driver: snd_hda_intel v: kernel 
  bus ID: 02:00.1 chip ID: 10de:10f9 
  Device-4: Corsair Razer Viper type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-11.3:6 chip ID: 1b1c:0a17 
  serial: <filter> 
  Sound Server: ALSA v: k5.4.69-1-MANJARO

These are both a bit odd. Why do you have them?

According to Manjaro - Branch Compare no branch currently has that kernel.
Are you up to date?

sudo pacman-mirrors -f && sudo pacman -Syyu

video=astdrmfb im not sure what that is

pcie_acs_override=downstream, i am using this to properly passtrough my gpu to my kvm by default 2 of my gpu are in the same iommu group using the pcie acs patch it resolves that problem so i can properly do the gpu passtrough

Kernel: 5.4.69-1-MANJARO i am using this one because when i use kernel 58 the problem is even worst.

Me neither … but my guess is it has to do with video … I wonder how your system performs without it …

I mean stable branch is on 5.4.67-1, and testing branch is 5.4.71-1 … so your kernel version seems odd.

Did you check the updates?

for the acs patch i need to rebuild the kernel. so i should use the 5.4.67?

I see … you are manually building your own kernel ?
Well then yes … it makes sense to match up with whatever branch you are using.
And of course … you are going to need to make sure the modules are loaded and all … so either make sure mhwd is integrated, or to do it manually, etc.

im not sure what you mean.

I think it has something to do with the hardware acceleration. Would be good to see if there hints in:

journalctl -b -0

I guess there are some conflicts.

Also recompile your kernel with the current lts version :wink:

Could you link me to the lts version whenever i type the git clone command for linux54 it just grabs the 5.4.69 also journal is not a valid command

Sorry, the command is journalctl… corrected it.

Here is the repo: Projects · Packages / Core / linux54 · GitLab

Given the exact version/release that Stable Branch is on … probably want to clone from this commit:

maybe … There is probably going to be a Stable update soon too it seems.

Hi, I have the same problem for about a year and it is exactly the same as Cobiyyy described: It is always a chance, that my system freezes, when I am watching a video or even watching GIFs or making a video call or doing a screen share for example in Discord.
I also have the Kernel Version 5.4.101-1-MANJARO x86_64, is there any chance that I can switch to a stable branch if that one is unstable or do I have to wait until maybe there will be a stable update?
Here are more infos I got from using the inxi-command:

System:    Host: draketop Kernel: 5.4.101-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Swift SF315-41 v: V1.02 serial: <superuser required> 
           Mobo: RR model: Becks_RR v: V1.02 serial: <superuser required> UEFI: Insyde v: 1.02 date: 12/04/2017 
Battery:   ID-1: BAT0 charge: 41.9 Wh (100.0%) condition: 41.9/48.9 Wh (85.6%) 
CPU:       Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP cache: L2: 2 MiB 
           Speed: 1370 MHz min/max: 1600/2000 MHz Core speeds (MHz): 1: 1370 2: 1382 3: 1512 4: 1371 5: 1378 6: 1377 7: 1476 
           8: 1450 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] driver: amdgpu v: kernel 
           Device-2: Sunplus Innovation HD WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.35.0 5.4.101-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 20.3.4 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.4.101-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci 
           IF: wlp2s0 state: up mac: 98:22:ef:7e:58:f7 
           IF-ID-1: br-53d60a069bbe state: down mac: 02:42:32:fe:82:9b 
           IF-ID-2: docker0 state: down mac: 02:42:8a:be:e4:f6 
Bluetooth: Device-1: Lite-On type: USB driver: btusb 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 238.47 GiB used: 90.25 GiB (37.8%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW256G7 size: 238.47 GiB 
Partition: ID-1: / size: 233.43 GiB used: 90.25 GiB (38.7%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 64.8 C mobo: N/A gpu: amdgpu temp: 64.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 228 Uptime: N/A Memory: 7.49 GiB used: 1.41 GiB (18.8%) Shell: Bash inxi: 3.3.02

I’m not sure about AMD graphics, check which config is active now with mhdw -li mhwd -li. If it shows something like video-linux, try changing it to modesetting with sudo mhwd -i pci video-modesetting and reboot then.
If that doesn’t help, I can only suggest installing some newer kernel to see how it works with your APU, maybe linux 5.10 is better in this sense: sudo pacman -S linux510 linux510-headers.

Hello and thank you for your advice.
mhdw is unfortunately a command my linux does not know. Is there also another command or what do I have to install?

It was a typo. I meant mhwd, you could see it in the next command.

Ah alright Thank you,
I have done that and I had indeed the video-linux. I changed it now and hope that it helps. I will write again in about a month if I had any more Problems or if the problem is solved.
Regardless, thanks a lot for your help :slight_smile:

The Problem got a little better when I watch Videos, but my System still freezes, when I do a Screenshare or Video-Call. I installed the Linux510 kernel as well, is there anything I can do additionally?