System doesn't boot after update, found fixes don't help

I recently updated the kernel, and afterwards I rebooted. However, instead of booting I was dumped in a shell with this message
Warning: /lib/modules/5.10.7-3-MANJARO/modules.devname not found - ignoring
mount: /new_root: unknown filesystem type 'ext4'.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
I found similar questions on the Unix StackExchange, and on CupOfLinux, which for some reason I’m unable to link to, and followed the solution that worked for both of them. However, mkinitcpio -p linux510 failed due to a large number of missing modules, so I instead tried mkinitcpio -p linux59, which did complete successfully. However, after I rebooted I received the same error message as before. Any help would be greatly appreciated.

Welcome at the forum, @kriv02 :tada:

Boot a live ISO and enter in a terminal

sudo manjaro-chroot -a

Select your OS, if only 0:0 is indicated enter 1. Then

pacman -Syu linux510

exit twice and reboot.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.