System does not work after latest update

My system:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.17.1-3-MANJARO (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Core™2 Duo CPU E8400 @ 3.00GHz
Memory: 5.8 ГиБ of RAM
Graphics Processor: NVIDIA GeForce GT 1030/PCIe/SSE2

After the last update and the subsequent reboot of my computer, the system became unstable. This was especially evident after the launch of the Chromium-based browser (Google Chrome, Opera).

Since I am a web developer, these two browsers are extremely important to me.
But when I start Google Chrome, Opera, the system freezes.
After rebooting by physically turning off the computer and turning it on with the button, I found that all my system settings had gone wrong and had taken the default settings.
This all happened on the SSD drive on which I installed the system.
Next to the HDD, I also have manjaro installed, since I recently purchased an SSD and did not delete the system on the HDD.

As is usually the case in such cases, I tried to restore the system (on the SSD with the saved pictures on the SSD in TimeShift on the HDD).
However, after I booted from the HDD and went into TimeShift, selecting the btrfs (file system on the SSD) settings, I found that there was not a single snapshot, although I took at least 4-6 backup snapshots just in case.

When searching for information about my case, I found that there are TimeShift snapshots in my system on the SSD, however, all info.json files are damaged in them

I created a new snapshot, copied the info.json file into the snapshot that was taken earlier, however, I found that I had already (through many recovery attempts and various trials) deleted the snapshot that was before the last update. That is, it was not possible to return to the state of the system before the last update.

After I spent a whole day trying to restore Manjaro and all my settings, I, fortunately, just took and transferred the saved copy of the files in the home / user /. * folder from the stored pokii on the HDD (I a snapshot of the SSD in the HDD /in case something happens to the SSD/), and all the settings were thankfully restored.
However, this recovery did not change the fact that the system stopped responding (generally) when loading Google Chrome (… Opera).
After spending a lot of time, looking at a lot of materials on the Internet on this issue, I still did not understand what happened, and I did not succeed in fully restoring the system from TimeShift (both SSD and HDD copies). Since all copies of the system were damaged on the SSD, and the HDD copy was too large (more than 6 million files) and my system could not cope with so much data (TimeShift stopped working and closed).
That is, the most important part was that the system at some points simply stopped responding. And I couldn’t understand why. I tried various kernels (all available), tried to remove the nvidia driver (but I couldn’t do it at that time).
I had to reinstall the system. Due to the fact that it stopped responding and because deleting TimeShift snapshots, I deleted (accidentally [epicfail]) all data from the SSD…/…home folder, because I did not know that the folders in / run /timeshift/@* are just links to actual folders on the system.
In general (I know that it’s funny to you, but I didn’t feel like laughing), after spending almost a day looking for a solution, I didn’t find it, and I had to reinstall the system, now for two reasons (system hang and deleted files in home).
However, with the reinstallation of the system, too, everything was not so smooth. Since I have an encrypted SSD drive, the system simply refused to install on it!
That is, the system was previously installed on an encrypted (LUKS) SSD drive. I booted into a live USB stick and tried to install the system, but it did not install due to an error I did not understand. The disk layout is:
of 128 GB disk (GPT partition table) -
-122 - system with btrfs (with encryption code)
-6 GB swap (no encryption)
-8 MB unallocated area for bios

after 5 or 6 attempts to install the system (I’ve tried GPT/MBR and also tried BTRFS without encryption), nothing worked for me.
I came up with the brilliant idea to completely format the SSD disk before installation, and only then I was able to fully install the system on it.
That is, with disk encryption already present, the operating system was NOT installed on it with different installation data, before I formatted it completely.

Having installed the new system on the SSD, I booted it up and saw the same freeze, only now at the login (after entering the password). That is, immediately after loading (manjaro … loading … login … fail), it hung and did not react to any keyboard actions.

After I uninstalled the nvidia drivers, the system started working. But without drivers for a video card, I can’t imagine how to live. Only standard drivers (video linux proprietary) were installed.

I installed the nvidia drivers, but this time the system, after entering a 100% correct password, threw me again to enter the password. Googling, I realized that it was the nvidia drivers (maybe)…

After the next reboot and the appearance of the user password entry page, I was surprised to see that you can choose another display server (WayLand was loaded by default), I chose x11 and the system started working stably, even after installing the nvidia drivers.

What is the conclusion? After updating the system, as I understood, the default display server became wayland, which did not allow my system to work stably. However, on my system, when entering the password, there was no option to select the display server, perhaps because the theme was not standard, perhaps this function was simply not available on my old system, since the update affected only some parts, but not this one . I mean, they did not programmatically make the display server selection function show up when entering a password when the computer is turned on.

I hope you had fun while reading my article.

It does not require specific answers, however, I hope that the development team will be able to draw important information for themselves from it.


После последнего обновления и последующей перезагрузки моего компьютера, система стала работать нестабильно. Особенно это было видно после запуска браузера на базе Chromium (Google Chrome, Opera).

Так как я являюсь веб-разработчиком, то мне эти оба браузера крайне важны.
Но при запуске Google Chrome, Opera система зависла.
После перезагрузки с помощью физического отключения компьютера и включения кнопкой, я обнаружил, что все мои настройки системы сбились и приняли стандартные настройки.
Это всё происходило на SSD диске, на котором у меня установлена система.
Рядом на HDD у меня также установлена manjaro, так как SSD я недавно приобрёл и не удалял систему на HDD.

Как и обычно бывает в таких случаях, я постарался восстановить систему (на SSD с сохранёнными снимками на SSD в TimeShift на HDD).
Однако, после того, как я загрузился с HDD и зашёл в TimeShift, выбрав настройки btrfs (файловая система на SSD), я обнаружил, что там нет ни одного снимка, хотя я делал как минмум 4-6 резервных снимков на всякий случай.

При поиске информации о моём случае, я обнаружил, что снимки TimeShift в моей системе на SSD есть, однако, в них повреждены все файлы info.json

Я создал новый снимок, скопировал файл info.json в снимок, который делался ранее, однако, обнаружил, что я уже (при многих попытках восстановления и различных проб), удалил тот снимок, который был до последнего обновления. То есть возвратиться к состоянию системы до последнего обновления не представлялось возможным.

После того, как я потратил целый день на то, чтобы попытаться восстановить Manjaro и все мои настройки, я, к своему счастью, просто взял и перенёс сохранённую копию файлов папки home/user/.* из сохранённой их покии на диске HDD (я сделал снимок SSD в HDD /на случай, если что-то случится с SSD/), и все настройки, к счастью, были восстановлены.
Однако, это восстановление никак не отменяло того, что система переставала отвечать (вообще), при загрузке Google Chrome (… Opera).
Потратив массу времени, посмотрев массу материалов в интернете по этому вопросу, я так и не понял, что произошло, а полноценно восстановить систему из TimeShift (и SSD, и HDD копий) у меня не получилось. Так как на SSD все копии системы были повреждены, а HDD копия была слишком большая (более 6 миллионов файлов) и моя система не справилась с таким количеством данных (TimeShift переставал работать и закрывался).
То есть, самой важной частью было то, что система в некоторые моменты просто переставала отвечать. И я не мог понять почему. Я пробовал различные ядра (все доступные), пробовал убрать драайвера nvidia (но у меня это не получилось сделать на тот момент).
Мне пришлось переустановить систему. Из-за того, что она переставала отвечать и из-за того, что удаляя снимки TimeShift, я удалил (случайно [epicfail]) все данные из папки SSD…/…home, так как не знал, что папки в /run/timeshift/@* - это просто ссылки на настоящие папки в системе.
В общем (я знаю, что вам смешно, но мне было не до смеха), потратив почи сутки на поиск решения, я его так и не нашёл, и мне пришлось переустанавливать систему, теперь уже по двум причинам (зависание системы и удалённые файлы в home).
Однако, с переустановкой системы тоже было не всё так гладко. Так как у меня зашифрованный SSD диск, то система на него просто отказывалась ставиться!
То есть, ранее система была установлена на зашифрованном (LUKS) диске SSD. Я загрузился в USB-живой флешки и постарался установить систему, но она не устанавливалась из-за непонятной для меня ошибки. Разметка диска такая:
из 128 ГБ диска (GPT таблицей разделов)-
-122 - система с btrfs (с кодом шифрования)
-6 ГБ swap (без шифра)
-8 MB неразмеченной области для bios

после 5 или 6 попыток установить систему (я пробовал GPT/MBR, а также пробовал BTRFS без шифрования) у меня так ничего и не получилось.
Мне пришла в голову гениальная идея отформатировать полностью диса SSD перед установкой и только тогда я смог полноценно установить на него систему.
То есть, при присутствующем ранее шифровании диска, операционная система НЕ устанавливалась на него с разными данными для установки, до того, как я его не отформатировал полностью.

Установив новую систему на SSD, я загрузил её и увидел всё тоже самое зависание, только теперь уже при входе в систему (после ввода пароля). То есть сразу после загрузки (manjaro … loading … login … fail) она зависала и никак не реагировала ни на какие действия клавиатуры.

После того, как я удалил драйвера на nvidia, система начала работать. Но без драйверов на видео карту я не представляю как жить. Был установлены лишь стандартные драйвера (video linux proprietary).

Я установил драйвера nvidia, но на этот раз система, после ввода 100% правильного пароля меня снова перекидывала на ввод пароля. Погуглив, я понял, что дело в драйверах nvidia (возможно)…

После очередной перезагрузки и появления страницы ввода пароля пользователя, я для себя с удивлением увидел то, что можно выбрать другой сервер отображения (по умолчанию загружался WayLand), я выбрал x11 и система начала работать стабильно, даже после установки драйверов nvidia.

Какой вывод? После обновления системы, как я понял, сервер отображения по умолчанию стал wayland, что не давало моей системе работать стабильно. Однако, в моей системе во время ввода пароля не было варианта выбора сервера отображения, возможно, потому, что тема оформления была не стандартной, возможно, эта функция у меня на старой системе просто отсутствовала, так как обновление коснулось лишь некоторых частей, но не этой. В смысле, программно не сделали так, чтобы функция выбора сервера отображения показывалась при вводе пароля при включении компьютера.

Надеюсь, вы весело провели время, когда читали мою статью.

Она не требует особых ответов, однако, надеюсь, что команда разработчиков сможет почерпнуть для себя из неё важную информацию.

Sorry for your loss, though you may have gained knowledge from that experience.

Here are some pointers from your story.

This may have been helpful: [HowTo] Find error logs

If they went back to default settings, there probably was an issue with your user settings, which are within your home folder. Restoring the system may not have any effect, unless you changed Timeshift settings to also include your home folder – which doesn’t by default.

If you configured timeshift to take BTRFS snapshots of your system on the SSD, the partitions should be on the SSD – most likely the ones you found afterwards. In order to save snapshot on a distinct drive, you need to use the RSYNC mode.

As in, they were not readable? The content was corrupted? Or simply wouldn’t work with the latest browsers’ version?

Do you remember which kernels were installed?
If you kept EOL kernels installed, the update may have removed driver because of dependency incompatibility, since they couldn’t work with those kernels.

Did you do so manually, instead of using timeshift?

I believe the partition would have been reformatted anyway. AFAIK there is no option to “repair system” in calamares.

Think about coming to us earlier next time. :wink:


Thank you for your reply. Indeed, from this situation, I learned a lot about recovery steps, how to remove nvidia drivers when I met Alt + Ctrl + F2 and others.
Undoubtedly, I do not blame duty for anything, because I carry out all my actions myself. It’s a pity that the time wasted, all the files that are very important to me, they are duplicated on some media, including on remote servers, therefore, it’s only a matter of time to restore that system from 0 to completely, just a matter of time.

If you configured timeshift to take BTRFS snapshots of your system on the SSD […].

^ Yes, I found out about it, definitely, I took pictures from SSD to HDD using RSYNC

As in, they were not readable? The content was corrupted? Or simply wouldn’t work with the latest browsers’ version?

^ Some files had broken data at the end, when opening them through VS Code, I saw [null] characters in some files at the end, in some at the beginning of the file.
Some of the files were just empty, but there were also those broken [null] bits.

When I removed them, Timeshift saw these snapshots, but they turned out to be useless for me, since they were created after the system update, and I deleted the snapshots that were created before the update when trying to restore. I can’t say the exact algorithm of actions, because I did too much and spent a lot of time, I just didn’t remember everything.

Do you remember which kernels were installed?[…]

^ I had almost all the latest kernels installed, the drivers on nvidia were also updated and installed with this update. Here is their list: 5.17, 5.15, 5.10. I tried to start the system with all of them, but the result was the same - when you start the browser, everything freezes after 10-40 seconds. And the browser itself did not open at all. First, the internet speed widgets, CPU usage on the taskbar stopped working, then the mouse stopped responding.
My PC also has a CPU overclock, I tried to lower the values ​​to the standard level of both frequency and power, but this did not work. Plus, on a brand new system, I had the same problem until I booted from x11.

Did you do so manually, instead of using timeshift?

^ Yes, I manually transferred and replaced the files, because TimeShift refused to restore more than 6 million files. When creating a snapshot from SSD to HDD, I did not take into account the fact that all TimeShift save files will also fall into the snapshot. That is, from the SSD to the HDD, all backup copies of the TimeShift files on the SSD were also copied to the TimeShift snapshot. Therefore, the Timeshift program, when I tried to recover data from the HDD to the SSD through it, booting from the HDD (working Manjaro), simply stopped working 10-15 minutes after the recovery was prepared by the program itself. Therefore, I tried to transfer the / home files manually and I succeeded. But due to the fact that I started cleaning timeshift snapshots (at that time I didn’t fully understand how exactly it works), I also deleted the @home folder, which was a link to a real folder in the system on the SSD. And at that time, I no longer had a backup copy of the files, since I had already deleted all copies from the HDD and SSD in order to create new clean copies later.

I also had a suspicion that perhaps it was some kind of virus, since all the TimeShift info.json files were damaged on the SSD, and for some reason the files in / home were also damaged. I did not launch programs, perhaps some of the executable files were also damaged.

However, everything was fine before the update. It is possible that the damage caused the computer to freeze and hard reboot, but one can only guess.

I believe the partition would have been reformatted anyway. […]

^ Yes, I perfectly understand that the disk needed to be completely formatted and did manual partitioning of the disk during installation, but all the time I got an error due to the fact that the disk previously had an encrypted partition. Because of this, the system did not want to bet on him.

I did this:

  1. I downloaded the image and wrote it to a USB flash drive.
  2. Booted from the flash drive and started installing Manjaro on the SDD.
  3. Used manual partitioning of the SSD drive, while trying to delete all the data that was previously on it.

At the same time, I set a new password on the disk and started the installation, but the system did not install and an error occurred, since the disk had an encrypted partition earlier. When booting from the HDD (working system), I found that the SSD drive was completely formatted, which was what I needed, and the password for it changed to a new one, but the system was not installed on it, no matter how I tried, until I completely deleted all partitions via GParted and started the installation again. Only with a completely missing encrypted partition, the system was installed on the SSD.

Thank you for the advice to ask for help, I’ll try to use it.

1 Like

this is rolling release, no backup no mercy.