System comes out of sleep instantly

Despite a bunch of searching and following various leads I’ve been unable to get suspend working on my laptop like it used to some months ago.

Here’s the default system info request:

inxi --full --admin --filter --width                                                                                         ✔ 
  Kernel: 6.8.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.8-x86_64
    root=UUID=6c741ddc-adf1-4f76-a514-30f51d2ae500 rw rootflags=subvol=@
    nvidia_drm.modeset=1 quiet splash apparmor=1 security=apparmor
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro
    base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA506QM_TUF506QM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FA506QM v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: FA506QM.314
    date: 01/07/2023
  ID-1: BAT1 charge: 53.5 Wh (67.4%) condition: 79.4/90.2 Wh (88.0%)
    volts: 15.8 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: not charging
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 1164 high: 2895 min/max: 400/4463 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 2231 2: 400 3: 1737
    4: 2649 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 2894
    14: 2895 15: 2222 16: 400 bogomips: 102241
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: always-on; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    off: DP-1 empty: none bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-1 off: eDP-1
    empty: none bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 51.0 C
  Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:3 chip-ID: 322e:202c
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau,radeon alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu,nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: DP-1 model: AOC Q27G2G4 serial: <filter> built: 2020
    res: 2560x1440 dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23")
    diag: 685mm (27") ratio: 16:9 modes: max: 2560x1440 min: 640x480
  Monitor-2: HDMI-A-1 model: Sony TV serial: <filter> built: 2010
    res: 1920x1080 dpi: 30 gamma: 1.2 size: 1600x900mm (62.99x35.43")
    diag: 1836mm (72.3") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-3: eDP-1 model: Najing CEC Panda 0x004d built: 2019 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
    surfaceless: drv: nvidia wayland: drv: radeonsi x11: drv: radeonsi
    inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir
    LLVM 16.0.6 DRM 3.57 6.8.5-1-MANJARO) device-ID: 1002:1638 memory: 500 MiB
    unified: no display-ID: :0.0
  API: Vulkan v: 1.3.279 layers: 7 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3060 Laptop GPU driver: nvidia v: 550.67 device-ID: 10de:2520
    surfaces: xcb,xlib,wayland device: 1 type: integrated-gpu name: AMD Radeon
    Graphics (RADV RENOIR) driver: mesa radv v: 24.0.2-manjaro1.1
    device-ID: 1002:1638 surfaces: xcb,xlib,wayland
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt, snd_sof_amd_vangogh, snd_sof_amd_acp63 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.8.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: off tools: pw-cli
  Server-4: PulseAudio v: 17.0 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:4 chip-ID: 13d3:3563
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 3.19 TiB used: 1.69 TiB (53.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 38.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Samsung model: MZVLQ512HBLU-00B00
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: FXM7201Q temp: 33.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EAVS-00D7B1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 1.75 scheme: MBR
  ID-1: / raw-size: 453.69 GiB size: 453.69 GiB (100.00%)
    used: 99.81 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:9
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 28.6 MiB (11.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:7
  ID-3: /home raw-size: 453.69 GiB size: 453.69 GiB (100.00%)
    used: 99.81 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:9
  ID-4: /var/log raw-size: 453.69 GiB size: 453.69 GiB (100.00%)
    used: 99.81 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 64.1 C mobo: 38.0 C gpu: amdgpu temp: 51.0 C
  Fan Speeds (rpm): cpu: 0
  Memory: total: 16 GiB note: est. available: 15.03 GiB used: 6.59 GiB (43.8%)
  Processes: 467 Power: uptime: 4h 11m states: freeze,mem,disk
    suspend: s2idle wakeups: 5 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 5.96 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1728 pm: pacman pkgs: 1691 libs: 532 tools: gnome-software,pamac
    pm: flatpak pkgs: 37 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.33

And below is a dmesg where ‘suspend’ appears. You can see a couple sample attempts at suspend @ times 255 and 573.

sudo dmesg | grep suspend                                                                                               
[    0.316981] Low-power S0 idle used by default for system suspend
[    2.909741] nvme 0000:04:00.0: platform quirk: setting simple suspend
[    2.909745] nvme 0000:05:00.0: platform quirk: setting simple suspend
[  255.529080] PM: suspend entry (s2idle)
[  255.653479] printk: Suspending console(s) (use no_console_suspend to debug)
[  255.668234] queueing ieee80211 work while going to suspend
[  258.817967] PM: suspend exit
[  572.930307] PM: suspend entry (s2idle)
[  573.052969] printk: Suspending console(s) (use no_console_suspend to debug)
[  573.062257] queueing ieee80211 work while going to suspend
[  576.838544] PM: suspend exit

Is there any other info/log that would be helpful?

And this is the latest lead I’ve been following (the others have been weeks/months ago so I don’t have them in front of me):

cat /proc/acpi/wakeup                                                                                                        ✔ 
Device	S-state	  Status   Sysfs node
GPP0	  S4	*enabled pci:0000:00:01.1
GPP1	  S4	*disabled
GP17	  S4	*enabled  pci:0000:00:08.1

Some people had seen success suspending after setting any enabled status to disabled. I had to the two there but changing them to disabled did not help.

Hi @Scoobin,

Have you tried with a different kernel? If not, I suggest you do. My suspend also gave issues, albeit I think not the same one, on all kernels. Until 6.1, and It’ll be supported for quite some time still:

4th SLTS release (which CIP[23] is planning[17] to support until August 2033)

Linux kernel version history - Wikipedia

So my suggestion would be trying that, version 6.1, especially since you mentioned it used to work in the past.

Hey @Mirdarthos, yes today I tried 6.6, 6.7 and 6.8 kernels.

OK I’ve found the cause for my situation. While reading this and the guy talked about shutting his laptop lid for suspend and I realised I don’t do that since I use an external screen. So I pulled the USB-C (DP) plug on my exertnal monitor and thus suspend was able to work properly.

So that’s the cause, now I just need to find a fix to be able to suspend without unplugging my external monitor. This is my current lead, from the link I mentioned above.

systemd-inhibit --list --mode=block                                                                               ✔  6m 58s  
WHO UID  USER PID  COMM            WHAT                                                     WHY                                            >
sam 1000 sam  1947 gsd-power       handle-lid-switch                                        External monitor attached or configuration chan>
sam 1000 sam  1942 gsd-media-keys  handle-power-key:handle-suspend-key:handle-hibernate-key GNOME handling keypresses                      >
sam 1000 sam  1695 gnome-session-b shutdown                                                 user session inhibited                         >

3 inhibitors listed.

I suggest 6.1, as previously mentioned, just for giggles.


You could try this for troubleshooting:

I see you’re using zswap (which is fine) but, do also you have sufficient swap space defined to cater for hibernation, for example?

See zswap in the ArchWiki for more information, if needed. Cheers.

I might give this a go for testing purposes, but there are efficiency gains in 6.6 that I’m attached to. :slight_smile:

EDIT: @Mirdarthos OK no luck with 6.1. I assume it was working in the past because prior to that point I didn’t have an external monitor and was just using the built-in one.

Testing from that link you provided came back empty.

ls /sys/bus/i*c/devices/*/power/wakeup                                                                                     
zsh: no matches found: /sys/bus/i*c/devices/*/power/wakeup

I think so, according to this. But I don’t know why it’s reading my RAM as 15.3GB.

               total        used        free      shared  buff/cache   available
Mem:           15391        5783        5143         179        4968        9608
Swap:          16383        2459       13924
Total:         31775        8242       19068