System can't detect Wi-Fi hardware (Intel AX 210)

Hello! I’m new to Linux! I decided to finally make the switch after two catastrophic issues with Windows finally pushed me into changing my main OS. I’m still setting things up (I’m a week into using Manjaro), but I’ve had a particular hiccup with connecting to wifi.

It was firstly on my laptop (Toshiba Satellite with a i7-5500U). It had a Intel AX 210 wifi adapter installed, as the adapter included with the system was seemingly failing to work properly. On Windows 10, this adapter worked just fine after drivers were installed. I’ve installed Manjaro to my laptop first to test things out and to play around with it before installing it onto my main desktop. Everything worked as expected, save for that. The current version of Manjaro I am running is Ornara 21.0.4 with Linux kernel 5.10.34. I went to look at Intel’s adapter support site to see if there was a driver or software I needed to install, but from what it seems, the 210 adapter has driver support built into the kernel (for versions 5.10+ specifically)

My desktop also has a wireless adapter installed internally (Intel AX 200, used primarily for bluetooth). This one works as expected upon installing Manjaro, no issues or set-up necessary. I’ve swapped the two adapters between systems, so that my laptop can connect via wifi again, but that leaves me without bluetooth connectivity on my desktop. Interestingly enough, the bluetooth menu on my taskbar keeps popping in and out. As to why, I have no clue.

It’s not as big of a necessity for it to be working ASAP, especially since the AX 200 is working fine in my laptop, but any help would be appreciated!

There are open bug reports:

Wrong report, that’s a duplicate. It’s been fixed with linux-firmware 20210426.r1905.fa0efef-1.


Oh lovely! Thanks for the link, I’ll go and update my firmware now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.