Syncronise time in terminal

I using the computer through RDP . Date & Time is locked and the unlock button is disabled for some reason, even though the user is a “sudo” user. The system time is wrong, so I want synchronise it or enable automatic synchronisation in terminal. Is that possible?

Hi @kingofmanjar0,

I suspect you’re looking for the timedatectl command.

$ timedatectl --help
timedatectl [OPTIONS...] COMMAND ...

Query or change system time and date settings.

status                   Show current time settings
show                     Show properties of systemd-timedated
set-time TIME            Set system time
set-timezone ZONE        Set system time zone
list-timezones           Show known time zones
set-local-rtc BOOL       Control whether RTC is in local time
set-ntp BOOL             Enable or disable network time synchronization

systemd-timesyncd Commands:
timesync-status          Show status of systemd-timesyncd
show-timesync            Show properties of systemd-timesyncd

-h --help                Show this help message
--version             Show package version
--no-pager            Do not pipe output into a pager
--no-ask-password     Do not prompt for password
-H --host=[USER@]HOST    Operate on remote host
-M --machine=CONTAINER   Operate on local container
--adjust-system-clock Adjust system clock when changing local RTC mode
--monitor             Monitor status of systemd-timesyncd
-p --property=NAME       Show only properties by this name
-a --all                 Show all properties, including empty ones
--value               When showing properties, only print the value

See the timedatectl(1) man page for details.

Hope this helps!

Have you tried setting the time from the Manjaro Settings Manager instead?

1 Like

Manjaro Setting’s time was not disabled and setting it worked (it popped up the sudo dialogue). I wonder why Gnome Setting’s time option was disabled.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.