Symlinks within local website

I am a new user of Manjaro having the following issue:
I have a huge collection of images that I cannot/do not want to store on my harddisk. They are on a external device. I need to reach these pics in a local webpage.
Currently, I have done that by creating a symlink from the local web server to the external device directory containing the images. It is perfect with Ubuntu.
Now, I want to do the same in Manjaro, but, it does not work. It seems that a server on Manjaro can’t make use of symlinks, even on the same device.
Is there a workaround to this problem? Or is that not possible at all?
Thanks in advance.

Does this solve your issue?

Maybe rather a permission issue? Did you check if the owner/group http can actually read these files?

Have you already tried to use a bind-mount instead of a symlink ?

Hi megavolt,
I checked permissions and ownerships but… not on the external device. In fact, after having set /run/media/user to 755, it works. Thank you for your advice. Sorry, my mistake!
This seemed to me that it would have been the same issue as I observed when trying to settled web page files in my home directory. I created a symlink in /srv/html towards a directory under /home/user. I do not see the pages in the web browser. Then I created a /www directory where I direct the symlinks: of course it works. Nevertheless, I would prefer to have the web pages files in my home directory. Is that possible?
Thanks again.

Hi fasto
As you can read in my reply to megavolt, I experimented the same issue. Then, I settled my web files in a /www directory - directly at the root and I symlinked this from my home directory. It works. I would better like to have the files directly in my home directory.

Does putting them in your home directory, symlinking, and fixing the permissions not work?

No, it does not…

Why not? The important part is “fixing permissions”. By default the home folder is only accessible by your user. Just open your Home for everyone and it will work.

Sorry, I did never come to the idea that the home/user directory should also be set to 755. My mistake! It works now…
Anyway, thanks a lot to all of you to have taken some of your time for answering this stupid question.
Best wishes.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.