Switching between audio outputs

Hi all,

I have a couple of issues with “Sound” on Gnome:

  1. When I plug my wired headphone in, the sound system does not switch to it automatically. Similarly when I unplug the headphone I usually have to go to the sound panel and change the output back to the speakers. Shouldn’t this be automatic? Is there a way to see what’s preventing automatic switching?

  2. I have no idea what are some of these devices:

  • My Yeti microphone doesn’t have an S/PDIF output – not sure what is that item in the list. Why does it appear in this list (item 5)? Also it has a microphone icon but it is listed in the output devices and not input devices. Shouldn’t the icon be either USB or Speaker?

  • Similarly I don’t think the headphone output channel of the Yeti microphone has two “No Bass Boost” and “Base Boost” modes and I was curious why are they showing in the list? (items 6 and 7)

  • My speakers are not USB – I have connected them to my PC using a 3.5mm to dual RCA cable. Why is it listed as USB?

  • In general the names for items 1 to 4 don’t make any sense and are not descriptive enough.

Is there a way to make the item names more meaningful and disable some items completely so that they don’t appear in the list?

The Yeti microphone has a built-in Analog to Digital Converter and audio is sent to system via USB using S/PDIF (in this case 2 channels uncompressed PCM audio)

I am not certain what Gnome DE is showing in your screenshot but I think they are likely to be outputs available in PulseAudio

please post response to

pacmd list-cards

Audio sink outputs in PulseAudio can be disabled by changing the card Profile to output only or ‘Off’
Gnome DE controls may not allow access to profile settings but they are accessible in the Configuration tab of Pulseaudio Volume Control - pavucontrol --tab=5

Output Devices tab of ‘pavucontrol --tab=3’ can allow user to rename devices ,
but only if PulseAudio has a module loaded module-device-manager
I do not think Gnome loads this module by default

please post response to this command to confirm what modules are loaded

pactl list short modules
1 Like