Switched from Kubuntu to manjaro KDE, it is noticabely slower.

What are the best ways to speed up KDE on manjaro without disabling compositing or blur, with Nvidia drivers?

I have no idea why it is slower, it should be faster being that this is more up-to-date and has the latest drivers.

Be more specific what slower means to you. System start, opening applications, moving windows? Also some information about your computer might help.

2 Likes

Just generally everything, the ui feels noticeably slower and more janky. I have an i7 8700 with a gtx 1070 ti and 16 gigs of ram, booting off of an SSD.

output of

 inxi -Fxxxz
System:    Host: hackerman-01 Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Dell product: XPS 8930 v: 1.0.10 serial: <filter> Chassis: type: 3 serial: <filter> 
           Mobo: Dell model: 0DF42J v: A00 serial: <filter> UEFI: Dell v: 1.0.10 date: 05/17/2018 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76632 
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 801 6: 800 7: 801 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e92 
           Device-2: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Dell driver: nvidia v: 430.14 bus ID: 01:00.0 
           chip ID: 10de:1b82 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 1440x900~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: e000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell driver: alx v: kernel port: d000 
           bus ID: 04:00.0 chip ID: 1969:e0a1 
           IF: enp4s0 state: down mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-8:4 chip ID: 0cf3:e009 
Drives:    Local Storage: total: 3.87 TiB used: 23.82 GiB (0.6%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV256G NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: AADA4105 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC28 scheme: GPT 
           ID-3: /dev/sdc type: USB vendor: Seagate model: BUP Slim BL size: 1.82 TiB serial: <filter> rev: 0108 scheme: GPT 
Partition: ID-1: / size: 224.77 GiB used: 23.82 GiB (10.6%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
Info:      Processes: 255 Uptime: 6m Memory: 15.38 GiB used: 1.86 GiB (12.1%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           clang: 8.0.0 Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34

well
do you want performance or battery life ?

I don't care about battery life, its a desktop. Here is an example of the sort of jank I am talking about; https://drive.google.com/open?id=1V3QO5ELmnmaDWFV_ogC7J9EkmtyCe2aP

I already went through nvidia settings and set force composistion to true.

well there are many things wrong with default manjaro for a desktop as its made for battery life.
so with desktop you dont get to use full potential
to get performance
1.you can try setting cpu governor to performance.
2.uninstall tlp.
3.setup zram.
4.set swappiness to 5
5.vm.cache pressure to 50
6.enable haveged

https://wiki.archlinux.org/index.php/Improving_performance

2 Likes

or
if dont wanna bother about setting every performance tweaks yourself.
you can try manjarowish kde spin it has all the performance tweaks setup from start.

Where do I adjust cpu governor and zram and vm cache and haveged, and what is tlp?. I already did swapiness

Also, on uninstalling TLP, my fan just went to max and isnt spinning down. EDIT: Disregard this, it went away

tlp is for thinkpads to save battery power.
dont need this on desktop it does more harm than good.
to enable haveged

systemctl enable haveged

to set cpu governor to performance.
edit /etc/default/cpupower
and uncomment and edit
governor=ondemand
to governer=performance
then

systemctl enable cpupower
2 Likes

Ok, done all those things. Will they 'stick' between reboots? and what is zram and vm cache?

they persist across reboot

Also if you preserved your home you could have configs that are incompatable.
Also if this is a new install its likely that baloo/indexing is happening.
Also are you up to date?
Also have you checked if there is anything running taking resources ? (such as by looking at htop)

also btw you arent using nvidia drivers by default - if you installed bumblebee for your optimus setup you are using intel (and call nvidia when needed like using primusrun)

Its up to you if thats how you want it to work.

1 Like

Have you checked compositing settings and animations' speed?

I have and set them to a faster speed as I am used to, and set force composition. But that's it. How do I fix not usi g nvidia drivers by default @cscs?

disable intel gpu from bios.

It doesn't show up in Bios. I have a dell XPS 8930.

well explore all options in bios especially named "video"
as far as I know most of desktop computer bios has option to have set video to auto, intel , Nvidia.

Forum kindly sponsored by