Switch to screen started not to work

Hello everyone,

I’ve been experiencing issues with the “Switch to Desktop” shortcuts in KDE Plasma, which were working perfectly until a recent update. Currently, my system is running KDE Plasma version 6.0.5 on the 6.6.32-1-MANJARO kernel.

I found a similar issue discussed here for older versions:

There is no “Active screen follows mouse” setting there.

Has anyone else experienced this with KDE Plasma 6.0.5, or has a potential solution been identified?

Is your problem with switch to screen or switch to desktop? They are different things.

If the problem is that they’re not working at all then that’s probably because shortcut settings got lost in the Plasma 5 → 6 update. Go to System Settings → Keyboard → Shortcuts → KWin and set them up again. I just tested with switch to next/previous desktop set to Alt+F5 and Alt+F6 and it works for me.

If that’s not it then explain exactly what issues you’re having.

1 Like

Hello MrLavender,
My issue concerns switching screens on my LCD monitors using KDE Plasma. I have three monitors. Although my old shortcuts are still available, I tried using new ones without any change in the outcome.

I’m attempting to achieve the following: when I press a shortcut, such as Alt+F5, I want the keyboard focus to transfer from an active window on my first monitor to a window on the second monitor.

Shortcut Settings

Window Behaviour settings

Seems to be a known bug that has recently been fixed. I guess it will be in the Plasma 6.0.6 release whenever that happens.

https://bugs.kde.org/show_bug.cgi?id=482865

https://bugs.kde.org/show_bug.cgi?id=484902

EDIT Actually it looks like the next release is going to be Plasma 6.1.

2 Likes