Switch to Intel 13 Gen graphic card can not get into desktop environment

Thanks a lot for spending/wasting your time reading through this post.

I have successfully installed a dual-boot system (win11 & Manjaro) and used it for several months on my PC with Intel 13900K and Nvidia 1650s without any problem.

But today I sent the NV card to producers for fixing, so I had to switch to the Intel Graphic card for temporary use. Then I plugged the display cable into the DP port on the motherboard. It had no problem getting into the Win11 system. But when I tried to launch Manjaro, after showing the Manjaro loading icon, the screen became completely blank.

I have tried my best to search the internet but haven’t found any solutions for it. Here is what I have tried at the current stage:

Launch by the installation USB (live CD?), but it also cannot get into the installation system interface (very strange, I have successfully used it to install Manjaro several months ago). The screen stuck at the following command line (same results for the open-source driver and proprietary driver):

[ OK ] Reached target Graphical Interface

At that point, I searched several posts and was suggested to double-check the secure boot and BIOS UEFI. Since the only thing I have done is unplug the monitor cable from NV card DP to motherboard DP, and the system performed well before, I personally believe it was not caused by such a BIOS setting issue.

Launch Manjaro and press ctrl + alt + F2 to enter TTY, using the following command to check:

$ mwhd -li
> installed PCI config:
name              version        freedriver       type
video-nvidia    2023.03.23         false          PCI
video-linux     2018.05.04         true           PCI

$ mwhd -i
> 0000:00:02. (0300:8086:a780) Display controller Intel Corporation:
name                version       freedriver    type
video-linux         2018.05.04    true           PCI
video-modesetting   2020.10.13    true           PCI
video-vesa          2017.03.13    true           PCI

The automatic detecter chose the video-linux → still black screen
Manually uninstall video-linux and install video-modesetting → still black screen

Though I could temporarily use Win11 to wait for the NV card back, I am still curious about if any solutions I could do to use Manjaro on the Intel Driver, which should be not a problem, at least easier than the NV card…

Please let me know if any additional information that I could provide for figuring this out.