Switch to built-in GPU from Nvidia

I had previously configured proprietary drivers and using nvidia to render graphics and now my GPU card is damaged.

I want to change the configuration and use inbuilt configuration instead of the nvidia GPU.

Things I can’t do right now

  • provide system info, as I am using my nvme ssd on different system through live usb + external casing
  • purchase new gpu, the gpu is soldered as I am using laptop.

Things I can provide: Since I am able to access my ssd from different system (manjaro-chroot), I can provide you the config files to help me fix this issue.

1 Like

post the output of

inxi --admin --verbosity=7 --filter --no-host --width

OP mentioned he can’t do that:

However, @tbhaxor, can you access the drive on a Linux machine, somehow?


a Good idea might also be to check the BIOS/UEFI and disable it there. In fact, I’d suggest that before you go on.

Edit #2:

If you can disable in BIOS/UEFI, then you an disable it, ensure the Intel one is enabled, boot and enter a live environment, chroot into your installation and undo the steps to use only nvidia.

Edit #3:

Sorry, @Olli, missed this:

@tbhaxor if you disabled the nvidia card in BIOS/UEFIand ensured the Intel one is enabled, then simply uninstalling any and all nvidia-related stuff and undoing any custom configurations should be sufficient.

Update: It is display issue not the GPU one. Display is pitch dark in middle and some smudgy lines on the borders. Also when I restarted the PC (hard reset), I can’t see the BIOS splash screen.

I will get it diagnosed on the computer shop tomorrow.

As sad as it is, at least now you know…

Yes, I can. Also I tried to boot it on different system and can confirm there are two modes Plasms (Wayland) and Plasma (X11).

Well, considering your previous post, I’d say that you have a borked screen. Or screen-laptop connection is borked.

Yeah, i dont put any weight on screen. Maybe its later case

Only one way to be sure…

P.S.: Have you tried an external screen?

Yeah with HDMI, the screen says no signal. I had this compatibility issues earlier so dropped dual screen idea and used the builtin display only.

Then it sounds like a connection…