Suspend issue - Power light does not pulse when sleeping

My system is up to date, but when I put the laptop to sleep the Power light / indictator that should pulse when the system is sleeping remains on. My laptop is a Lenovo IdeaPad 5i Pro (11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz 2.42 GHz).
For information, I have also changed to the LTS Recommended kernel
How can I resolve this issue please? Many thanks.

Check if kernel 6.1 is better for your system.

Check if a newer firmware is available and see the Arch wiki if there is known issues with your system.

Thank you. I tried kernel 6.1.64-1, and looked at the ArchWiki for Lenovo to no avail. Is there anything else I can try? Thank you.

I have no idea :grin: Why is it an issue?

Rather cosmetic I you ask me and not something one cannot live with.

1 Like

I am happy to live with the issue if I am sure the system is sleeping when I ask it to. Is there a way of checking this?


 $ systemctl --help
System Commands:
  is-system-running                   Check whether system is fully running
  default                             Enter system default mode
  rescue                              Enter system rescue mode
  emergency                           Enter system emergency mode
  halt                                Shut down and halt the system
  poweroff                            Shut down and power-off the system
  reboot                              Shut down and reboot the system
  kexec                               Shut down and reboot the system with kexec
  soft-reboot                         Shut down and reboot userspace
  exit [EXIT_CODE]                    Request user instance or container exit
  switch-root [ROOT [INIT]]           Change to a different root file system
  suspend                             Suspend the system
  hibernate                           Hibernate the system
  hybrid-sleep                        Hibernate and suspend the system
  suspend-then-hibernate              Suspend the system, wake after a period of
                                      time, and hibernate

Thank you. I can Suspend the system from running systemctl suspend however, the power light remains on, and does not pulse as it would normally when sleeping. systemctl is-system-running reports running.

Using a 5.15 kernel solved the issue here on a Lenovo Ideapad 14ITL05.
All 6.xx kernels have the problem.

Thank you so much. Installing kernel 5.15 fixed the issue for me, and the power light now pulses when the system is suspended.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.