Suspend issue after last update

Looks like my Macbook Pro keeps coming out of suspend and going a bit nuts on something. Just lost 35% battery during one hour suspend.

What’s the best way to log what it’s doing?

To illustrate this, the system keeps resuming and going back into suspend…

Oct 09 11:06:19 manjarombp systemd-sleep[26951]: System resumed.
Oct 09 11:06:50 manjarombp systemd-sleep[27349]: Suspending system…
Oct 09 11:06:58 manjarombp systemd-sleep[27349]: System resumed.
Oct 09 11:07:29 manjarombp systemd-sleep[27723]: Suspending system…
Oct 09 11:07:37 manjarombp systemd-sleep[27723]: System resumed.
Oct 09 11:08:08 manjarombp systemd-sleep[28091]: Suspending system…
Oct 09 11:08:16 manjarombp systemd-sleep[28091]: System resumed.
Oct 09 11:08:47 manjarombp systemd-sleep[28474]: Suspending system…
Oct 09 11:08:55 manjarombp systemd-sleep[28474]: System resumed.
Oct 09 11:09:26 manjarombp systemd-sleep[28853]: Suspending system…
Oct 09 11:09:34 manjarombp systemd-sleep[28853]: System resumed.
Oct 09 11:10:05 manjarombp systemd-sleep[29258]: Suspending system…
Oct 09 11:10:13 manjarombp systemd-sleep[29258]: System resumed.
Oct 09 11:10:44 manjarombp systemd-sleep[29631]: Suspending system…
Oct 09 11:10:51 manjarombp systemd-sleep[29631]: System resumed.
Oct 09 11:11:22 manjarombp systemd-sleep[30004]: Suspending system…
Oct 09 11:11:30 manjarombp systemd-sleep[30004]: System resumed.
Oct 09 11:12:01 manjarombp systemd-sleep[30379]: Suspending system…
Oct 09 11:12:09 manjarombp systemd-sleep[30379]: System resumed.
Oct 09 11:12:40 manjarombp systemd-sleep[30753]: Suspending system…
Oct 09 11:12:48 manjarombp systemd-sleep[30753]: System resumed.
Oct 09 11:13:19 manjarombp systemd-sleep[31123]: Suspending system…
Oct 09 11:13:27 manjarombp systemd-sleep[31123]: System resumed.
Oct 09 11:13:58 manjarombp systemd-sleep[31525]: Suspending system…
Oct 09 11:14:06 manjarombp systemd-sleep[31525]: System resumed.
Oct 09 11:14:37 manjarombp systemd-sleep[31902]: Suspending system…
Oct 09 11:14:45 manjarombp systemd-sleep[31902]: System resumed.
Oct 09 11:15:16 manjarombp systemd-sleep[32273]: Suspending system…
Oct 09 11:15:24 manjarombp systemd-sleep[32273]: System resumed.
Oct 09 11:15:55 manjarombp systemd-sleep[32652]: Suspending system…
Oct 09 11:16:03 manjarombp systemd-sleep[32652]: System resumed.

When I suspend from the command line, it suspends but also doesn’t want to wake up any more.
Closing the lid suspends but keeps waking up.

It doesn’t do this in other distros (tried Pop_OS and Mint)

Switching off bluetooth or wifi doesn’t make a difference

I’ve been having problems with suspend too, mine is a little different though, for me the suspend works, but when I resume a reboot is initiated and I loose suspend.

I found this FAQ from XFCE.org:

I have put my computer into suspend or hibernate mode, but the computer is not waking up.

This was the subject of many bug reports. Please note that the power manager has nothing to do with these problems, since the kernel is responsible for these tasks. The kernel team is putting a lot of effort into fixing these kind of problems. However, if you still have problems please report a bug to your distributor and hopefully they can contact the kernel team and possibly provide a work-around.

I’ll Try a different kernel and report back if it’s working.


 ██████████████████  ████████     arc
 ██████████████████  ████████     OS: Manjaro 20.1.1 Mikah
 ██████████████████  ████████     Kernel: x86_64 Linux 5.7.19-2-MANJARO
 ██████████████████  ████████     Uptime: 39m
 ████████            ████████     Packages: 1305
 ████████  ████████  ████████     Shell: bash 5.0.18
 ████████  ████████  ████████     Resolution: 2560x1440
 ████████  ████████  ████████     DE: Xfce4
 ████████  ████████  ████████     WM: Compiz
 ████████  ████████  ████████     WM Theme: Matcha-dark-sea
 ████████  ████████  ████████     GTK Theme: Matcha-sea [GTK2]
 ████████  ████████  ████████     Icon Theme: Papirus-Maia
 ████████  ████████  ████████     Font: Noto Sans 10
 ████████  ████████  ████████     Disk: 157G / 227G (73%)
                                  CPU: Intel Core i7-6600U @ 4x 3.4GHz [45.0°C]
                                  GPU: Mesa Intel(R) HD Graphics 520 (SKL GT2)
                                  RAM: 2508MiB / 15906MiB

Switched to 5.4 kernel and suspend is working as expected. You might try a different kernel and see if that fixes your problem.

I tried 5.4 and 5.8
I never had any problem with this until the latest Manjaro update

I think I fixed it (or at least got rid of the symptoms) by creating and enabling a service that writes ACPI codes to /proc/acpi/wakeup to disable, among others, LID0. The lid behaves correctly in any other distro, so I presume there’s a driver issue or something in the latest update that messed up the lid sensor. Opening the lid doesn’t wake the laptop up, but that’s ok because the power button does, of course