Suspend hangs when connected to a thermaltake level 20 gt keyboard

Following this thread: Suspend hangs when connected to a specific usb keyboard
Unfortunately, I need to re-open the issue, as it has reappeared. I have success in disabling the usb device from waking up by utilizing /proc/acpi/wakeup(refer to:, but that is a temporary solution. Within the arch-article, there’s a link to arch forum, where there’s an automation that re-adds those at startup(systemd service) and also a bash script, neither of which conforms to my expectations to be able to do this with a config file. The good news is that I have more control of what my linux system is trying to do…

Edit: a side question - why couldn’t I re-open or even add responses to my old topic? I find it so hard to get used to those new forum interfaces and they seem to prove not functional enough…

This is why… :arrow_down:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

The thread had been marked as solved, and from that moment on, there is a 15-day grace time for still replying to the thread, and this 15-day deadline keeps moving forward in time with every new post still being added to the thread.

However, if no one replies to the thread anymore within 15-days after the last post has been submitted, then the forum engine will automatically close the thread 15 days after the last reply.

So, now there will be two threads for the same issue.
I have some progress, though.
I tried disabling all suspicious usb devices from waking up trough udev config(adding a .rule entry in this directory /etc/udev/rules.d/, refer to: It had partial success. Then I realized there were two hub-entries there. This is the hub I am using and the one integrated into the keyboard, which was supposed to route through the separate cable. Then I went pluging in my phone in there and after a couple of restarts, it stopped hanging. Finally, I re-plugged the keyboard into its own hub, which proved to work ok, since I can still use it for input. The side effect is, that it gets tricked that there is something connected to its hub. I’ll be monitoring it some time (preferably a fortnight ahead) and report back whether I’ve achieved a permanent fix. The sad news is that this keyboard does not quite route its hub separately, despite the thick cable, which is annoying on its own. I planned trimming the hub out anyway, so it may get a “surgery” some time soon. At least I have an idea what to expect when/if I have the hub removed. I hope it does not fall into disturbing my suspend again…