Surfshark VPN connects, but IP adress stays the same

Fellow Manjarees,

I just stumbled across a strange phenomen: When I connect to a VPN server (surfshark), no matter wether I use their app (which uses wireguard) or via a manual connection (openvpn), the app as well as the network manager states “connected”, however, my external (!) IP does not change.
The author of this thread seems to have had the same issue:

I am running Manjaro stable, KDE, Kernel 6.7.7-1.

Any ideas, what might cause this issue?

Thank you kindly for your help.

PS: The open-vpn connections did a couple of weeks ago, when I last checked (connecting AND rerouting IP traffic)

Hi @Knecker,

While I’ve never done this and have no experience with it, I can tell you that it sounds like a routing problem.

You mentioned WireGuard, so I suggest checking your settings according to:

Hope this helps!

1 Like

Then you are not connected - recheck your credentials and configuration.

The problem is: The system says otherwise! The connection does NOT fail. When using the internal openvpn connection from the network manager, it connects and also shows “connected”. When using the surfshark app (which connects via wireguard instead of openvpn) it also connects and states “connected”.
There is also no problem with the credentials, when using wrong credentials for example, the connection fails.

In short: It connects, but somehow does not route traffic through the VPN. It only seems to be connected to the VPN (no errors), but still uses my internet providers IP for traffic.

Hi Mirdarthos, thank you very much.

I have gathered new information:

  1. The problem must somehow be connected to surfshark. I also have a VPN connection to my university here (utilizing open-vpn), which does connect AND changes the IP accordingly.
  2. You are absolutely correct, there must be a routing problem.

Unfortunately, the article you provided is a bit too techie for a noob like me. But I also don’t think I could find the answer in manually setting up wireguard. The problem occurs when using
a) The surfshark-gui packages from manjaro repositories (which connects via wireguard)
b) The KDE Network Manager GUI (using an open-vpn connection).

Also (as stated above), the problem only persists with VPN connections to servers from surfshark. I am quite puzzled on this one - as it seems not to be a general local misconfiguration.

Some of us might best be called Manjaroos
Especially those from Australia. :wink:

1 Like

And unfortunately, as I said, I do not know anything more, since I’ve never used it, only read up on it relatively quickly.

Manually setting up Wireguard will allow better control over the routing table, if I’m not mistaken.

And you mentioned that the university VPN uses OpenVPN and works fine, but the Surfshark one doesn’t and uses Wireguard. I know Surfshark provides the OpenVPN protocol as well, so have you tried that? If it does work, it’s quite obviously the routing set up when connecting to the Wireguard VPN and you could inspect how it’s done for the one VPN and copy the method to use on the other VPN.

Still - that is your configuration somewhere causing it - I advise you to check it - again.

Surfshark client works exactly as advertised

PoC screenshot


So, I’ve found a solution by consulting the support.

This is a WARNING for all surfshark users: When IPv6 is enabled, the VPN (which will connect via IPv4 as today) will sucessfully connect, but your traffic will run through the IPv6 from your provider (unprotected, not routed over the VPN server) nevertheless…

The solution is too either shoot birds with cannons and disable IPv6 altogether in /etc/default/grub by adding ipv6.disable to GRUB_CMDLINE_LINUX_DEFAULT , for example:
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"
Do not forget to invoke $ sudo update-grub afterwards.

Another (better way imho) would be to disable IPV6 in System Settings for the specific connection. Be sure to reconnect once, after disabling it.

Thanks to everyone for your input!

Just as I said - a local configuration.

If your provider provides IPv6 - still it is a local configuration issue - just as I said.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.