Surface Pro 3 Wifi

Hi there,

tldr: Surface Pro 3i5 - make sure linux-firmware-marvell is installed for wifi to work

Updated today, including kernel updates, but after reboot no Wifi!
Device: Surface Pro 3 i5
Updates (from pamac.log):
[2022-02-08T20:07:43+1100] [ALPM] installed linux-firmware-whence (20220119.0c6a7b3-3)
[2022-02-08T20:07:44+1100] [ALPM] upgraded linux-firmware (20211216.f682ecb-1 → 20220119.0c6a7b3-3)
[2022-02-08T20:07:46+1100] [ALPM] upgraded linux510 (5.10.93-1 → 5.10.96-1)
[2022-02-08T20:07:53+1100] [ALPM] upgraded linux510-headers (5.10.93-1 → 5.10.96-1)
[2022-02-08T20:07:54+1100] [ALPM] upgraded linux516 (5.16.2-1 → 5.16.5-1)
[2022-02-08T20:07:58+1100] [ALPM] upgraded linux516-headers (5.16.2-1 → 5.16.5-1)

A bit of investigation with dmesg turns out that I was missing the directory /usr/lib/firmware/mrvl

As a test I reverted, and copied the firmware from git before trying the upgrade again:

git clone git://

Confirmed the error still occurred so copied the directory into the correct place, rebooted again and everything works!

sudo cp -R ~/Downloads/linux-firmware/mrvl /usr/lib/firmware/.

So, problem identified and workaround applied, but then the question of how do I prevent this in the future?

A quick check in the pamac gui for “marvell” has the “linux-firmware-marvell” package in the official repositories. I guess it’s a case of “maybe it was included by accident before” and now I need to explicitly include the new package.

Hopefully this helps someone else!


There was a note about marvell and linux-firmware in the last stable update announcement from 05/02. Does it apply to your device?

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic
1 Like


i had the same problem with a surface pro 2 after last stable update.
after installing linux-firmware-marvell everything works fine again :slight_smile:

thanks for the hint

Maybe someone can assist. I’m pretty new to linux in all it’s forms. I try it every couple of years, get frustrated, and give up. I have a Surface Pro 3 and a Surface Book and I’ve installed the latest Manjaro(gnome) distros on each - not dual booting, but completely. On neither machine is a network device even detected. PopOS works fine, but I really had my sights set on Manjaro for some reason.

I’m trying these pamac commands to install marvell firmware, but I get “Error: target not found: linux-firmware-marvell”

Am I having trouble because I’m not online? Other forums I’ve read point to specialized Surface kernels, but I have no idea how to use those and again, it at least seems like I need internet access to do most of the steps that I (think I) understand. Any thoughts?

I just installed Manjaro KDE on a Surface Pro 3 and found out the WiFi doesn’t work OOB. I’m going to try to download that firmware.git file and copy it over to the Surface Pro 3 and run that command, unless it’s advised against. :sweat_smile: I’m kind of new to Linux myself…no better way to learn than to screw up!

1 Like

Update; didn’t work. I might have to get a USB Wi-Fi dongle :roll_eyes:

Got this tp-link USB dongle annnnd…I’m still dead in the water. Very annoying. The Q&A section of Amazon reviews showed someone asking if it worked on Linux and someone stated it did. This guy installed Pop!_OS and Wi-Fi seems to be working fine. I feel like the installers should have drivers for every network device possible, considering the immediate updates required.

UPDATE; This GitHub page was suggested by someone in another thread and I decided on the Alfa AWUS036ACHM 802.11ac. It worked flawlessly—actually, it only seemed to detect and connect to my 2.4GHz network. I was able to update the system and installed the ‘linux-firmware-marvell’ package thru pacman and now the Surface Pro 3 internal Wi-Fi works—2.4 and 5GHz.

1 Like