Support plug-and-play for thunderbolt docking station

TL;DR: Could plug-and-play support for thunderbolt devices be built into Manjaro? Similar to Windows, a dialog could appear where the user is informed of the device’s presence and asked whether it should be authorized.

So I spent quite a while to get my new docking station to work. It was a simple command that did the trick, so I figure that it might be possible to include support for this kind of hardware into Manjaro so that it works out of the box.
This is the docking station: Dell Dock WD19
This is my laptop: Lenovo YOGA 720-13IKB. This laptop has two USB-C ports, one of which transmits the video signal, the other one does not.

inxi -MS
System:
  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64
    Desktop: Xfce v: 4.16.0 Distro: Manjaro Linux
Machine:
  Type: Convertible System: LENOVO product: 80X6 v: Lenovo YOGA 720-13IKB
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: 1YCN40WW(V2.07)
    date: 05/25/2018

This was my journey:

  1. Connect the docking station to the video-capable USB-C port. Video output worked, but none of the USB ports of the docking station worked.
  2. Good lord, is the docking station compatible with my laptop? Do some research, find nothing besides “did you connect it to the correct port?”.
  3. Is the docking station broken? Try the docking station with a Dell laptop (Windows) from work. It works. Can I update the firmware or something? Nope.
  4. ■■■■ – it’s my laptop. Do I need a driver or what? Research for the tenth time in your life how to install a driver on Linux. The eternal answer: You don’t.
  5. So is it the OS? Boot the laptop into Windows, which you fortunately still have installed although you never use it. Takes ages because the last time you booted into Windows was nine months ago.
  6. Connect the docking station. It works as expected. Are you ■■■■■■■ kidding me. However I noted that before it worked, some kind of Dell auto-installer popped up where I had to elevatedly confirm that I wanted to use all features of the hardware. Something about thunderbolt security features. Interesting.
  7. Do research on the thunderbolt interface because you apparently don’t know ■■■■ about anything and learn that thunderbolt devices need to be authorized or some ■■■■ in order to work. Find bolt. The events are overturning now.
  8. boltctl → Shows the docking station as connected but not authorized, also gives the device’s UUID. [heavy breathing]
  9. boltctl enroll <uuid>
  10. Profit.

This journey took me about two hours! Please note that I am not complaining – I secretly love tinkering with my system and I like that I learned what I learned during this journey. However, anybody who wants things to just work would have given up very early and might have ended up using a different OS in order to use their precious new docking station.

3 Likes

I thought it would be more complicated XD
Thanks, now I know how to use thunderbolt.

Interesting, my WD19 worked out of the box. At least from the OS viewpoint (I had to tinker some BIOS configs on my XPS).

Thanks for leaving tips to others, though.